The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.
History of vulnerabilities analyzed by Vigil@nce:

vulnerability announce 12852

WordPress: SQL injection of Grand Flagallery

Synthesis of the vulnerability

An attacker can use a SQL injection in Grand Flagallery of WordPress, in order to read or alter data.
Impacted products: WordPress Plugins ~ not comprehensive.
Severity: 2/4.
Consequences: data reading, data creation/edition, data deletion.
Provenance: internet client.
Creation date: 22/05/2013.
Identifiers: BID-60184, VIGILANCE-VUL-12852.

Description of the vulnerability

The Grand Flagallery plugin displays multimedia documents.

However, user's data are directly inserted in a SQL query.

An attacker can therefore use a SQL injection in Grand Flagallery of WordPress, in order to read or alter data.
Full Vigil@nce bulletin... (Free trial)

vulnerability alert CVE-2013-3551

OTRS: ticket reading via AgentTicketPhone

Synthesis of the vulnerability

An authenticated attacker can change the url of the ticket split mechanism of OTRS, in order to read tickets of other users, which can contain sensitive information.
Impacted products: Debian, openSUSE, OTRS Help Desk.
Severity: 2/4.
Consequences: data reading.
Provenance: user account.
Creation date: 22/05/2013.
Identifiers: BID-60117, CVE-2013-3551, DSA-2696-1, MDVSA-2013:188, openSUSE-SU-2013:1338-1, VIGILANCE-VUL-12851.

Description of the vulnerability

Users can split an OTRS ticket in two tickets.

The AgentTicketPhone.pm module is called during the ticket creation. However, it does not check if the user is allowed to read the ticket before splitting it.

An authenticated attacker can therefore change the url of the ticket split mechanism of OTRS, in order to read tickets of other users, which can contain sensitive information.
Full Vigil@nce bulletin... (Free trial)

vulnerability 12850

WordPress: SQL injection of ProPlayer

Synthesis of the vulnerability

An attacker can use a SQL injection in ProPlayer of WordPress, in order to read or alter data.
Impacted products: WordPress Plugins ~ not comprehensive.
Severity: 2/4.
Consequences: data reading, data creation/edition, data deletion.
Provenance: document.
Creation date: 21/05/2013.
Identifiers: BID-60019, VIGILANCE-VUL-12850.

Description of the vulnerability

The ProPlayer plugin displays multimedia documents.

However, user's data are directly inserted in a SQL query.

An attacker can therefore use a SQL injection in ProPlayer of WordPress, in order to read or alter data.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability note CVE-2013-3660 CVE-2013-3661

Windows: privilege escalation via pprFlattenRec

Synthesis of the vulnerability

An attacker can use a PATHRECORD object, to corrupt the memory of the Windows win32k!EPATHOBJ::pprFlattenRec() function, in order to escalate his privileges.
Impacted products: Windows 2003, Windows 2008 R0, Windows 2008 R2, Windows 2012, Windows 7, Windows 8, Windows RT, Windows Vista, Windows XP.
Severity: 2/4.
Consequences: administrator access/rights.
Provenance: document.
Number of vulnerabilities in this bulletin: 2.
Creation date: 21/05/2013.
Identifiers: 2850851, BID-60051, BID-60159, CVE-2013-3660, CVE-2013-3661, MS13-053, VIGILANCE-VUL-12849.

Description of the vulnerability

The EPATHOBJ::pprFlattenRec() function of the win32k.sys driver uses an internal PATHRECORD object, which is a double chained list.

However, one of the pointers is not initialized before being used.

An attacker can therefore use a PATHRECORD object, to corrupt the memory of the Windows win32k!EPATHOBJ::pprFlattenRec() function, in order to escalate his privileges.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability bulletin 12848

Joomla: SQL injection of S5 Clan Roster

Synthesis of the vulnerability

An attacker can use a SQL injection in S5 Clan Roster of Joomla, in order to read or alter data.
Impacted products: Joomla Extensions ~ not comprehensive.
Severity: 2/4.
Consequences: data reading, data creation/edition, data deletion.
Provenance: document.
Creation date: 21/05/2013.
Identifiers: BID-59993, VIGILANCE-VUL-12848.

Description of the vulnerability

The S5 Clan Roster (com_s5clanroster) extension is used to manage games.

However, user's data are directly inserted in a SQL query.

An attacker can therefore use a SQL injection in S5 Clan Roster of Joomla, in order to read or alter data.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability announce CVE-2013-3258

WordPress: Cross Site Request Forgery of Digg Digg

Synthesis of the vulnerability

An attacker can trigger a Cross Site Request Forgery in Digg Digg of WordPress, in order to force the victim to perform operations.
Impacted products: WordPress Plugins ~ not comprehensive.
Severity: 2/4.
Consequences: user access/rights.
Provenance: document.
Creation date: 21/05/2013.
Identifiers: BID-60046, CVE-2013-3258, VIGILANCE-VUL-12847.

Description of the vulnerability

The Digg Digg plugin adds buttons.

However, the origin of queries is not checked. They can for example originate from an image included in an HTML document.

An attacker can therefore trigger a Cross Site Request Forgery in Digg Digg of WordPress, in order to force the victim to perform operations.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability CVE-2013-2072

Xen: buffer overflow of pyxc_vcpu_setaffinity

Synthesis of the vulnerability

When the system uses the Python libxc Toolstack, a guest administrator can generate a buffer overflow in pyxc_vcpu_setaffinity() of Xen, in order to trigger a denial of service, and possibly to execute code.
Impacted products: Debian, Fedora, openSUSE, SUSE Linux Enterprise Desktop, SLES, Unix (platform) ~ not comprehensive.
Severity: 2/4.
Consequences: administrator access/rights.
Provenance: user shell.
Creation date: 21/05/2013.
Identifiers: BID-59982, CERTA-2013-AVI-316, CVE-2013-2072, DSA-3041-1, FEDORA-2013-8571, FEDORA-2013-8590, openSUSE-SU-2013:1392-1, openSUSE-SU-2013:1404-1, SUSE-SU-2013:1075-1, SUSE-SU-2014:0446-1, VIGILANCE-VUL-12845, XSA-56.

Description of the vulnerability

Xen can be configured with a Python libxc, xl or xapi Toolstack.

The pyxc_vcpu_setaffinity() function of tools/python/xen/lowlevel/xc/xc.c defines the affinity of a VCPU. However, this function does not check if the VCPU number is larger than the size of the array storing information.

When the system uses the Python libxc Toolstack, a guest administrator can therefore generate a buffer overflow in pyxc_vcpu_setaffinity() of Xen, in order to trigger a denial of service, and possibly to execute code.
Full Vigil@nce bulletin... (Free trial)

vulnerability note CVE-2013-2486 CVE-2013-2487 CVE-2013-3555

Wireshark: multiple vulnerabilities

Synthesis of the vulnerability

Several vulnerabilities of Wireshark can be used by a remote attacker to create a denial of service.
Impacted products: Debian, Fedora, openSUSE, Solaris, RHEL, Wireshark.
Severity: 2/4.
Consequences: denial of service on service.
Provenance: intranet client.
Number of vulnerabilities in this bulletin: 9.
Creation date: 21/05/2013.
Identifiers: BID-59992, BID-59994, BID-59995, BID-59996, BID-59997, BID-59998, BID-59999, BID-6000, BID-60000, BID-60001, BID-60002, BID-60021, CERTA-2013-AVI-543, CVE-2013-2486, CVE-2013-2487, CVE-2013-3555, CVE-2013-3556, CVE-2013-3557, CVE-2013-3558, CVE-2013-3559, CVE-2013-3560, CVE-2013-3561, CVE-2013-3562, DLA-497-1, DSA-2700-1, FEDORA-2013-17635, MDVSA-2013:172, openSUSE-SU-2013:0848-1, openSUSE-SU-2013:0911-1, openSUSE-SU-2013:0947-1, openSUSE-SU-2013:1084-1, openSUSE-SU-2013:1086-1, RHSA-2013:1569-02, RHSA-2014:0341-01, VIGILANCE-VUL-12844, wnpa-sec-2013-23, wnpa-sec-2013-24, wnpa-sec-2013-25, wnpa-sec-2013-26, wnpa-sec-2013-27, wnpa-sec-2013-28, wnpa-sec-2013-29, wnpa-sec-2013-30, wnpa-sec-2013-31.

Description of the vulnerability

The Wireshark program captures and displays network packets. Protocols are decoded by dissectors. They are impacted by several vulnerabilities.

An attacker can generate an infinite loop in the RELOAD dissector, in order to trigger a denial of service. [severity:1/4; CVE-2013-2486, CVE-2013-2487, wnpa-sec-2013-23]

An attacker can stop the GTPv2 dissector, in order to trigger a denial of service. [severity:2/4; BID-59992, CVE-2013-3555, wnpa-sec-2013-24]

An attacker can stop the ASN.1 BER dissector, in order to trigger a denial of service. [severity:2/4; BID-59997, BID-60021, CVE-2013-3556, CVE-2013-3557, wnpa-sec-2013-25]

An attacker can stop the PPP CCP dissector, in order to trigger a denial of service. [severity:2/4; BID-59994, CVE-2013-3558, wnpa-sec-2013-26]

An attacker can stop the DCP ETSI dissector, in order to trigger a denial of service. [severity:1/4; BID-59995, BID-6000, BID-60000, CVE-2013-3559, wnpa-sec-2013-27]

An attacker can stop the MPEG DSM-CC dissector, in order to trigger a denial of service. [severity:2/4; BID-59999, CVE-2013-3560, wnpa-sec-2013-28]

An attacker can stop the Websocket dissector, in order to trigger a denial of service. [severity:2/4; BID-59996, BID-59998, CVE-2013-3561, CVE-2013-3562, wnpa-sec-2013-29]

An attacker can generate an infinite loop in the MySQL dissector, in order to trigger a denial of service. [severity:2/4; BID-60001, CVE-2013-3561, wnpa-sec-2013-30]

An attacker can generate an infinite loop in the ETCH dissector, in order to trigger a denial of service. [severity:1/4; BID-60002, CVE-2013-3561, wnpa-sec-2013-31]
Full Vigil@nce bulletin... (Free trial)

vulnerability bulletin 12843

Bintec R, X: infinite loop of A-MPDU

Synthesis of the vulnerability

An attacker can send a malformed A-MPDU (Aggregated MAC Protocol Data Unit) packet, to generate an infinite loop in Bintec R/X, in order to trigger a denial of service.
Impacted products: Bintec R, Bintec X.
Severity: 2/4.
Consequences: denial of service on server.
Provenance: intranet client.
Creation date: 17/05/2013.
Identifiers: VIGILANCE-VUL-12843.

Description of the vulnerability

An attacker can send a malformed A-MPDU (Aggregated MAC Protocol Data Unit) packet, to generate an infinite loop in Bintec R/X, in order to trigger a denial of service.
Full Vigil@nce bulletin... (Free trial)

vulnerability announce CVE-2013-2108 CVE-2013-2109

WordPress: Cross Site Request Forgery of WP CleanFix

Synthesis of the vulnerability

An attacker can trigger a Cross Site Request Forgery in WP CleanFix of WordPress, in order to force the victim to perform operations.
Impacted products: WordPress Plugins ~ not comprehensive.
Severity: 2/4.
Consequences: user access/rights.
Provenance: internet client.
Number of vulnerabilities in this bulletin: 2.
Creation date: 17/05/2013.
Identifiers: BID-59940, BID-59983, CVE-2013-2108, CVE-2013-2109, VIGILANCE-VUL-12842.

Description of the vulnerability

The WP CleanFix plugin checks and repairs a blog.

However, the origin of queries is not checked. They can for example originate from an image included in an HTML document.

An attacker can therefore trigger a Cross Site Request Forgery in WP CleanFix of WordPress, in order to force the victim to perform operations.
Full Vigil@nce bulletin... (Free trial)

Previous page   Next page

Direct access to page 1 21 41 61 81 101 121 141 161 181 201 221 241 261 281 301 321 341 361 381 401 421 441 461 481 501 521 541 561 581 601 621 641 661 681 701 721 741 761 781 801 821 841 861 881 901 921 941 961 981 1001 1021 1041 1061 1081 1101 1121 1141 1161 1181 1201 1211 1212 1213 1214 1215 1216 1217 1218 1219 1220 1221 1222 1223 1224 1225 1226 1227 1228 1229 1230 1231 1241 1261 1281 1301 1321 1341 1361 1381 1401 1421 1441 1461 1481 1501 1521 1541 1561 1581 1601 1621 1641 1661 1681 1701 1721 1741 1761 1781 1801 1821 1841 1861 1881 1901 1921 1941 1961 1981 2001 2021 2041 2061 2081 2101 2121 2141 2161 2181 2201 2221 2241 2261 2281 2301 2321 2341 2361 2381 2401 2421 2441 2461 2481 2501 2521 2541 2561 2581 2601 2621 2641 2661 2681 2701 2721 2741 2761 2781 2801 2819