The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.
History of vulnerabilities analyzed by Vigil@nce:

vulnerability alert CVE-2014-3921

WordPress Simple Popup Images: Cross Site Scripting

Synthesis of the vulnerability

An attacker can trigger a Cross Site Scripting of WordPress Simple Popup Images, in order to execute JavaScript code in the context of the web site.
Impacted products: WordPress Plugins ~ not comprehensive.
Severity: 2/4.
Consequences: client access/rights.
Provenance: document.
Creation date: 22/05/2014.
Identifiers: CVE-2014-3921, VIGILANCE-VUL-14791.

Description of the vulnerability

The Simple Popup Images plugin can be installed on WordPress.

However, it does not filter received data before inserting them in generated HTML documents.

An attacker can therefore trigger a Cross Site Scripting of WordPress Simple Popup Images, in order to execute JavaScript code in the context of the web site.
Full Vigil@nce bulletin... (Free trial)

vulnerability CVE-2014-1770

Internet Explorer 8: use after free via CMarkup

Synthesis of the vulnerability

An attacker can use a freed memory area in the CMarkup class of Internet Explorer, in order to trigger a denial of service, and possibly to execute code.
Impacted products: IE, Windows 2003, Windows 2008 R0, Windows 2008 R2, Windows 2012, Windows 7, Windows 8, Windows RT, Windows Vista.
Severity: 3/4.
Consequences: user access/rights, denial of service on client.
Provenance: document.
Creation date: 22/05/2014.
Identifiers: 2969262, CVE-2014-1770, MS14-035, VIGILANCE-VUL-14790, VU#239151, ZDI-14-140.

Description of the vulnerability

The Internet Explorer product uses the MSHTML!CMarkup class when a web document is processed.

The CollectGarbage() method can free a pointer allocated by CMarkup::CreateInitialMarkup(), however it is then reused.

An attacker can therefore use a freed memory area in the CMarkup class of Internet Explorer, in order to trigger a denial of service, and possibly to execute code.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability note CVE-2010-4207 CVE-2012-5881 CVE-2014-3941

TYPO3: multiple vulnerabilities

Synthesis of the vulnerability

An attacker can use several vulnerabilities of TYPO3.
Impacted products: Debian, openSUSE, openSUSE Leap, TYPO3 Core.
Severity: 2/4.
Consequences: user access/rights, client access/rights, data reading.
Provenance: internet client.
Number of vulnerabilities in this bulletin: 7.
Creation date: 22/05/2014.
Identifiers: CERTFR-2014-AVI-240, CVE-2010-4207, CVE-2012-5881, CVE-2014-3941, CVE-2014-3942, CVE-2014-3943, CVE-2014-3944, CVE-2014-3945, CVE-2014-3946, DSA-2942-1, openSUSE-SU-2014:0813-1, openSUSE-SU-2016:2025-1, openSUSE-SU-2016:2114-1, TYPO3-CORE-SA-2014-001, VIGILANCE-VUL-14789.

Description of the vulnerability

Several vulnerabilities were announced in TYPO3.

An attacker can change the HTTP Host header, in order to inject data in scripts using $_SERVER['HTTP_HOST']. [severity:2/4; CVE-2014-3941]

An attacker can unserialize data, in order to execute code. [severity:2/4; CVE-2014-3942]

An attacker can trigger a Cross Site Scripting in Backend, in order to execute JavaScript code in the context of the web site. [severity:2/4; CVE-2014-3943]

An attacker can trigger a Cross Site Scripting in ExtJS, in order to execute JavaScript code in the context of the web site. [severity:2/4; CVE-2010-4207, CVE-2012-5881]

An authenticated attacker can indefinitely renew his session. [severity:2/4; CVE-2014-3944]

Hashed passwords are not always salted. [severity:1/4; CVE-2014-3945]

An attacker, who is member of another group, can obtain sensitive information. [severity:2/4; CVE-2014-3946]
Full Vigil@nce bulletin... (Free trial)

computer vulnerability bulletin CVE-2014-3947 CVE-2014-3948

TYPO3 powermail: two vulnerabilities

Synthesis of the vulnerability

An attacker can use several vulnerabilities of TYPO3 powermail.
Impacted products: TYPO3 Extensions ~ not comprehensive.
Severity: 3/4.
Consequences: user access/rights, client access/rights.
Provenance: internet client.
Number of vulnerabilities in this bulletin: 2.
Creation date: 22/05/2014.
Identifiers: CVE-2014-3947, CVE-2014-3948, TYPO3-EXT-SA-2014-007, VIGILANCE-VUL-14788.

Description of the vulnerability

Several vulnerabilities were announced in TYPO3 powermail.

An attacker can upload a malicious file, in order for example to upload a Trojan. [severity:3/4; CVE-2014-3947]

An attacker can trigger a Cross Site Scripting, in order to execute JavaScript code in the context of the web site. [severity:2/4; CVE-2014-3948]
Full Vigil@nce bulletin... (Free trial)

computer vulnerability announce 14787

Drupal: information disclosure via Site Reports

Synthesis of the vulnerability

An attacker, who has the "access site reports" or "View site reports" permission of Drupal, can obtain sensitive information.
Impacted products: Drupal Core.
Severity: 1/4.
Consequences: data reading.
Provenance: user account.
Creation date: 22/05/2014.
Identifiers: DRUPAL-PSA-2014-002, VIGILANCE-VUL-14787.

Description of the vulnerability

The Drupal product logs its events.

The "access site reports" or "View site reports" permission allows users to see logs. However, these logs may contain sensitive information, such as passwords.

An attacker, who has the "access site reports" or "View site reports" permission of Drupal, can therefore obtain sensitive information.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability alert 14786

Drupal Password Policy: bypassing the policy

Synthesis of the vulnerability

An attacker can continue to use the same password with Drupal Password Policy, in order to bypass the security policy.
Impacted products: Drupal Modules ~ not comprehensive.
Severity: 1/4.
Consequences: user access/rights.
Provenance: user account.
Creation date: 22/05/2014.
Identifiers: DRUPAL-SA-CONTRIB-2014-057, VIGILANCE-VUL-14786.

Description of the vulnerability

The Password Policy module can be installed on Drupal.

However, unlike expressed by the policy, a user can choose several times the same password.

An attacker can therefore continue to use the same password with Drupal Password Policy, in order to bypass the security policy.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability 14785

Drupal Commerce Moneris: information disclosure

Synthesis of the vulnerability

An attacker can access to the database of Drupal Commerce Moneris, in order to obtain sensitive information.
Impacted products: Drupal Modules ~ not comprehensive.
Severity: 2/4.
Consequences: data reading.
Provenance: internet client.
Creation date: 22/05/2014.
Identifiers: DRUPAL-SA-CONTRIB-2014-056, VIGILANCE-VUL-14785.

Description of the vulnerability

The Commerce Moneris module can be installed on Drupal.

However, credit card information are stored in clear text in the database.

An attacker can therefore access to the database of Drupal Commerce Moneris, in order to obtain sensitive information.
Full Vigil@nce bulletin... (Free trial)

vulnerability note 14784

Drupal Require Login: information disclosure

Synthesis of the vulnerability

An attacker can use Drupal Require Login, in order to obtain sensitive information.
Impacted products: Drupal Modules ~ not comprehensive.
Severity: 2/4.
Consequences: data reading.
Provenance: internet client.
Creation date: 22/05/2014.
Identifiers: DRUPAL-SA-CONTRIB-2014-055, VIGILANCE-VUL-14784.

Description of the vulnerability

The Require Login module can be installed on Drupal.

However, an attacker can bypass access restrictions to data.

An attacker can therefore use Drupal Require Login, in order to obtain sensitive information.
Full Vigil@nce bulletin... (Free trial)

vulnerability bulletin 14783

Drupal Views: information disclosure

Synthesis of the vulnerability

An attacker can use Drupal Views, in order to obtain sensitive information.
Impacted products: Drupal Modules ~ not comprehensive, Fedora.
Severity: 2/4.
Consequences: data reading.
Provenance: user account.
Creation date: 22/05/2014.
Identifiers: DRUPAL-SA-CONTRIB-2014-054, FEDORA-2014-6597, FEDORA-2014-6615, VIGILANCE-VUL-14783.

Description of the vulnerability

The Views module can be installed on Drupal.

However, an attacker can bypass access restrictions to data.

An attacker can therefore use Drupal Views, in order to obtain sensitive information.
Full Vigil@nce bulletin... (Free trial)

vulnerability announce CVE-2014-2607

HP Operations Manager i: privilege escalation

Synthesis of the vulnerability

An authenticated attacker can use a vulnerability of HP Operations Manager i, in order to escalate his privileges.
Impacted products: HP Operations.
Severity: 2/4.
Consequences: administrator access/rights, privileged access/rights.
Provenance: user account.
Creation date: 22/05/2014.
Identifiers: c04296442, CVE-2014-2607, HPSBMU03042, VIGILANCE-VUL-14782.

Description of the vulnerability

An authenticated attacker can use a vulnerability of HP Operations Manager i, in order to escalate his privileges.
Full Vigil@nce bulletin... (Free trial)

Previous page   Next page

Direct access to page 1 21 41 61 81 101 121 141 161 181 201 221 241 261 281 301 321 341 361 381 401 421 441 461 481 501 521 541 561 581 601 621 641 661 681 701 721 741 761 781 801 821 841 861 881 901 921 941 961 981 1001 1021 1041 1061 1081 1101 1121 1141 1161 1181 1201 1221 1241 1261 1281 1301 1321 1341 1361 1381 1383 1384 1385 1386 1387 1388 1389 1390 1391 1392 1393 1394 1395 1396 1397 1398 1399 1400 1401 1402 1403 1421 1441 1461 1481 1501 1521 1541 1561 1581 1601 1621 1641 1661 1681 1701 1721 1741 1761 1781 1801 1821 1841 1861 1881 1901 1921 1941 1961 1981 2001 2021 2041 2061 2081 2101 2121 2141 2161 2181 2201 2221 2241 2261 2281 2301 2321 2341 2361 2381 2401 2421 2441 2461 2481 2501 2521 2541 2561 2581 2601 2621 2641 2661 2681 2701 2721 2741 2761 2781 2801 2821 2824