The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.
History of vulnerabilities analyzed by Vigil@nce:

security vulnerability CVE-2014-3494

kdelibs: man-in-the-middle via POP3 kioslave

Synthesis of the vulnerability

An attacker can act as a man-in-the-middle between KMail and a POP3 server, in order to read or alter data.
Severity: 2/4.
Creation date: 19/06/2014.
Identifiers: CVE-2014-3494, FEDORA-2014-7572, FEDORA-2014-7579, openSUSE-SU-2015:0573-1, VIGILANCE-VUL-14918.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The KMail/KIO product uses the kdelibs library.

The POP3 kioslave is used by KMail to connect to a POP3 messaging server. However, if the certificate of the secured POP3 server changed, the error does not flow to KMail, so the user is not warned.

An attacker can therefore act as a man-in-the-middle between KMail and a POP3 server, in order to read or alter data.
Full Vigil@nce bulletin... (Free trial)

threat alert 14917

Drupal Password Policy: multiple vulnerabilities

Synthesis of the vulnerability

An attacker can use several vulnerabilities of Drupal Password Policy.
Severity: 2/4.
Number of vulnerabilities in this bulletin: 3.
Creation date: 19/06/2014.
Identifiers: DRUPAL-SA-CONTRIB-2014-062, VIGILANCE-VUL-14917.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

Several vulnerabilities were announced in Drupal Password Policy.

After a migration to version 7, when user's password has to be renewed, a user can reuse his old password. [severity:2/4]

After a migration to version 7, MD5 hashed passwords are kept indefinitely, which may ease a future brute force. [severity:1/4]

When the user_save() function is called before the user has changed his password, he is not forced to change it anymore. [severity:2/4]
Full Vigil@nce bulletin... (Free trial)

weakness announce 14916

Drupal Custom Meta: Cross Site Scripting

Synthesis of the vulnerability

An attacker can trigger a Cross Site Scripting of Drupal Custom Meta, in order to execute JavaScript code in the context of the web site.
Severity: 2/4.
Creation date: 19/06/2014.
Identifiers: DRUPAL-SA-CONTRIB-2014-065, VIGILANCE-VUL-14916.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The Custom Meta module can be installed on Drupal.

However, it does not filter received data before inserting them in generated HTML documents.

An attacker can therefore trigger a Cross Site Scripting of Drupal Custom Meta, in order to execute JavaScript code in the context of the web site.
Full Vigil@nce bulletin... (Free trial)

cybersecurity weakness 14915

Drupal Course: information disclosure

Synthesis of the vulnerability

An attacker can use Drupal Course, in order to obtain sensitive information.
Severity: 2/4.
Creation date: 19/06/2014.
Identifiers: DRUPAL-SA-CONTRIB-2014-064, VIGILANCE-VUL-14915.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The Course module can be installed on Drupal.

However, an attacker can bypass access restrictions to form data.

An attacker can therefore use Drupal Course, in order to obtain sensitive information.
Full Vigil@nce bulletin... (Free trial)

cybersecurity announce CVE-2014-4505

Drupal Easy Breadcrumb: Cross Site Scripting

Synthesis of the vulnerability

An attacker can trigger a Cross Site Scripting of Drupal Easy Breadcrumb, in order to execute JavaScript code in the context of the web site.
Severity: 2/4.
Creation date: 19/06/2014.
Identifiers: CVE-2014-4505, DRUPAL-SA-CONTRIB-2014-063, VIGILANCE-VUL-14914.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The Easy Breadcrumb module can be installed on Drupal.

However, it does not filter received data before inserting them in generated HTML documents.

An attacker can therefore trigger a Cross Site Scripting of Drupal Easy Breadcrumb, in order to execute JavaScript code in the context of the web site.
Full Vigil@nce bulletin... (Free trial)

computer threat alert 14913

Drupal VideoWhisper Webcam Plugins: Cross Site Scripting

Synthesis of the vulnerability

An attacker can trigger a Cross Site Scripting of Drupal VideoWhisper Webcam Plugins, in order to execute JavaScript code in the context of the web site.
Severity: 2/4.
Creation date: 19/06/2014.
Identifiers: DRUPAL-SA-CONTRIB-2014-061, VIGILANCE-VUL-14913.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The VideoWhisper Webcam Plugins module can be installed on Drupal.

However, it does not filter received data before inserting them in generated HTML documents.

An attacker can therefore trigger a Cross Site Scripting of Drupal VideoWhisper Webcam Plugins, in order to execute JavaScript code in the context of the web site.
Full Vigil@nce bulletin... (Free trial)

cybersecurity bulletin CVE-2014-4171

Linux kernel: denial of service via Punch Hole

Synthesis of the vulnerability

A local attacker can use a mmap() during a Punch Hole by the Linux kernel, in order to trigger a denial of service.
Severity: 1/4.
Creation date: 18/06/2014.
Identifiers: CERTFR-2014-AVI-373, CVE-2014-4171, FEDORA-2014-9010, FEDORA-2014-9142, openSUSE-SU-2014:0957-1, openSUSE-SU-2014:0985-1, openSUSE-SU-2014:1669-1, openSUSE-SU-2014:1677-1, RHSA-2014:1318-01, RHSA-2015:0102-01, SUSE-SU-2014:1316-1, SUSE-SU-2014:1319-1, USN-2334-1, USN-2335-1, USN-2336-1, USN-2337-1, VIGILANCE-VUL-14912.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

A part of an allocated area (XFS, ext4, Btrfs, tmpfs) can be freed (Punch Hole) with:
  madvise(..., MADV_REMOVE);
  fallocate(fd, FALLOC_FL_PUNCH_HOLE, ...);

However, if a user has a mmap() surrounding the area to free, the kernel locks.

A local attacker can therefore use a mmap() during a Punch Hole by the Linux kernel, in order to trigger a denial of service.
Full Vigil@nce bulletin... (Free trial)

security bulletin CVE-2014-4163

WordPress Featured Comments: Cross Site Request Forgery

Synthesis of the vulnerability

An attacker can trigger a Cross Site Request Forgery of WordPress Featured Comments, in order to force the victim to perform operations.
Severity: 2/4.
Creation date: 18/06/2014.
Identifiers: CVE-2014-4163, VIGILANCE-VUL-14911.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The Featured Comments plugin can be installed on WordPress.

However, the origin of queries is not checked. They can for example originate from an image included in an HTML document.

An attacker can therefore trigger a Cross Site Request Forgery of WordPress Featured Comments, in order to force the victim to perform operations.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability alert CVE-2014-0477

Perl: denial of service via Email-Address

Synthesis of the vulnerability

An attacker can send a special email address to a program using the Email::Address module of Perl, in order to trigger a denial of service.
Severity: 2/4.
Creation date: 18/06/2014.
Identifiers: CVE-2014-0477, DSA-2969-1, FEDORA-2014-7610, FEDORA-2014-7613, MDVSA-2014:192, openSUSE-SU-2014:1328-1, VIGILANCE-VUL-14910.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The Perl Email::Address module analyzes email addresses.

An email can for example use the following header:
  To: "Jean Dupont" <jd@example.com>
However, if the text between quote characters is empty, the parse() method of Email::Address consumes too many resources.

An attacker can therefore send a special email address to a program using the Email::Address module of Perl, in order to trigger a denial of service.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability announce CVE-2014-4157

Linux kernel: privilege escalation via PR_SET_SECCOMP on MIPS

Synthesis of the vulnerability

An attacker can call functions which should be forbidden by PR_SET_SECCOMP of the Linux kernel on MIPS, in order to escalate his privileges.
Severity: 2/4.
Creation date: 18/06/2014.
Identifiers: 751417, CVE-2014-4157, VIGILANCE-VUL-14909.
Full Vigil@nce bulletin... (Free trial)

Description of the vulnerability

The PR_SET_SECCOMP operation of prctl() indicates to limit the allowed system calls for the current thread:
 - SECCOMP_MODE_STRICT : only read(), write(), _exit() and sigreturn() are allowed.
 - SECCOMP_MODE_FILTER : a list of allowed calls is defined.

However, on a MIPS processor, PR_SET_SECCOMP is not checked. All system calls are thus allowed.

An attacker can therefore call functions which should be forbidden by PR_SET_SECCOMP of the Linux kernel on MIPS, in order to escalate his privileges.
Full Vigil@nce bulletin... (Free trial)

   

Direct access to page 1 21 41 61 81 101 121 141 161 181 201 221 241 261 281 301 321 341 361 381 401 421 441 461 481 501 521 541 561 581 601 621 641 661 681 701 721 741 761 781 801 821 841 861 881 901 921 941 961 981 1001 1021 1041 1061 1081 1101 1121 1141 1161 1181 1201 1221 1241 1261 1281 1301 1321 1341 1361 1381 1396 1397 1398 1399 1400 1401 1402 1403 1404 1406 1408 1409 1410 1411 1412 1413 1414 1415 1416 1421 1441 1461 1481 1501 1521 1541 1561 1581 1601 1621 1641 1661 1681 1701 1721 1741 1761 1781 1801 1821 1841 1861 1881 1901 1921 1941 1961 1981 2001 2021 2041 2061 2081 2101 2121 2141 2161 2181 2201 2221 2241 2261 2281 2301 2321 2341 2361 2381 2401 2421 2441 2461 2481 2501 2521 2541 2561 2581 2601 2621 2641 2661 2681 2701 2721 2741 2761 2781 2801 2821 2841 2861 2881 2901 2921 2928