The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.
History of vulnerabilities analyzed by Vigil@nce:

computer vulnerability announce CVE-2014-0118

Apache httpd: denial of service via mod_deflate

Synthesis of the vulnerability

An attacker can send special data to Apache httpd with mod_deflate as an Input Filter, in order to trigger a denial of service.
Impacted products: Apache httpd, Apache httpd Modules ~ not comprehensive, Debian, Fedora, HP-UX, WebSphere AS Traditional, NSMXpress, Solaris, Puppet, RHEL, JBoss EAP by Red Hat, SAS Add-in for Microsoft Office, SAS Analytics Pro, Base SAS Software, SAS Enterprise BI Server, SAS Enterprise Guide, SAS Management Console, SAS OLAP Server, SAS SAS/ACCESS, SAS SAS/AF, SAS SAS/CONNECT, SAS SAS/EIS, SAS SAS/ETS, SAS SAS/FSP, SAS SAS/GRAPH, SAS SAS/IML, SAS SAS/OR, SAS SAS/STAT, SAS SAS/Web Report Studio, Slackware, Ubuntu.
Severity: 2/4.
Consequences: denial of service on server, denial of service on service.
Provenance: internet client.
Creation date: 17/07/2014.
Identifiers: 1690185, 1695392, 7036319, c04686230, c04832246, CERTFR-2015-AVI-286, CVE-2014-0118, DSA-2989-1, FEDORA-2014-8742, FEDORA-2014-9057, HPSBUX03337, HPSBUX03512, JSA10685, MDVSA-2014:142, MDVSA-2015:093, RHSA-2014:0920-01, RHSA-2014:0921-01, RHSA-2014:0922-01, RHSA-2014:1019-01, RHSA-2014:1020-01, RHSA-2014:1021-01, RHSA-2014:1086-01, RHSA-2014:1087-01, RHSA-2014:1088-01, SSA:2014-204-01, SSRT102066, SSRT102254, USN-2299-1, VIGILANCE-VUL-15067.

Description of the vulnerability

The mod_deflate module of Apache httpd compresses/uncompresses data.

The decompression of the HTTP body is for example enabled with:
  <Location /dav-area>
    SetInputFilter DEFLATE
  </Location>

However, in this case, special data lead to the consumption of several resources.

An attacker can therefore send special data to Apache httpd with mod_deflate as an Input Filter, in order to trigger a denial of service.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability alert CVE-2014-0226

Apache httpd: buffer overflow of mod_status

Synthesis of the vulnerability

An attacker can generate a buffer overflow in mod_status of Apache httpd, in order to trigger a denial of service, and possibly to execute code.
Impacted products: Apache httpd, Apache httpd Modules ~ not comprehensive, Debian, Fedora, HP-UX, WebSphere AS Traditional, NSMXpress, openSUSE, Solaris, Puppet, RHEL, JBoss EAP by Red Hat, SAS Add-in for Microsoft Office, SAS Analytics Pro, Base SAS Software, SAS Enterprise BI Server, SAS Enterprise Guide, SAS Management Console, SAS OLAP Server, SAS SAS/ACCESS, SAS SAS/AF, SAS SAS/CONNECT, SAS SAS/EIS, SAS SAS/ETS, SAS SAS/FSP, SAS SAS/GRAPH, SAS SAS/IML, SAS SAS/OR, SAS SAS/STAT, SAS SAS/Web Report Studio, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity: 2/4.
Consequences: privileged access/rights, user access/rights, denial of service on service.
Provenance: intranet client.
Creation date: 17/07/2014.
Identifiers: 1690185, 1695392, 7036319, c04686230, c04832246, CERTFR-2015-AVI-286, CVE-2014-0226, DSA-2989-1, FEDORA-2014-8742, FEDORA-2014-9057, HPSBUX03337, HPSBUX03512, JSA10685, MDVSA-2014:142, MDVSA-2015:093, openSUSE-SU-2014:0969-1, openSUSE-SU-2014:1044-1, openSUSE-SU-2014:1045-1, openSUSE-SU-2014:1647-1, RHSA-2014:0920-01, RHSA-2014:0921-01, RHSA-2014:0922-01, RHSA-2014:1019-01, RHSA-2014:1020-01, RHSA-2014:1021-01, RHSA-2014:1086-01, RHSA-2014:1087-01, RHSA-2014:1088-01, SSA:2014-204-01, SSRT102066, SSRT102254, SUSE-SU-2014:0967-1, SUSE-SU-2014:1080-1, SUSE-SU-2014:1081-1, SUSE-SU-2014:1082-1, USN-2299-1, VIGILANCE-VUL-15066, ZDI-14-236.

Description of the vulnerability

The mod_status module can be enabled on Apache httpd:
  <Location /server-status>
    SetHandler server-status
    Require host example.com
  </Location>
Its access is usually restricted.

The ScoreBoard of httpd stores information related to current processes and sessions. The mod_status module reads the ScoreBoard. However, data are not correctly synchronized: when two queries are sent on /server-status and a normal page, the size of data (client, request, vhost) can be inconsistent.

An attacker can therefore generate a buffer overflow in mod_status of Apache httpd, in order to trigger a denial of service, and possibly to execute code.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability CVE-2014-4960

Joomla com_youtubegallery: SQL injection

Synthesis of the vulnerability

An attacker can use a SQL injection of Joomla com_youtubegallery, in order to read or alter data.
Impacted products: Joomla Extensions ~ not comprehensive.
Severity: 2/4.
Consequences: data reading, data creation/edition, data deletion.
Provenance: internet client.
Creation date: 17/07/2014.
Identifiers: CVE-2014-4960, VIGILANCE-VUL-15065.

Description of the vulnerability

The Joomla com_youtubegallery product uses a database.

However, user's data are directly inserted in a SQL query.

An attacker can therefore use a SQL injection of Joomla com_youtubegallery, in order to read or alter data.
Full Vigil@nce bulletin... (Free trial)

vulnerability note CVE-2014-3323

Cisco Unified Contact Center Enterprise: directory traversal

Synthesis of the vulnerability

An attacker can traverse directories of Cisco Unified Contact Center Enterprise, in order to read a file in the service root path.
Impacted products: Cisco Unified CCX.
Severity: 2/4.
Consequences: data reading.
Provenance: internet client.
Creation date: 17/07/2014.
Identifiers: CSCun25262, CVE-2014-3323, VIGILANCE-VUL-15064.

Description of the vulnerability

The Cisco Unified Contact Center Enterprise product offers a web service.

However, user's data are directly inserted in an access path. Sequences such as "/.." can thus be used to go in the upper directory.

An attacker can therefore traverse directories of Cisco Unified Contact Center Enterprise, in order to read a file in the service root path.
Full Vigil@nce bulletin... (Free trial)

vulnerability bulletin CVE-2014-4943

Linux kernel: privilege escalation via SOL_PPPOL2TP

Synthesis of the vulnerability

An attacker can use a L2TP socket when the Linux kernel is compiled with SOL_PPPOL2TP, in order to escalate his privileges.
Impacted products: Debian, Fedora, Linux, openSUSE, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity: 2/4.
Consequences: administrator access/rights, privileged access/rights.
Provenance: user shell.
Creation date: 17/07/2014.
Identifiers: CERTFR-2014-AVI-325, CERTFR-2014-AVI-332, CVE-2014-4943, DSA-2992-1, FEDORA-2014-8487, FEDORA-2014-8519, MDVSA-2014:155, openSUSE-SU-2014:1669-1, openSUSE-SU-2014:1677-1, openSUSE-SU-2015:0566-1, RHSA-2014:0923-01, RHSA-2014:0924-01, RHSA-2014:0925-01, RHSA-2014:1025-01, SUSE-SU-2014:1138-1, SUSE-SU-2014:1316-1, SUSE-SU-2014:1319-1, SUSE-SU-2015:0481-1, USN-2281-1, USN-2282-1, USN-2283-1, USN-2284-1, USN-2285-1, USN-2286-1, USN-2287-1, USN-2288-1, USN-2289-1, USN-2290-1, VIGILANCE-VUL-15063.

Description of the vulnerability

The Linux kernel can be configured with CONFIG_PPPOL2TP (PPP over L2TP).

However, the pppol2tp_setsockopt() function modifies UDP data structures instead of L2TP.

An attacker can therefore use a L2TP socket when the Linux kernel is compiled with SOL_PPPOL2TP, in order to escalate his privileges.
Full Vigil@nce bulletin... (Free trial)

vulnerability announce CVE-2014-9156

Drupal FileField: information disclosure

Synthesis of the vulnerability

An attacker can use Drupal FileField, in order to obtain sensitive information.
Impacted products: Drupal Modules ~ not comprehensive.
Severity: 2/4.
Consequences: data reading.
Provenance: user account.
Creation date: 17/07/2014.
Identifiers: CVE-2014-9156, DRUPAL-SA-CONTRIB-2014-071, VIGILANCE-VUL-15062.

Description of the vulnerability

The FileField module can be installed on Drupal.

However, an attacker can bypass access restrictions to files.

An attacker can therefore use Drupal FileField, in order to obtain sensitive information.
Full Vigil@nce bulletin... (Free trial)

vulnerability alert 15061

Drupal Password Policy: multiple vulnerabilities

Synthesis of the vulnerability

An attacker can use several vulnerabilities of Drupal Password Policy.
Impacted products: Drupal Modules ~ not comprehensive.
Severity: 1/4.
Consequences: user access/rights, data reading.
Provenance: user shell.
Number of vulnerabilities in this bulletin: 2.
Creation date: 17/07/2014.
Identifiers: DRUPAL-SA-CONTRIB-2014-070, VIGILANCE-VUL-15061.

Description of the vulnerability

Several vulnerabilities were announced in the Drupal Password Policy module.

An authenticated attacker can use the Password Change Tab module, to bypass the constraint which forces users to not reuse an old password. [severity:1/4]

When the administrator forces a user to change his password, he is not forced to do it. [severity:1/4]
Full Vigil@nce bulletin... (Free trial)

vulnerability CVE-2014-5019 CVE-2014-5020 CVE-2014-5021

Drupal: multiple vulnerabilities

Synthesis of the vulnerability

An attacker can use several vulnerabilities of Drupal.
Impacted products: Debian, Drupal Core, Fedora.
Severity: 2/4.
Consequences: client access/rights, data reading, denial of service on service.
Provenance: document.
Number of vulnerabilities in this bulletin: 4.
Creation date: 17/07/2014.
Identifiers: CERTFR-2014-AVI-326, CVE-2014-5019, CVE-2014-5020, CVE-2014-5021, CVE-2014-5022, DRUPAL-SA-CORE-2014-003, DSA-2983-1, FEDORA-2014-8485, FEDORA-2014-8488, FEDORA-2014-8495, FEDORA-2014-8515, MDVSA-2015:181, VIGILANCE-VUL-15060.

Description of the vulnerability

Several vulnerabilities were announced in Drupal.

An attacker can use an HTTP Host header, in order to trigger a denial of service. [severity:2/4; CVE-2014-5019]

An attacker can see an attachment via the File Module, in order to obtain sensitive information. [severity:2/4; CVE-2014-5020]

An attacker can trigger a Cross Site Scripting in Form API, in order to execute JavaScript code in the context of the web site. [severity:2/4; CVE-2014-5021]

An attacker can trigger a Cross Site Scripting in Ajax System, in order to execute JavaScript code in the context of the web site. [severity:2/4; CVE-2014-5022]
Full Vigil@nce bulletin... (Free trial)

computer vulnerability note CVE-2014-0198 CVE-2014-0224 CVE-2014-3251

Puppet Enterprise: multiple vulnerabilities

Synthesis of the vulnerability

An attacker can use several vulnerabilities of Puppet Enterprise.
Impacted products: Puppet.
Severity: 2/4.
Consequences: user access/rights, data reading, data creation/edition.
Provenance: intranet client.
Number of vulnerabilities in this bulletin: 3.
Creation date: 16/07/2014.
Identifiers: CVE-2014-0198, CVE-2014-0224, CVE-2014-3251, VIGILANCE-VUL-15059.

Description of the vulnerability

Several vulnerabilities were announced in Puppet Enterprise.

An attacker can dereference a NULL pointer in OpenSSL applications using SSL_MODE_RELEASE_BUFFERS, in order to trigger a denial of service (VIGILANCE-VUL-14690). [severity:2/4; CVE-2014-0198]

An attacker can act as a man in the middle between a client and a server using OpenSSL, in order to read or alter exchanged data (VIGILANCE-VUL-14844). [severity:2/4; CVE-2014-0224]

When Mcollective is configured with the aes_security plugin, an attacker can use a malicious certificate, in order to establish a connection. [severity:2/4; CVE-2014-3251]
Full Vigil@nce bulletin... (Free trial)

computer vulnerability bulletin CVE-2014-4931

Symfony: directory traversal via _locale

Synthesis of the vulnerability

An attacker can traverse directories via _locale of Symfony, in order to read a file outside the service root path.
Impacted products: Symfony.
Severity: 2/4.
Consequences: data reading.
Provenance: internet client.
Creation date: 16/07/2014.
Identifiers: CVE-2014-4931, VIGILANCE-VUL-15058.

Description of the vulnerability

The Symfony product offers a web service.

However, the Locale (language) sent by users is directly inserted in an access path such as "/app/{_locale}/". Sequences such as "/.." can thus be used to go in the upper directory.

An attacker can therefore traverse directories via _locale of Symfony, in order to read a file outside the service root path.
Full Vigil@nce bulletin... (Free trial)

Previous page   Next page

Direct access to page 1 21 41 61 81 101 121 141 161 181 201 221 241 261 281 301 321 341 361 381 401 421 441 461 481 501 521 541 561 581 601 621 641 661 681 701 721 741 761 781 801 821 841 861 881 901 921 941 961 981 1001 1021 1041 1061 1081 1101 1121 1141 1161 1181 1201 1221 1241 1261 1281 1301 1321 1341 1361 1381 1401 1409 1410 1411 1412 1413 1414 1415 1416 1417 1418 1419 1420 1421 1422 1423 1424 1425 1426 1427 1428 1429 1441 1461 1481 1501 1521 1541 1561 1581 1601 1621 1641 1661 1681 1701 1721 1741 1761 1781 1801 1821 1841 1861 1881 1901 1921 1941 1961 1981 2001 2021 2041 2061 2081 2101 2121 2141 2161 2181 2201 2221 2241 2261 2281 2301 2321 2341 2361 2381 2401 2421 2441 2461 2481 2501 2521 2541 2561 2581 2601 2621 2641 2661 2681 2701 2721 2741 2761 2781 2801 2816