The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.
History of vulnerabilities analyzed by Vigil@nce:

computer vulnerability 16195

Perl Gtk2: memory corruption via list_devices

Synthesis of the vulnerability

An attacker can generate a memory corruption in list_devices() of Perl Gtk2, in order to trigger a denial of service, and possibly to execute code.
Impacted products: Fedora, Perl Module ~ not comprehensive.
Severity: 2/4.
Consequences: user access/rights, denial of service on client.
Provenance: document.
Creation date: 16/02/2015.
Identifiers: FEDORA-2015-1733, FEDORA-2015-1762, MDVSA-2015:044, VIGILANCE-VUL-16195.

Description of the vulnerability

The Gtk2 module can be installed with Perl.

However, the Gtk2::Gdk::Display::list_devices() function does not correctly manage its memory.

An attacker can therefore generate a memory corruption in list_devices() of Perl Gtk2, in order to trigger a denial of service, and possibly to execute code.
Full Vigil@nce bulletin... (Free trial)

vulnerability note 16194

libflac: three vulnerabilities

Synthesis of the vulnerability

An attacker can use several vulnerabilities of libflac.
Impacted products: Fedora.
Severity: 2/4.
Consequences: user access/rights, denial of service on client.
Provenance: document.
Number of vulnerabilities in this bulletin: 3.
Creation date: 13/02/2015.
Identifiers: FEDORA-2017-e7f9c23746, FEDORA-2017-f0d976df9e, VIGILANCE-VUL-16194.

Description of the vulnerability

Several vulnerabilities were announced in libflac.

An attacker can generate a buffer overflow in FLAC__stream_encoder_process, in order to trigger a denial of service, and possibly to execute code. [severity:2/4]

An attacker can use EncoderSession_init_encoder, in order to trigger a denial of service. [severity:1/4]

An attacker can generate a buffer overflow in flac__encode_file, in order to trigger a denial of service, and possibly to execute code. [severity:2/4]
Full Vigil@nce bulletin... (Free trial)

vulnerability bulletin CVE-2015-1593

Linux kernel: weakness of ASLR via randomize_stack_top

Synthesis of the vulnerability

An attacker can use a weakness of ASLR of the Linux kernel, in order to more easily guess a stack address.
Impacted products: Debian, BIG-IP Hardware, TMOS, Fedora, Linux, openSUSE, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity: 1/4.
Consequences: data reading.
Provenance: user account.
Creation date: 13/02/2015.
Identifiers: CERTFR-2015-AVI-140, CERTFR-2015-AVI-144, CERTFR-2015-AVI-263, CVE-2015-1593, DSA-3170-1, FEDORA-2015-3011, FEDORA-2015-3594, openSUSE-SU-2015:0713-1, openSUSE-SU-2015:0714-1, RHSA-2015:1137-01, RHSA-2015:1138-01, RHSA-2015:1139-01, RHSA-2015:1221-01, SOL17244, SUSE-SU-2015:0581-1, SUSE-SU-2015:0736-1, USN-2560-1, USN-2561-1, USN-2562-1, USN-2563-1, USN-2564-1, USN-2565-1, VIGILANCE-VUL-16193.

Description of the vulnerability

Systems use ASLR in order to randomize memory addresses used by programs and libraries.

The randomize_stack_top() function of the fs/binfmt_elf.c file randomizes stack addresses. However, it uses a 32 bit integer to store 34 bits, so two bits of random are lost. An attacker thus have four more chances to bypass ASLR (268 million values, instead of 1 billion).

An attacker can therefore use a weakness of ASLR of the Linux kernel, in order to more easily guess a stack address.
Full Vigil@nce bulletin... (Free trial)

vulnerability announce CVE-2015-8982

glibc: two vulnerabilities of strxfrm

Synthesis of the vulnerability

An attacker can use several vulnerabilities of strxfrm of glibc.
Impacted products: BIG-IP Hardware, TMOS, Ubuntu, Unix (platform) ~ not comprehensive.
Severity: 2/4.
Consequences: user access/rights, denial of service on service.
Provenance: document.
Number of vulnerabilities in this bulletin: 2.
Creation date: 13/02/2015.
Identifiers: CVE-2015-8982, K71877858, SOL16416, USN-3239-1, USN-3239-2, USN-3239-3, VIGILANCE-VUL-16192.

Description of the vulnerability

The strxfrm() function transforms a string using the locale. Two vulnerabilities were announced in strxfrm() of the glibc.

An attacker can generate an integer overflow during the memory size computation, in order to trigger a denial of service, and possibly to execute code. [severity:2/4]

An attacker can generate a stack overflow via alloca(), in order to trigger a denial of service. [severity:1/4]
Full Vigil@nce bulletin... (Free trial)

vulnerability alert CVE-2015-2090

WordPress Survey & Poll: SQL injection

Synthesis of the vulnerability

An attacker can use a SQL injection of WordPress Survey & Poll, in order to read or alter data.
Impacted products: WordPress Plugins ~ not comprehensive.
Severity: 2/4.
Consequences: data reading, data creation/edition, data deletion.
Provenance: internet client.
Creation date: 13/02/2015.
Identifiers: CVE-2015-2090, VIGILANCE-VUL-16191.

Description of the vulnerability

The WordPress Survey & Poll product uses a database.

However, user's data are directly inserted in a SQL query.

An attacker can therefore use a SQL injection of WordPress Survey & Poll, in order to read or alter data.
Full Vigil@nce bulletin... (Free trial)

vulnerability 16190

procmail: two buffer overflows

Synthesis of the vulnerability

An attacker can use several vulnerabilities of procmail.
Impacted products: Unix (platform) ~ not comprehensive.
Severity: 3/4.
Consequences: privileged access/rights, user access/rights.
Provenance: internet client.
Number of vulnerabilities in this bulletin: 2.
Creation date: 13/02/2015.
Identifiers: 769937, VIGILANCE-VUL-16190.

Description of the vulnerability

Several vulnerabilities were announced in procmail.

An attacker can generate a buffer overflow with an address like "<a@example.com,", in order to trigger a denial of service, and possibly to execute code. [severity:3/4]

An attacker can generate a buffer overflow with an address like "<a@example.com\", in order to trigger a denial of service, and possibly to execute code. [severity:3/4]
Full Vigil@nce bulletin... (Free trial)

computer vulnerability note 16189

procmail: file reading via TZ

Synthesis of the vulnerability

A local attacker can set the TZ environment variable before sending an email calling procmail, in order to force the opening of a file, or a denial of service if this file is blocking.
Impacted products: Unix (platform) ~ not comprehensive.
Severity: 1/4.
Consequences: data reading.
Provenance: user shell.
Creation date: 13/02/2015.
Identifiers: CVE-2014-9681-REJECT, VIGILANCE-VUL-16189.

Description of the vulnerability

The procmail program is called to manage received emails.

The procmail program filters environment variables which are potentially dangerous. However, procmail keeps the TZ variable, which can indicate the name of a Time Zone file. The procmail application, linked to the glibc, thus opens this file to analyze its timing information. It can be noted that the content of this file is never returned to the user.

A local attacker can therefore set the TZ environment variable before sending an email calling procmail, in order to force the opening of a file, or a denial of service if this file is blocking.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability bulletin CVE-2015-0268

Xen: denial of service via GICD_SGIR

Synthesis of the vulnerability

An attacker in a guest system can set the GICD_SGIR register on Xen, in order to trigger a denial of service.
Impacted products: Unix (platform) ~ not comprehensive.
Severity: 1/4.
Consequences: denial of service on server, denial of service on service.
Provenance: user shell.
Creation date: 13/02/2015.
Identifiers: CVE-2015-0268, VIGILANCE-VUL-16188, XSA-117.

Description of the vulnerability

The Xen product emulates the ARM GICv2 (Generic Interrupt Controller) component.

The GICD_SGIR.TargetListFilter register can contain 3 values:
 - 0 : GICD_SGI_TARGET_LIST_VAL
 - 1 : GICD_SGI_TARGET_OTHERS_VAL
 - 2 : GICD_SGI_TARGET_SELF_VAL
 - 3 : reserved

However, if a local attacker uses the value 3, the vgic_v2_to_sgi() function calls the macro BUG(), which stops the host system.

An attacker in a guest system can therefore set the GICD_SGIR register on Xen, in order to trigger a denial of service.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability announce CVE-2014-6195

IBM TSM for Mail Data Protection for Domino: restore backup

Synthesis of the vulnerability

An attacker can use IBM TSM for Mail Data Protection for Domino, in order to corrupt an installation.
Impacted products: Tivoli Storage Manager.
Severity: 2/4.
Consequences: data reading, data creation/edition.
Provenance: intranet client.
Creation date: 12/02/2015.
Identifiers: 1695183, CVE-2014-6195, VIGILANCE-VUL-16187.

Description of the vulnerability

The IBM TSM for Mail Data Protection for Domino product offers a Domino Java GUI and Web GUI.

However, an attacker can bypass the authentication, and then restore a backup.

An attacker can therefore use IBM TSM for Mail Data Protection for Domino, in order to corrupt an installation.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability CVE-2015-2065

WordPress Contus Video Gallery: SQL injection

Synthesis of the vulnerability

An attacker can use a SQL injection in WordPress Contus Video Gallery, in order to read or alter data.
Impacted products: WordPress Plugins ~ not comprehensive.
Severity: 2/4.
Consequences: data reading, data creation/edition, data deletion.
Provenance: internet client.
Creation date: 12/02/2015.
Identifiers: CVE-2015-2065, VIGILANCE-VUL-16185.

Description of the vulnerability

The WordPress Contus Video Gallery product uses a database.

However, user's data are directly inserted in a SQL query.

An attacker can therefore use a SQL injection in WordPress Contus Video Gallery, in order to read or alter data.
Full Vigil@nce bulletin... (Free trial)

Previous page   Next page

Direct access to page 1 21 41 61 81 101 121 141 161 181 201 221 241 261 281 301 321 341 361 381 401 421 441 461 481 501 521 541 561 581 601 621 641 661 681 701 721 741 761 781 801 821 841 861 881 901 921 941 961 981 1001 1021 1041 1061 1081 1101 1121 1141 1161 1181 1201 1221 1241 1261 1281 1301 1321 1341 1361 1381 1401 1421 1441 1461 1481 1501 1514 1515 1516 1517 1518 1519 1520 1521 1522 1523 1524 1525 1526 1527 1528 1529 1530 1531 1532 1533 1534 1541 1561 1581 1601 1621 1641 1661 1681 1701 1721 1741 1761 1781 1801 1821 1841 1861 1881 1901 1921 1941 1961 1981 2001 2021 2041 2061 2081 2101 2121 2141 2161 2181 2201 2221 2241 2261 2281 2301 2321 2341 2361 2381 2401 2421 2441 2461 2481 2501 2521 2541 2561 2581 2601 2621 2641 2661 2681 2701 2721 2741 2761 2781 2801 2821 2841 2851