The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.
History of vulnerabilities analyzed by Vigil@nce:

computer vulnerability CVE-2015-2047

TYPO3 Core: bypassing authentication of rsaauth

Synthesis of the vulnerability

An attacker can use the rsaauth extension of TYPO3 Core, in order to authenticate on a restricted frontend area.
Impacted products: Debian, openSUSE, openSUSE Leap, TYPO3 Core.
Severity: 3/4.
Consequences: privileged access/rights, user access/rights.
Provenance: internet client.
Creation date: 19/02/2015.
Identifiers: CVE-2015-2047, DSA-3164-1, openSUSE-SU-2016:2169-1, TYPO3-CORE-SA-2015-001, VIGILANCE-VUL-16225.

Description of the vulnerability

The TYPO3 product version 4.3 to 4.6 can be configured:
 - with a user restricted frontend area
 - with the rsaauth extension loaded
 - with the rsaauth extension configured for the frontend with: $GLOBALS['TYPO3_CONF_VARS']['FE']['loginSecurityLevel'] = 'rsa'

However, in this case, the login is sufficient to authenticate.

An attacker can therefore use the rsaauth extension of TYPO3 Core, in order to authenticate on a restricted frontend area.
Full Vigil@nce bulletin... (Free trial)

vulnerability note CVE-2015-0623

Cisco Web Security Appliance: Cross Site Scripting

Synthesis of the vulnerability

An attacker can trigger a Cross Site Scripting of Cisco Web Security Appliance, in order to execute JavaScript code in the context of the web site.
Impacted products: AsyncOS, IronPort Web, Cisco WSA.
Severity: 2/4.
Consequences: client access/rights.
Provenance: document.
Creation date: 19/02/2015.
Identifiers: CERTFR-2015-AVI-076, CSCus40627, CVE-2015-0623, VIGILANCE-VUL-16224.

Description of the vulnerability

The Cisco Web Security Appliance product offers a web service.

However, it does not filter received data before inserting them in generated HTML documents.

An attacker can therefore trigger a Cross Site Scripting of Cisco Web Security Appliance, in order to execute JavaScript code in the context of the web site.
Full Vigil@nce bulletin... (Free trial)

vulnerability bulletin CVE-2015-4344

Drupal Services Basic Authentication: information disclosure

Synthesis of the vulnerability

An authenticated attacker can use Drupal RESTful Web Services, in order to obtain sensitive information.
Impacted products: Drupal Modules ~ not comprehensive.
Severity: 1/4.
Consequences: data reading.
Provenance: user account.
Creation date: 19/02/2015.
Identifiers: CVE-2015-4344, SA-CONTRIB-2015-050, VIGILANCE-VUL-16223.

Description of the vulnerability

The Services Basic Authentication module can be installed on Drupal.

However, an attacker can read the cache to bypass access restrictions to data.

An authenticated attacker can therefore use Drupal Services Basic Authentication, in order to obtain sensitive information.
Full Vigil@nce bulletin... (Free trial)

vulnerability announce CVE-2015-4345

Drupal RESTful Web Services: information disclosure

Synthesis of the vulnerability

An authenticated attacker can use Drupal RESTful Web Services, in order to obtain sensitive information.
Impacted products: Drupal Modules ~ not comprehensive.
Severity: 1/4.
Consequences: data reading.
Provenance: user account.
Creation date: 19/02/2015.
Identifiers: CVE-2015-4345, DRUPAL-SA-CONTRIB-2015-052, VIGILANCE-VUL-16222.

Description of the vulnerability

The RESTful Web Services module can be installed on Drupal.

However, an attacker can read the cache to bypass access restrictions to data.

An authenticated attacker can therefore use Drupal RESTful Web Services, in order to obtain sensitive information.
Full Vigil@nce bulletin... (Free trial)

vulnerability alert CVE-2015-2088

Drupal Term Queue: Cross Site Scripting

Synthesis of the vulnerability

An attacker can trigger a Cross Site Scripting of Drupal Term Queue, in order to execute JavaScript code in the context of the web site.
Impacted products: Drupal Modules ~ not comprehensive.
Severity: 2/4.
Consequences: client access/rights.
Provenance: document.
Creation date: 19/02/2015.
Identifiers: CVE-2015-2088, DRUPAL-SA-CONTRIB-2015-051, VIGILANCE-VUL-16221.

Description of the vulnerability

The Term Queue module can be installed on Drupal.

However, it does not filter received data before inserting them in generated HTML documents.

An attacker can therefore trigger a Cross Site Scripting of Drupal Term Queue, in order to execute JavaScript code in the context of the web site.
Full Vigil@nce bulletin... (Free trial)

vulnerability CVE-2015-2101

Drupal Navigate: Cross Site Scripting

Synthesis of the vulnerability

An attacker can trigger a Cross Site Scripting of Drupal Navigate, in order to execute JavaScript code in the context of the web site.
Impacted products: Drupal Modules ~ not comprehensive.
Severity: 2/4.
Consequences: client access/rights.
Provenance: document.
Creation date: 19/02/2015.
Identifiers: CVE-2015-2101, DRUPAL-SA-CONTRIB-2015-049, VIGILANCE-VUL-16220.

Description of the vulnerability

The Navigate module can be installed on Drupal.

However, it does not filter received data before inserting them in generated HTML documents.

An attacker can therefore trigger a Cross Site Scripting of Drupal Navigate, in order to execute JavaScript code in the context of the web site.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability note CVE-2015-2087

Drupal Avatar Uploader: file upload

Synthesis of the vulnerability

An attacker can upload a malicious file on Drupal Avatar Uploader, in order for example to upload a Trojan.
Impacted products: Drupal Modules ~ not comprehensive.
Severity: 3/4.
Consequences: privileged access/rights, user access/rights.
Provenance: internet client.
Creation date: 19/02/2015.
Identifiers: CVE-2015-2087, DRUPAL-SA-CONTRIB-2015-048, VIGILANCE-VUL-16219.

Description of the vulnerability

The Avatar Uploader module can be installed on Drupal.

It can be used to upload a file. However, as the file type is not restricted, a PHP file can be uploaded on the server, and then executed.

An attacker can therefore upload a malicious file on Drupal Avatar Uploader, in order for example to upload a Trojan.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability bulletin CVE-2015-2086

Drupal Panopoly Magic: Cross Site Scripting

Synthesis of the vulnerability

An attacker can trigger a Cross Site Scripting of Drupal Panopoly Magic, in order to execute JavaScript code in the context of the web site.
Impacted products: Drupal Modules ~ not comprehensive.
Severity: 2/4.
Consequences: client access/rights.
Provenance: document.
Creation date: 19/02/2015.
Identifiers: CVE-2015-2086, DRUPAL-SA-CONTRIB-2015-047, VIGILANCE-VUL-16218.

Description of the vulnerability

The Panopoly Magic module can be installed on Drupal.

However, it does not filter received data before inserting them in generated HTML documents.

An attacker can therefore trigger a Cross Site Scripting of Drupal Panopoly Magic, in order to execute JavaScript code in the context of the web site.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability announce CVE-2015-0270

Zend Framework: SQL injection of PostgreSQL Zend\Db

Synthesis of the vulnerability

An attacker can use a SQL injection in PostgreSQL Zend\Db of Zend Framework, in order to read or alter data.
Impacted products: Zend Framework.
Severity: 2/4.
Consequences: data reading, data creation/edition, data deletion.
Provenance: internet client.
Creation date: 19/02/2015.
Identifiers: CVE-2015-0270, VIGILANCE-VUL-16217, ZF2015-02.

Description of the vulnerability

The PostgreSQL Zend\Db adapter can be installed on Zend Framework.

However, user's data are directly inserted in a SQL query.

An attacker can therefore use a SQL injection in PostgreSQL Zend\Db of Zend Framework, in order to read or alter data.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability alert CVE-2014-9749

Squid cache: three vulnerabilities

Synthesis of the vulnerability

An attacker can use several vulnerabilities of Squid cache.
Impacted products: openSUSE, openSUSE Leap, Squid.
Severity: 2/4.
Consequences: user access/rights, data flow, denial of service on service.
Provenance: user account.
Number of vulnerabilities in this bulletin: 3.
Creation date: 19/02/2015.
Identifiers: 3997, 4066, CVE-2014-9749, openSUSE-SU-2015:1835-1, openSUSE-SU-2015:1835-2, openSUSE-SU-2017:0192-1, openSUSE-SU-2017:0223-1, VIGILANCE-VUL-16216.

Description of the vulnerability

Several vulnerabilities were announced in Squid cache.

An attacker can generate an CPU overload or a memory leak during the NTLM / Negotiate authentication, in order to trigger a denial of service. [severity:2/4; 3997]

An authenticated attacker cannot be revoked. [severity:1/4; 4066, CVE-2014-9749]

The security policy defined for the TOS/Diffserv of packets is not memorized, because of a missing CAP_NET_ADMIN capacity. [severity:1/4]
Full Vigil@nce bulletin... (Free trial)

Previous page   Next page

Direct access to page 1 21 41 61 81 101 121 141 161 181 201 221 241 261 281 301 321 341 361 381 401 421 441 461 481 501 521 541 561 581 601 621 641 661 681 701 721 741 761 781 801 821 841 861 881 901 921 941 961 981 1001 1021 1041 1061 1081 1101 1121 1141 1161 1181 1201 1221 1241 1261 1281 1301 1321 1341 1361 1381 1401 1421 1441 1461 1481 1501 1517 1518 1519 1520 1521 1522 1523 1524 1525 1526 1527 1528 1529 1530 1531 1532 1533 1534 1535 1536 1537 1541 1561 1581 1601 1621 1641 1661 1681 1701 1721 1741 1761 1781 1801 1821 1841 1861 1881 1901 1921 1941 1961 1981 2001 2021 2041 2061 2081 2101 2121 2141 2161 2181 2201 2221 2241 2261 2281 2301 2321 2341 2361 2381 2401 2421 2441 2461 2481 2501 2521 2541 2561 2581 2601 2621 2641 2661 2681 2701 2721 2741 2761 2781 2801 2821 2841 2846