The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.
History of vulnerabilities analyzed by Vigil@nce:

vulnerability bulletin CVE-2016-6210

OpenSSH: user detection via BLOWFISH

Synthesis of the vulnerability

An attacker can use a long password on OpenSSH, in order to detect if a login name is valid.
Impacted products: ProxySG par Blue Coat, SGOS by Blue Coat, Debian, BIG-IP Hardware, TMOS, Fedora, AIX, Juniper EX-Series, Juniper J-Series, Junos OS, SRX-Series, Data ONTAP 7-Mode, OpenSSH, openSUSE Leap, Solaris, RHEL, Slackware, Ubuntu.
Severity: 1/4.
Consequences: data reading.
Provenance: internet client.
Creation date: 18/07/2016.
Identifiers: bulletinoct2016, CERTFR-2016-AVI-279, CERTFR-2019-AVI-325, CVE-2016-6210, DLA-578-1, DSA-3626-1, FEDORA-2016-16e8d38f57, FEDORA-2016-341c83dbd3, FEDORA-2016-7440fa5ce2, JSA10940, K14845276, NTAP-20190206-0001, openSUSE-SU-2016:2339-1, RHSA-2017:2029-01, RHSA-2017:2563-01, SA136, SSA:2016-219-03, USN-3061-1, VIGILANCE-VUL-20133.

Description of the vulnerability

The OpenSSH product uses a workaround, so authentication trials with an invalid login last as long as a normal authentication. In order to do so, a fake password entry is created, with a hash based on the BLOWFISH algorithm.

However, BLOWFISH is faster than SHA256/SHA512 usually used. If the password to hash is long, the time difference can be measured.

An attacker can therefore use a long password on OpenSSH, in order to detect if a login name is valid.
Full Vigil@nce bulletin... (Free trial)

vulnerability announce CVE-2015-8239

sudo: privilege escalation via Digest_Spec

Synthesis of the vulnerability

An attacker can bypass restrictions via Digest_Spec of sudo, in order to escalate his privileges.
Impacted products: Fedora.
Severity: 2/4.
Consequences: administrator access/rights, privileged access/rights.
Provenance: user shell.
Creation date: 18/07/2016.
Identifiers: CVE-2015-8239, FEDORA-2016-90836ca57d, FEDORA-2016-f1e8e27e27, VIGILANCE-VUL-20132.

Description of the vulnerability

An attacker can bypass restrictions via Digest_Spec of sudo, in order to escalate his privileges.
Full Vigil@nce bulletin... (Free trial)

vulnerability alert CVE-2016-6214

libgd: out-of-bounds memory reading via TGA bpp/alphabit

Synthesis of the vulnerability

An attacker can force a read at an invalid address via TGA bpp/alphabit of libgd, in order to trigger a denial of service, or to obtain sensitive information.
Impacted products: Debian, Fedora, FortiAnalyzer, FortiAnalyzer Virtual Appliance, FortiGate, FortiGate Virtual Appliance, FortiOS, openSUSE, openSUSE Leap, Ubuntu.
Severity: 2/4.
Consequences: data reading, denial of service on service, denial of service on client.
Provenance: document.
Creation date: 18/07/2016.
Identifiers: CERTFR-2017-AVI-237, CVE-2016-6214, DSA-3619-1, FEDORA-2016-615f3bf06e, FG-IR-17-051, openSUSE-SU-2016:2117-1, openSUSE-SU-2016:2363-1, USN-3060-1, VIGILANCE-VUL-20131.

Description of the vulnerability

An attacker can force a read at an invalid address via TGA bpp/alphabit of libgd, in order to trigger a denial of service, or to obtain sensitive information.
Full Vigil@nce bulletin... (Free trial)

vulnerability CVE-2016-6132

libgd: out-of-bounds memory reading via read_image_tga

Synthesis of the vulnerability

An attacker can force a read at an invalid address via read_image_tga() of libgd, in order to trigger a denial of service, or to obtain sensitive information.
Impacted products: Debian, Fedora, FortiAnalyzer, FortiAnalyzer Virtual Appliance, FortiGate, FortiGate Virtual Appliance, FortiOS, openSUSE, openSUSE Leap, Ubuntu.
Severity: 2/4.
Consequences: data reading, denial of service on service, denial of service on client.
Provenance: document.
Creation date: 18/07/2016.
Identifiers: CERTFR-2017-AVI-237, CVE-2016-6132, DSA-3619-1, FEDORA-2016-615f3bf06e, FG-IR-17-051, openSUSE-SU-2016:2117-1, openSUSE-SU-2016:2363-1, USN-3060-1, VIGILANCE-VUL-20130.

Description of the vulnerability

An attacker can force a read at an invalid address via read_image_tga() of libgd, in order to trigger a denial of service, or to obtain sensitive information.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability note 20129

Ruby EventMachine: denial of service

Synthesis of the vulnerability

An attacker can generate a fatal error of Ruby EventMachine, in order to trigger a denial of service.
Impacted products: Debian.
Severity: 2/4.
Consequences: denial of service on service, denial of service on client.
Provenance: intranet client.
Creation date: 18/07/2016.
Identifiers: DLA-549-1, VIGILANCE-VUL-20129.

Description of the vulnerability

An attacker can generate a fatal error of Ruby EventMachine, in order to trigger a denial of service.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability bulletin 20128

WordPress Post Duplicator: Cross Site Scripting

Synthesis of the vulnerability

An attacker can trigger a Cross Site Scripting of WordPress Post Duplicator, in order to run JavaScript code in the context of the web site.
Impacted products: WordPress Plugins ~ not comprehensive.
Severity: 2/4.
Consequences: client access/rights.
Provenance: document.
Creation date: 15/07/2016.
Identifiers: VIGILANCE-VUL-20128.

Description of the vulnerability

The Post Duplicator plugin can be installed on WordPress.

However, it does not filter received data before inserting them in generated HTML documents.

An attacker can therefore trigger a Cross Site Scripting of WordPress Post Duplicator, in order to run JavaScript code in the context of the web site.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability announce 20127

WordPress bbPress: Cross Site Scripting

Synthesis of the vulnerability

An attacker can trigger a Cross Site Scripting of WordPress bbPress, in order to run JavaScript code in the context of the web site.
Impacted products: WordPress Plugins ~ not comprehensive.
Severity: 2/4.
Consequences: client access/rights.
Provenance: document.
Creation date: 15/07/2016.
Identifiers: VIGILANCE-VUL-20127.

Description of the vulnerability

The bbPress plugin can be installed on WordPress.

However, it does not filter received data before inserting them in generated HTML documents.

An attacker can therefore trigger a Cross Site Scripting of WordPress bbPress, in order to run JavaScript code in the context of the web site.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability alert 20126

WordPress Download Theme: directory traversal

Synthesis of the vulnerability

An attacker can traverse directories of WordPress Download Theme, in order to read a file outside the service root path.
Impacted products: WordPress Plugins ~ not comprehensive.
Severity: 2/4.
Consequences: data reading.
Provenance: internet client.
Creation date: 15/07/2016.
Identifiers: VIGILANCE-VUL-20126.

Description of the vulnerability

The Download Theme plugin can be installed on WordPress.

However, user's data are directly inserted in an access path. Sequences such as "/.." can thus be used to go in the upper directory.

An attacker can therefore traverse directories of WordPress Download Theme, in order to read a file outside the service root path.
Full Vigil@nce bulletin... (Free trial)

computer vulnerability 20125

WordPress MailPress: directory traversal

Synthesis of the vulnerability

An attacker can traverse directories of WordPress MailPress, in order to read a file outside the service root path.
Impacted products: WordPress Plugins ~ not comprehensive.
Severity: 2/4.
Consequences: data reading.
Provenance: internet client.
Creation date: 15/07/2016.
Identifiers: VIGILANCE-VUL-20125.

Description of the vulnerability

The MailPress plugin can be installed on WordPress.

However, user's data are directly inserted in an access path. Sequences such as "/.." can thus be used to go in the upper directory.

An attacker can therefore traverse directories of WordPress MailPress, in order to read a file outside the service root path.
Full Vigil@nce bulletin... (Free trial)

vulnerability note 20124

Joomla com_zhgooglemap: SQL injection

Synthesis of the vulnerability

An attacker can use a SQL injection of Joomla com_zhgooglemap, in order to read or alter data.
Impacted products: Joomla Extensions ~ not comprehensive.
Severity: 2/4.
Consequences: data reading, data creation/edition, data deletion.
Provenance: internet client.
Creation date: 15/07/2016.
Identifiers: VIGILANCE-VUL-20124.

Description of the vulnerability

The Joomla com_zhgooglemap product uses a database.

However, user's data are directly inserted in a SQL query.

An attacker can therefore use a SQL injection of Joomla com_zhgooglemap, in order to read or alter data.
Full Vigil@nce bulletin... (Free trial)

Previous page   Next page

Direct access to page 1 21 41 61 81 101 121 141 161 181 201 221 241 261 281 301 321 341 361 381 401 421 441 461 481 501 521 541 561 581 601 621 641 661 681 701 721 741 761 781 801 821 841 861 881 901 921 941 961 981 1001 1021 1041 1061 1081 1101 1121 1141 1161 1181 1201 1221 1241 1261 1281 1301 1321 1341 1361 1381 1401 1421 1441 1461 1481 1501 1521 1541 1561 1581 1601 1621 1641 1661 1681 1701 1721 1741 1761 1781 1801 1821 1841 1861 1881 1891 1892 1893 1894 1895 1896 1897 1898 1899 1900 1901 1902 1903 1904 1905 1906 1907 1908 1909 1910 1911 1921 1941 1961 1981 2001 2021 2041 2061 2081 2101 2121 2141 2161 2181 2201 2221 2241 2261 2281 2301 2321 2341 2361 2381 2401 2421 2441 2461 2481 2501 2521 2541 2561 2581 2601 2621 2641 2661 2681 2701 2721 2741 2761 2781 2801 2821 2841 2861 2871