L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Adobe Acrobat/Reader : exécution de code

Synthèse de la vulnérabilité 

Un attaquant peut créer un document PDF contenant du code JavaScript illicite afin de faire exécuter du code sur la machine de la victime ouvrant le document.
Logiciels impactés : Acrobat, NLD, openSUSE, Solaris, RHEL, SLES.
Gravité de cette vulnérabilité informatique : 3/4.
Date de création : 24/06/2008.
Références de cette annonce : 240106, 397839, 404976, 6718894, APSB08-13, APSB08-15, BID-29908, CERTA-2008-AVI-336, CVE-2008-2641, kb403742, RHSA-2008:0641-02, SUSE-SR:2008:016, VIGILANCE-VUL-7906, VU#788019.

Description de la vulnérabilité 

Un document PDF peut contenir du code JavaScript.

Lorsqu'une méthode JavaScript reçoit des données malformées, une corruption de mémoire se produit.

Un attaquant peut donc créer un document PDF contenant du code JavaScript illicite afin de faire exécuter du code sur la machine de la victime ouvrant le document.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte de vulnérabilité concerne les logiciels ou systèmes comme Acrobat, NLD, openSUSE, Solaris, RHEL, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cette menace est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin cyber-sécurité.

Solutions pour cette menace 

Adobe Acrobat/Reader : version 8.1.2 Security Update 1.
La version 8.1.2 Security Update 1 est corrigée :
Adobe Reader :
  Windows: http://www.adobe.com/support/downloads/detail.jsp?ftpID=3967
  Macintosh: http://www.adobe.com/support/downloads/detail.jsp?ftpID=3966
Adobe Acrobat :
  Windows: http://www.adobe.com/support/downloads/detail.jsp?ftpID=3976
  Macintosh: http://www.adobe.com/support/downloads/detail.jsp?ftpID=3977
 
Adobe Acrobat 3D :
  Windows: http://www.adobe.com/support/downloads/detail.jsp?ftpID=3975

Adobe Reader : version 7.1.0.
La version 7.1.0 est corrigée :
  http://www.adobe.com/go/getreader

Acrobat : version 7.1.0.
La version 7.1.0 est corrigée :
Acrobat 7 Windows :
  http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Windows
Acrobat 7 Macintosh :
  http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Macintosh

RHEL 3E, 4E, 5S : nouveaux paquetages acroread.
De nouveaux paquetages sont disponibles :
Red Hat Enterprise Linux version 3 Extras: acroread-8.1.2.SU1-2
Red Hat Enterprise Linux version 4 Extras: acroread-8.1.2.SU1-2.el4
Red Hat Enterprise Linux version 5 Supplementary: acroread-8.1.2.SU1-2.el5

Solaris : patch pour Adobe Acrobat/Reader.
Un patch est disponible:
  SPARC
    Solaris 10 : patch 121104-05
Les contre-mesures consistent à :
 - ne pas charger de fichier .pdf provenant de sources douteuses
 - désactiver Javascript dans le navigateur web et Adobe Acrobat/Reader

SuSE : nouveaux paquetages acroread.
De nouveaux paquetages sont disponibles :
Novell Linux Desktop 9 : acroread-7.0.9-2.6
SUSE CORE 9 : acroread-7.0.9-2.6
SUSE Linux Enterprise Desktop 10 : acroread-8.1.2_SU1-0.2
openSUSE : acroread-8.1.2_SU1-0.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une base cybersécurité. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.