L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Apache APR-core : lecture de mémoire hors plage prévue via apr_exp_tim

Synthèse de la vulnérabilité 

Un attaquant peut forcer la lecture à une adresse invalide via apr_exp_tim() de Apache APR-core, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Logiciels impactés : APR-core, Mac OS X, Debian, BIG-IP Hardware, TMOS, Fedora, Junos Space, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES.
Gravité de cette vulnérabilité informatique : 2/4.
Date de création : 24/10/2017.
Références de cette annonce : bulletinjul2018, bulletinjul2019, CVE-2017-12613, DLA-1162-1, FEDORA-2017-8d2cfc3752, HT209139, HT209193, JSA10873, K52319810, openSUSE-SU-2018:1214-1, RHSA-2017:3270-01, RHSA-2018:0465-01, RHSA-2018:0466-01, RHSA-2018:1253-01, SUSE-SU-2018:1322-1, VIGILANCE-VUL-24220.

Description de la vulnérabilité 

Un attaquant peut forcer la lecture à une adresse invalide via apr_exp_tim() de Apache APR-core, afin de mener un déni de service, ou d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de menace concerne les logiciels ou systèmes comme APR-core, Mac OS X, Debian, BIG-IP Hardware, TMOS, Fedora, Junos Space, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte de vulnérabilité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de menace informatique.

Solutions pour cette menace 

Apache APR-core : version 1.6.3.
La version 1.6.3 est corrigée :
  http://apr.apache.org/download.cgi

Apple macOS : version 10.14.
La version 10.14 est corrigée :
  https://support.apple.com/

Apple macOS : version 10.14.1.
La version 10.14.1 est corrigée :
  https://support.apple.com/

Debian 7 : nouveaux paquetages apr.
De nouveaux paquetages sont disponibles :
  Debian 7 : apr 1.4.6-3+deb7u2

F5 BIG-IP : solution pour APR.
La solution est indiquée dans les sources d'information.

Fedora 26 : nouveaux paquetages apr.
De nouveaux paquetages sont disponibles :
  Fedora 26 : apr 1.6.3-1.fc26

Junos Space : solution.
La solution est indiquée dans les sources d'information.

openSUSE Leap 42.3 : nouveaux paquetages libapr1.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : libapr1 1.5.1-9.3.1

Oracle Solaris : patch pour logiciels tiers de juillet 2018 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Oracle Solaris : patch pour logiciels tiers de juillet 2019 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Red Hat JBoss Web Server : version 3.1.0 Service Pack 2.
La version 3.1.0 Service Pack 2 est corrigée :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=webserver&downloadType=securityPatches&version=3.1

RHEL : nouveaux paquetages apr.
De nouveaux paquetages sont disponibles :
  RHEL 6 : apr 1.3.9-5.el6_9.1
  RHEL 7 : apr 1.4.8-3.el7_4.1

SUSE LE 11 SP4 : nouveaux paquetages libapr1.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : libapr1 1.3.3-11.18.19.13.2
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un correctif de vulnérabilité informatique. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.