L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Apache Tomcat : exécution de code via PersistenceManager

Synthèse de la vulnérabilité 

Un attaquant peut utiliser une vulnérabilité via PersistenceManager de Apache Tomcat, afin d'exécuter du code.
Produits impactés : Tomcat, Layer7 SiteMinder, CA SSO, SiteMinder, Debian, Avamar, Fedora, ePO, Snap Creator Framework, openSUSE Leap, Oracle Communications, Oracle DB, Oracle Fusion Middleware, Oracle Identity Management, Oracle OIT, Solaris, WebLogic, RHEL, Ubuntu.
Gravité de ce bulletin : 3/4.
Date de création : 21/05/2020.
Date de révision : 03/06/2020.
Références de cette menace : CERTFR-2020-AVI-315, CERTFR-2020-AVI-417, cpuapr2021, cpuoct2020, CVE-2020-9484, DLA-2209-1, DLA-2217-1, DLA-2279-1, DSA-2020-161, DSA-4627-1, ESDSA16092, FEDORA-2020-ce396e7d5c, FEDORA-2020-d9169235a8, NTAP-20200528-0005, openSUSE-SU-2020:0711-1, RHSA-2020:2529-01, RHSA-2020:2530-01, SB10332, USN-4448-1, USN-4596-1, VIGILANCE-VUL-32313.

Description de la vulnérabilité 

Un attaquant peut utiliser une vulnérabilité via PersistenceManager de Apache Tomcat, afin d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de menace informatique concerne les logiciels ou systèmes comme Tomcat, Layer7 SiteMinder, CA SSO, SiteMinder, Debian, Avamar, Fedora, ePO, Snap Creator Framework, openSUSE Leap, Oracle Communications, Oracle DB, Oracle Fusion Middleware, Oracle Identity Management, Oracle OIT, Solaris, WebLogic, RHEL, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin cyber-sécurité est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de compte utilisateur.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence technicien peut exploiter cette alerte de faille.

Solutions pour cette menace 

Apache Tomcat : version 9.0.35.
La version 9.0.35 est corrigée :
  https://tomcat.apache.org/whichversion.html

Apache Tomcat : version 8.5.55.
La version 8.5.55 est corrigée :
  https://tomcat.apache.org/whichversion.html

Apache Tomcat : version 7.0.104.
La version 7.0.104 est corrigée :
  https://tomcat.apache.org/whichversion.html

Apache Tomcat : contre-mesure pour PersistenceManager.
Une contre-mesure est indiquée dans la source d'information.

Debian 10 : nouveaux paquetages tomcat9.
De nouveaux paquetages sont disponibles :
  Debian 10 : tomcat9 9.0.31-1~deb10u2

Debian 8 : nouveaux paquetages tomcat7.
De nouveaux paquetages sont disponibles :
  Debian 8 : tomcat7 7.0.56-3+really7.0.100-1+deb8u1

Debian 8 : nouveaux paquetages tomcat8.
De nouveaux paquetages sont disponibles :
  Debian 8 : tomcat8 8.0.14-1+deb8u17

Debian 9 : nouveaux paquetages tomcat8.
De nouveaux paquetages sont disponibles :
  Debian 9 : tomcat8 8.5.54-0+deb9u2

Dell EMC Avamar Server : versions corrigées pour Apache Tomcat.
Les versions corrigées sont indiquées dans les sources d'information.

Fedora : nouveaux paquetages tomcat.
De nouveaux paquetages sont disponibles :
  Fedora 31 : tomcat 9.0.36-1.fc31
  Fedora 32 : tomcat 9.0.36-1.fc32

McAfee ePolicy Orchestrator : versions 5.9.1 EPO-919400 et 5.10.0 Update 9.
Les versions 5.9.1 EPO-919400 et 5.10.0 Update 9 sont corrigées :
  http://www.mcafee.com/us/downloads/downloads.aspx

openSUSE Leap 15.1 : nouveaux paquetages tomcat.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : tomcat 9.0.35-lp151.3.18.1

Oracle Communications : CPU de octobre 2020.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2714788.1
  https://support.oracle.com/rs?type=doc&id=2713777.1
  https://support.oracle.com/rs?type=doc&id=2714789.1
  https://support.oracle.com/rs?type=doc&id=2714787.1
  https://support.oracle.com/rs?type=doc&id=2714763.1
  https://support.oracle.com/rs?type=doc&id=2714792.1
  https://support.oracle.com/rs?type=doc&id=2713779.1
  https://support.oracle.com/rs?type=doc&id=2713303.1
  https://support.oracle.com/rs?type=doc&id=2714790.1
  https://support.oracle.com/rs?type=doc&id=2712893.1
  https://support.oracle.com/rs?type=doc&id=2714764.1
  https://support.oracle.com/rs?type=doc&id=2714796.1
  https://support.oracle.com/rs?type=doc&id=2714988.1
  https://support.oracle.com/rs?type=doc&id=2714791.1

Oracle Database : CPU de avril 2021.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2749094.1

Oracle Database : CPU de octobre 2020.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2694898.1

Oracle Fusion Middleware : CPU de avril 2021.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2749094.1

Oracle Fusion Middleware : CPU de octobre 2020.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2694898.1

Oracle Solaris : patch pour logiciels tiers de avril 2020 v3.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Oracle Solaris : patch pour logiciels tiers de avril 2021 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 6.10 : nouveaux paquetages tomcat6.
De nouveaux paquetages sont disponibles :
  RHEL 6.10 : tomcat6 6.0.24-115.el6_10

RHEL 7.8 : nouveaux paquetages tomcat.
De nouveaux paquetages sont disponibles :
  RHEL 7.8 : tomcat 7.0.76-12.el7_8

Snap Creator Framework : solution pour Tomcat.
Finalement, l'éditeur indique que Snap Creator Framework n'est pas vulnérable.

Symantec SiteMinder : version 12.8.04.
La version 12.8.04 est corrigée :
  https://support.broadcom.com/external/content/release-announcements/CA-Single-Sign-On-Hotfix-Cumulative-Release-Index/6544#SMWAM

Ubuntu 16.04 : nouveaux paquetages tomcat8.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : tomcat8 8.0.32-1ubuntu1.13

Ubuntu 20.04 : nouveaux paquetages tomcat9.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.04 LTS : tomcat9 9.0.31-1ubuntu0.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des alertes de vulnérabilité applicative. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.