L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Apache httpd : contournement de AllowOverride

Synthèse de la vulnérabilité 

Un attaquant local peut créer un fichier .htaccess afin de contourner les restrictions de AllowOverride.
Systèmes vulnérables : Apache httpd, Debian.
Gravité de cette menace : 1/4.
Date de création : 16/06/2009.
Références de cette faille : 44262, DSA-1816-1, VIGILANCE-VUL-8798.

Description de la vulnérabilité 

La directive AllowOverride du fichier de configuration de Apache httpd indique si les directives situées dans les fichiers .htaccess sont honorées. Par exemple :
  AllowOverride None : rien n'est autorisé
  AllowOverride All : tout est autorisé
  AllowOverride Option : les directives modifiant les options de répertoires sont autorisées

Depuis la version 2.2 de Apache httpd, le paramètre Options de la directive AllowOverride peut restreindre la liste des options autorisées. Par exemple :
  AllowOverride Options=Indexes,IncludesNOEXEC

Cependant, suite à une erreur de logique, lorsque au moins une option est indiquée dans AllowOverride, elles sont toutes autorisées (comme c'était le cas avec Apache httpd < 2.2).

Un attaquant peut donc par exemple activer l'option "Includes" dans un fichier .htaccess afin d'employer les commandes "#exec cmd" et "#exec cgi".
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte de vulnérabilité informatique concerne les logiciels ou systèmes comme Apache httpd, Debian.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte de faille est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de compte utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte sécurité.

Solutions pour cette menace 

Apache httpd : version 2.2.9.
La version 2.2.9 est corrigée :
  http://httpd.apache.org/download.cgi

Debian : nouveaux paquetages apache2.
De nouveaux paquetages sont disponibles :
  http://security.debian.org/pool/updates/main/a/apache2/*_2.2.3-4+etch8_*.deb
  http://security.debian.org/pool/updates/main/a/apache2/*_2.2.9-10+lenny3_*.deb
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un patch de vulnérabilités informatiques. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.