L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base et des outils pour y remédier.

Vulnérabilité de Apache httpd : élévation de privilèges via mod_session_cookie Ignored Expiry Time

Synthèse de la vulnérabilité

Un attaquant peut contourner les restrictions via mod_session_cookie Ignored Expiry Time de Apache httpd, afin d'élever ses privilèges.
Gravité de cette vulnérabilité informatique : 2/4.
Date création : 23/01/2019.
Références de cette annonce : bulletinapr2019, CERTFR-2019-AVI-031, CVE-2018-17199, DLA-1647-1, DSA-4422-1, HPESBUX03950, ibm10869064, ibm10872490, ibm10876972, openSUSE-SU-2019:0296-1, openSUSE-SU-2019:0305-1, RHSA-2019:4126-01, SSA:2019-022-01, SUSE-SU-2019:0498-1, SUSE-SU-2019:0504-1, USN-3937-1, VIGILANCE-VUL-28330.

Description de la vulnérabilité

Un attaquant peut contourner les restrictions via mod_session_cookie Ignored Expiry Time de Apache httpd, afin d'élever ses privilèges.
Bulletin Vigil@nce complet... (Essai gratuit)

Ce bulletin de vulnérabilité informatique concerne les logiciels ou systèmes comme Apache httpd, Debian, HP-UX, IBM i, Rational ClearCase, openSUSE Leap, Solaris, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de compte utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de faille.

Solutions pour cette menace

Apache httpd : version 2.4.38.
La version 2.4.38 est corrigée :
  http://httpd.apache.org/download.cgi

Debian 8 : nouveaux paquetages apache2.
De nouveaux paquetages sont disponibles :
  Debian 8 : apache2 2.4.10-10+deb8u13

Debian 9 : nouveaux paquetages apache2.
De nouveaux paquetages sont disponibles :
  Debian 9 : apache2 2.4.25-3+deb9u7

HP-UX Apache-based Web Server : version B.2.4.18.05.
La version B.2.4.18.05 est corrigée :
  https://h20392.www2.hpe.com/portal/swdepot/displayProductInfo.do?productNumber=HPUXWSSUITE
  https://h20392.www2.hpe.com/portal/swdepot/displayProductInfo.do?productNumber=HPUXWSATW508

IBM i : patch pour HTTP Server.
Un patch est indiqué dans les sources d'information.

IBM Rational ClearCase : patch pour Apache httpd.
Un patch est disponible :
  http://www-01.ibm.com/support/docview.wss?uid=ibm10875878

openSUSE Leap 15.0 : nouveaux paquetages apache2.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : apache2 2.4.33-lp150.2.9.1

openSUSE Leap 42.3 : nouveaux paquetages apache2.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : apache2 2.4.23-37.1

Oracle Solaris : patch pour logiciels tiers de avril 2019 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 6 : nouveaux paquetages httpd24-httpd.
De nouveaux paquetages sont disponibles :
  RHEL 6.0-6.10 : httpd24-httpd 2.4.34-15.el6

Slackware : nouveaux paquetages httpd.
De nouveaux paquetages sont disponibles :
  Slackware 14.0 : httpd 2.4.38-*-1_slack14.0
  Slackware 14.1 : httpd 2.4.38-*-1_slack14.1
  Slackware 14.2 : httpd 2.4.38-*-1_slack14.2

SUSE LE 12 SP3/4 : nouveaux paquetages apache2.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : apache2 2.4.23-29.34.4
  SUSE LE 12 SP4 : apache2 2.4.23-29.34.4

SUSE LE 15 : nouveaux paquetages apache2.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : apache2 2.4.33-3.9.7

Ubuntu : nouveaux paquetages apache2-bin.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.10 : apache2-bin 2.4.34-1ubuntu2.1
  Ubuntu 18.04 LTS : apache2-bin 2.4.29-1ubuntu4.6
  Ubuntu 16.04 LTS : apache2-bin 2.4.18-2ubuntu3.10
  Ubuntu 14.04 LTS : apache2-bin 2.4.7-1ubuntu4.22

Wind River Linux : solution (21/05/2019).
La solution est indiquée dans les sources d'information.
Bulletin Vigil@nce complet... (Essai gratuit)

Service de veille sur les vulnérabilités informatiques

Vigil@nce fournit un patch de sécurité informatique. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.