L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Apache httpd mod_perl : exécution de code via htaccess

Synthèse de la vulnérabilité 

Un attaquant peut utiliser une vulnérabilité via htaccess de Apache httpd mod_perl, afin d'exécuter du code.
Systèmes vulnérables : Apache httpd Modules ~ non exhaustif, Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette menace : 2/4.
Date de création : 10/09/2018.
Références de cette faille : 644169, CVE-2011-2767, DLA-1507-1, FEDORA-2018-a94668408d, openSUSE-SU-2019:2549-1, openSUSE-SU-2019:2558-1, RHSA-2018:2737-01, RHSA-2018:2825-01, RHSA-2018:2826-01, SUSE-SU-2019:3213-1, SUSE-SU-2020:14266-1, USN-3825-1, USN-3825-2, VIGILANCE-VUL-27182.

Description de la vulnérabilité 

Un attaquant peut utiliser une vulnérabilité via htaccess de Apache httpd mod_perl, afin d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de faille informatique concerne les logiciels ou systèmes comme Apache httpd Modules ~ non exhaustif, Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de faille informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de compte utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis cyber-sécurité.

Solutions pour cette menace 

Apache httpd mod_perl : patch pour htaccess.
Un patch est indiqué dans les sources d'information.

Debian 8 : nouveaux paquetages libapache2-mod-perl2.
De nouveaux paquetages sont disponibles :
  Debian 8 : libapache2-mod-perl2 2.0.9~1624218-2+deb8u3

Fedora 27 : nouveaux paquetages mod_perl.
De nouveaux paquetages sont disponibles :
  Fedora 27 : mod_perl 2.0.10-9.fc27

openSUSE Leap 15 : nouveaux paquetages apache2-mod_perl.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : apache2-mod_perl 2.0.11-lp150.2.3.1
  openSUSE Leap 15.1 : apache2-mod_perl 2.0.11-lp151.3.3.1

RHEL 6.10 : nouveaux paquetages mod_perl.
De nouveaux paquetages sont disponibles :
  RHEL 6 : mod_perl 2.0.4-12.el6_10

RHEL : nouveaux paquetages rh-perl524-mod_perl.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-perl524-mod_perl 2.0.9-10.el6
  RHEL 7 : rh-perl524-mod_perl 2.0.9-10.el7

RHEL : nouveaux paquetages rh-perl526-mod_perl.
De nouveaux paquetages sont disponibles :
  RHEL 7 : rh-perl526-mod_perl 2.0.10-10.el7

SUSE LE 11 : nouveaux paquetages apache2-mod_perl.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : apache2-mod_perl 2.0.4-40.63.3.3
  SUSE LE 11 SP4 : apache2-mod_perl 2.0.4-40.63.3.3

SUSE LE 12 SP4/5 : nouveaux paquetages apache2-mod_perl.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : apache2-mod_perl 2.0.8-13.5.1
  SUSE LE 12 SP5 : apache2-mod_perl 2.0.8-13.5.1

SUSE LE 15 : nouveaux paquetages apache2-mod_perl.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : apache2-mod_perl 2.0.11-bp150.3.3.1
  SUSE LE 15 SP1 : apache2-mod_perl 2.0.11-bp151.4.3.1

Ubuntu : nouveaux paquetages mod_perl.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.10 : libapache2-mod-perl2 2.0.10-2ubuntu3.18.10.1
  Ubuntu 18.04 LTS : libapache2-mod-perl2 2.0.10-2ubuntu3.18.04.1
  Ubuntu 16.04 LTS : libapache2-mod-perl2 2.0.9-4ubuntu1.2
  Ubuntu 14.04 LTS : libapache2-mod-perl2 2.0.8+httpd24-r1449661-6ubuntu2.1
  Ubuntu 12.04 ESM : libapache2-mod-perl2 2.0.5-5ubuntu1.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une alerte de vulnérabilités logicielles. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.