L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Apache httpd : obtention d'information via URL Normalization Consecutive Slashes

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via URL Normalization Consecutive Slashes de Apache httpd, afin d'obtenir des informations sensibles.
Produits impactés : Apache httpd, Blue Coat CAS, Broadcom Content Analysis, Debian, Fedora, HP-UX, IBM i, Rational ClearCase, WebSphere AS Traditional, openSUSE Leap, Oracle Communications, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de ce bulletin : 3/4.
Date de création : 02/04/2019.
Références de cette menace : CERTFR-2019-AVI-141, cpuapr2020, CVE-2019-0220, DLA-1748-1, DSA-4422-1, FEDORA-2019-a4ed7400f4, HPESBUX03950, ibm10880413, ibm10883380, ibm10885680, openSUSE-SU-2019:1190-1, openSUSE-SU-2019:1209-1, openSUSE-SU-2019:1258-1, RHSA-2019:2343-01, RHSA-2019:3436-01, RHSA-2019:4126-01, SUSE-SU-2019:0873-1, SUSE-SU-2019:0878-1, SUSE-SU-2019:0888-1, SUSE-SU-2019:0888-2, SUSE-SU-2019:0889-1, SYMSA16056, USN-3937-1, VIGILANCE-VUL-28917.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via URL Normalization Consecutive Slashes de Apache httpd, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte de menace concerne les logiciels ou systèmes comme Apache httpd, Blue Coat CAS, Broadcom Content Analysis, Debian, Fedora, HP-UX, IBM i, Rational ClearCase, WebSphere AS Traditional, openSUSE Leap, Oracle Communications, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette vulnérabilité cybersécurité est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un attaquant avec un niveau de compétence expert peut exploiter cette faille cybersécurité.

Solutions pour cette menace 

Apache httpd : contre-mesure pour URL Normalization Consecutive Slashes.
Une contre-mesure est indiquée dans la source d'information.

Broadcom Content Analysis : solution pour Apache HTTP Server.
La solution est indiquée dans les sources d'information.

Debian 8 : nouveaux paquetages apache2.
De nouveaux paquetages sont disponibles :
  Debian 8 : apache2 2.4.10-10+deb8u14

Debian 9 : nouveaux paquetages apache2.
De nouveaux paquetages sont disponibles :
  Debian 9 : apache2 2.4.25-3+deb9u7

Fedora 28 : nouveaux paquetages httpd.
De nouveaux paquetages sont disponibles :
  Fedora 28 : httpd 2.4.39-1.1.fc28

HP-UX Apache-based Web Server : version B.2.4.18.05.
La version B.2.4.18.05 est corrigée :
  https://h20392.www2.hpe.com/portal/swdepot/displayProductInfo.do?productNumber=HPUXWSSUITE
  https://h20392.www2.hpe.com/portal/swdepot/displayProductInfo.do?productNumber=HPUXWSATW508

IBM i : patch pour Apache httpd.
Un patch est disponible :
  IBM i 7.2 - SI69901 : https://www-945.ibm.com/support/fixcentral/
  IBM i 7.3 - SI69900 et SI69828 : https://www-945.ibm.com/support/fixcentral/

IBM i : patch pour HTTP Server.
Un patch est indiqué dans les sources d'information.

IBM Rational ClearCase : versions corrigées pour Apache httpd.
Les versions corrigées sont indiquées dans les sources d'information.
Cette mise à jour est équivalente à celle de VIGILANCE-SOL-65296.

IBM WebSphere Application Server Traditional : versions corrigées pour Apache httpd.
Les versions corrigées sont indiquées dans les sources d'information.

openSUSE Leap 15.0 : nouveaux paquetages apache2.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : apache2 2.4.33-lp150.2.17.1

openSUSE Leap 42.3 : nouveaux paquetages apache2.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : apache2 2.4.23-49.1

Oracle Communications : CPU de avril 2020.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2647690.1
  https://support.oracle.com/rs?type=doc&id=2654603.1
  https://support.oracle.com/rs?type=doc&id=2652618.1
  https://support.oracle.com/rs?type=doc&id=2653087.1
  https://support.oracle.com/rs?type=doc&id=2653688.1
  https://support.oracle.com/rs?type=doc&id=2652610.1
  https://support.oracle.com/rs?type=doc&id=2653279.1
  https://support.oracle.com/rs?type=doc&id=2652619.1
  https://support.oracle.com/rs?type=doc&id=2652621.1
  https://support.oracle.com/rs?type=doc&id=2652606.1
  https://support.oracle.com/rs?type=doc&id=2653691.1
  https://support.oracle.com/rs?type=doc&id=2653692.1
  https://support.oracle.com/rs?type=doc&id=2647687.1
  https://support.oracle.com/rs?type=doc&id=2652622.1

RHEL 6 : nouveaux paquetages httpd24-httpd.
De nouveaux paquetages sont disponibles :
  RHEL 6.0-6.10 : httpd24-httpd 2.4.34-15.el6

RHEL 7 : nouveaux paquetages httpd.
De nouveaux paquetages sont disponibles :
  RHEL 7 : httpd 2.4.6-90.el7

RHEL 8 : nouveau module httpd-2.4.
Le module suivant est mis à jour :
  RHEL 8 Module : httpd:2.4

SUSE LE 12 : nouveaux paquetages apache2.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : apache2 2.4.10-14.36.1
  SUSE LE 12 SP1 : apache2 2.4.16-20.24.1
  SUSE LE 12 SP2 : apache2 2.4.23-29.40.1
  SUSE LE 12 SP3 : apache2 2.4.23-29.40.1
  SUSE LE 12 SP4 : apache2 2.4.23-29.40.1

SUSE LE 15 : nouveaux paquetages apache2.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : apache2 2.4.33-3.15.1

Ubuntu : nouveaux paquetages apache2-bin.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.10 : apache2-bin 2.4.34-1ubuntu2.1
  Ubuntu 18.04 LTS : apache2-bin 2.4.29-1ubuntu4.6
  Ubuntu 16.04 LTS : apache2-bin 2.4.18-2ubuntu3.10
  Ubuntu 14.04 LTS : apache2-bin 2.4.7-1ubuntu4.22

Wind River Linux : version 10.18.44.9.
La version 10.18.44.9 est corrigée :
  https://support2.windriver.com/
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une alerte de sécurité informatique. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.