L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Apache mod_auth_openidc : redirection via Slash Backslash

Synthèse de la vulnérabilité 

Un attaquant peut tromper l'utilisateur via Slash Backslash de Apache mod_auth_openidc, afin de le rediriger vers un site malveillant.
Logiciels impactés : Apache httpd Modules ~ non exhaustif, Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES.
Gravité de cette vulnérabilité informatique : 1/4.
Date de création : 02/03/2020.
Références de cette annonce : CVE-2019-20479, DLA-2130-1, DLA-2298-1, FEDORA-2020-1106ece93a, FEDORA-2020-33d51234cd, openSUSE-SU-2020:0376-1, RHSA-2020:3032-01, SUSE-SU-2020:0705-1, SUSE-SU-2020:0706-1, VIGILANCE-VUL-31708.

Description de la vulnérabilité 

Le produit Apache mod_auth_openidc dispose d'un service web.

Cependant, le service web accepte de rediriger la victime sans la prévenir, vers un site externe indiqué par l'attaquant.

Un attaquant peut donc tromper l'utilisateur via Slash Backslash de Apache mod_auth_openidc, afin de le rediriger vers un site malveillant.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de menace informatique concerne les logiciels ou systèmes comme Apache httpd Modules ~ non exhaustif, Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de vulnérabilité informatique est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un attaquant avec un niveau de compétence expert peut exploiter cette menace sécurité.

Solutions pour cette menace 

Apache mod_auth_openidc : patch pour Slash Backslash.
Un patch est indiqué dans les sources d'information.

Debian 8 : nouveaux paquetages libapache2-mod-auth-openidc.
De nouveaux paquetages sont disponibles :
  Debian 8 : libapache2-mod-auth-openidc 1.6.0-1+deb8u3

Debian 9 : nouveaux paquetages libapache2-mod-auth-openidc.
De nouveaux paquetages sont disponibles :
  Debian 9 : libapache2-mod-auth-openidc 2.1.6-1+deb9u1

Fedora 31-32 : nouveaux paquetages mod_auth_openidc.
De nouveaux paquetages sont disponibles :
  Fedora 31 : mod_auth_openidc 2.4.2.1-1.fc31
  Fedora 32 : mod_auth_openidc 2.4.2.1-1.fc32

openSUSE Leap 15.1 : nouveaux paquetages apache2-mod_auth_openidc.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : apache2-mod_auth_openidc 2.3.8-lp151.2.6.1

RHEL 8.0 : nouveau module mod_auth_openidc-2.3.
Le module suivant est mis à jour :
  RHEL 8.0 Module : mod_auth_openidc:2.3

SUSE LE 12 SP4/5 : nouveaux paquetages apache2-mod_auth_openidc.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : apache2-mod_auth_openidc 2.4.0-3.11.1
  SUSE LE 12 SP5 : apache2-mod_auth_openidc 2.4.0-3.11.1

SUSE LE 15 SP1 : nouveaux paquetages apache2-mod_auth_openidc.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : apache2-mod_auth_openidc 2.3.8-3.7.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des annonces cyber-sécurité. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.