L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base et des outils pour y remédier.

alerte de vulnérabilité CVE-2015-8620

Avast Antivirus : buffer overflow de aswSnx.sys

Synthèse de la vulnérabilité

Un attaquant peut provoquer un buffer overflow dans aswSnx.sys de Avast, afin de mener un déni de service, et éventuellement d'exécuter du code avec les privilèges du système.
Produits concernés : Avast AV.
Gravité : 2/4.
Date création : 23/02/2016.
Date révision : 16/06/2017.
Références : CVE-2015-8620, VIGILANCE-VUL-19011, ZDI-16-681.

Description de la vulnérabilité

Le produit Avast installe le pilote aswSnx.sys (Avast Virtualization).

Cependant, si la taille des données est supérieure à la taille du tableau de stockage, un débordement se produit dans aswSnx.sys. Les détails techniques ne sont pas connus.

Un attaquant peut donc provoquer un buffer overflow dans aswSnx.sys de Avast, afin de mener un déni de service, et éventuellement d'exécuter du code avec les privilèges du système.
Bulletin Vigil@nce complet.... (Essai gratuit)

Service de veille sur les vulnérabilités informatiques

Vigil@nce fournit une base de vulnérabilité informatique. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.