L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Bouncy Castle : obtention d'information via GCM

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via GCM de Bouncy Castle, afin d'obtenir des informations sensibles.
Logiciels vulnérables : Bouncy Castle JCE, Debian, Fedora, Android OS, JBoss EAP par Red Hat, Ubuntu.
Gravité de cette annonce : 2/4.
Date de création : 11/04/2017.
Références de cette vulnérabilité informatique : CVE-2015-6644, DLA-893-1, DSA-3829-1, FEDORA-2017-4c3ac44551, RHSA-2017:1832-01, RHSA-2017:2808-01, RHSA-2017:2809-01, RHSA-2017:2810-01, RHSA-2017:2811-01, USN-3727-1, VIGILANCE-VUL-22393.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via GCM de Bouncy Castle, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte de menace informatique concerne les logiciels ou systèmes comme Bouncy Castle JCE, Debian, Fedora, Android OS, JBoss EAP par Red Hat, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette faille est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin de vulnérabilité informatique.

Solutions pour cette menace 

Bouncy Castle : patch pour GCM.
Un patch est indiqué dans les sources d'information.

Debian : nouveaux paquetages bouncycastle.
De nouveaux paquetages sont disponibles :
  Debian 7 : bouncycastle 1.44+dfsg-3.1+deb7u2
  Debian 8 : bouncycastle 1.49+dfsg-3+deb8u2

Fedora 24 : nouveaux paquetages bouncycastle.
De nouveaux paquetages sont disponibles :
  Fedora 24 : bouncycastle 1.52-9.fc24

Google Android OS : solution de janvier 2016.
La solution est indiquée dans les sources d'information.

Red Hat JBoss Enterprise Application Platform : version 7.0.8.
La version 7.0.8 est corrigée :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=appplatform&downloadType=securityPatches&version=7.0

Red Hat JBoss Fuse/A-MQ : version 6.3 R4.
La version 6.3 R4 est corrigée :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=jboss.fuse&downloadType=securityPatches&version=6.3
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=jboss.amq&downloadType=securityPatches&version=6.3

Ubuntu 14.04 : nouveaux paquetages bouncycastle.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 LTS : libbcmail-java 1.49+dfsg-2ubuntu0.1, libbcpg-java 1.49+dfsg-2ubuntu0.1, libbcpkix-java 1.49+dfsg-2ubuntu0.1, libbcprov-java 1.49+dfsg-2ubuntu0.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une alerte de vulnérabilité applicative. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.