L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de CUPS : déni de service via IPP_TAG_UNSUPPORTED

Synthèse de la vulnérabilité 

Un attaquant peut envoyer un paquet contenant le tag IPP_TAG_UNSUPPORTED afin de stopper CUPS.
Systèmes impactés : CUPS, Debian, Mandriva Linux, Mandriva NF, openSUSE, RHEL, SLES.
Gravité de cette alerte : 2/4.
Date de création : 03/06/2009.
Références de cette alerte : BID-35169, CORE-2009-0420, CVE-2009-0949, DSA-1810-1, MDVSA-2009:281, MDVSA-2009:282, MDVSA-2009:282-1, MDVSA-2009:283, RHSA-2009:1082-01, RHSA-2009:1083-01, SUSE-SR:2009:012, VIGILANCE-VUL-8753.

Description de la vulnérabilité 

Le système CUPS (Common UNIX Printing System) assure une gestion simplifiée des imprimantes sous un environnement Unix.

Ce logiciel emploie le protocole IPP (Internet Printing Protocol) qui écoute sur le port 631/tcp. Ce protocole utilise des tags :
 - IPP_TAG_CHARSET : encodage de caractères
 - IPP_TAG_DATE : date
 - IPP_TAG_UNSUPPORTED : tag inconnu
 - etc.

Lorsqu'un paquet IPP contient un tag IPP_TAG_UNSUPPORTED, la fonction ippReadIO() du fichier cups/ipp.c n'initialise pas correctement une structure. Si le paquet contient deux tags, le deuxième déréférence alors un pointeur NULL.

Un attaquant peut donc envoyer un paquet contenant le tag IPP_TAG_UNSUPPORTED afin de stopper CUPS.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce de vulnérabilité concerne les logiciels ou systèmes comme CUPS, Debian, Mandriva Linux, Mandriva NF, openSUSE, RHEL, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de faille est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client intranet.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence spécialiste peut exploiter cette annonce de faille informatique.

Solutions pour cette menace 

CUPS : version 1.3.10.
La version 1.3.10 est corrigée :
  http://www.cups.org/

Debian : nouveaux paquetages cups.
De nouveaux paquetages sont disponibles :
  http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.2.7-4+etch8_*.deb
  http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1+lenny6_*.deb

Mandriva 2008.0 : nouveaux paquetages cups.
De nouveaux paquetages sont disponibles :
  cups-1.3.10-0.1mdv2008.0

Mandriva : nouveaux paquetages cups.
De nouveaux paquetages sont disponibles :
Mandriva Linux 2009.0:
  acl-2.2.47-4.1mdv2009.0
  cups-1.3.10-0.2mdv2009.0
  poppler-0.8.7-2.3mdv2009.0
Corporate 3.0:
  cups-1.1.20-5.21.C30mdk
Corporate 4.0:
  cups-1.2.4-0.12.20060mlcs4
Mandriva Enterprise Server 5:
  acl-2.2.47-4.1mdvmes5
  cups-1.3.10-0.2mdvmes5
  openslp-1.2.1-8.1mdvmes5
  poppler-0.8.7-2.3mdvmes5
Multi Network Firewall 2.0:
  cups-1.1.20-5.21.M20mdk

RHEL 3, 4 : nouveaux paquetages cups.
De nouveaux paquetages sont disponibles :
Red Hat Enterprise Linux version 3: cups-1.1.17-13.3.62
Red Hat Enterprise Linux version 4: cups-1.1.22-0.rc1.9.32.el4_8.3

RHEL 5 : nouveaux paquetages cups.
De nouveaux paquetages sont disponibles :
Red Hat Enterprise Linux version 5: cups-1.3.7-8.el5_3.6

SUSE : nouveaux paquetages (06/07/2009).
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des annonces de sécurité informatique. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.