L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de ClamAV : déni de service via cli_hm_scan

Synthèse de la vulnérabilité 

Un attaquant peut envoyer un email contenant une pièce jointe illicite, afin de provoquer une erreur dans la fonction cli_hm_scan(), qui stoppe ClamAV.
Logiciels impactés : ClamAV, Fedora, Mandriva Linux, NLD, OES, openSUSE, SUSE Linux Enterprise Desktop, SLES.
Gravité de cette vulnérabilité informatique : 2/4.
Date de création : 26/07/2011.
Références de cette annonce : 2818, BID-48891, CVE-2011-2721, FEDORA-2011-10053, FEDORA-2011-10090, MDVSA-2011:122, openSUSE-SU-2011:0940-1, SUSE-SU-2011:0948-1, VIGILANCE-VUL-10870.

Description de la vulnérabilité 

Le fichier libclamav/matcher-hash.c implémente la gestion des hachés des signatures de virus, à l'aide des algorithmes MD5, SHA1 et SHA256.

Un email peut contenir une pièce jointe PDF, contenant un objet illicite. Lorsque ClamAV analyse cet objet, il appelle la fonction cli_scanraw() qui appelle la fonction cli_hm_scan() du fichier libclamav/matcher-hash.c pour vérifier si sa signature est connue. Cependant, la fonction de recherche lit la mémoire située après le dernier haché, ce qui provoque une erreur de segmentation (notamment sous Solaris).

Un attaquant peut donc envoyer un email contenant une pièce jointe illicite, afin de provoquer une erreur dans la fonction cli_hm_scan(), qui stoppe ClamAV.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin sécurité concerne les logiciels ou systèmes comme ClamAV, Fedora, Mandriva Linux, NLD, OES, openSUSE, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis cyber-sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte de menace informatique.

Solutions pour cette menace 

ClamAV : version 0.97.2.
La version 0.97.2 est corrigée :
  http://www.clamav.net/lang/en/download/

ClamAV : patch pour cli_hm_scan.
Un patch est disponible dans les sources d'information.

Fedora : nouveaux paquetages clamav.
De nouveaux paquetages sont disponibles :
  clamav-0.97.2-1400.fc14
  clamav-0.97.2-1500.fc15

Mandriva : nouveaux paquetages clamav.
De nouveaux paquetages sont disponibles :
  clamav-0.97.2-0.1mdv2009.0
  clamav-0.97.2-0.1.20060mlcs4
  clamav-0.97.2-0.1mdvmes5.2

SUSE : nouveaux paquetages clamav.
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des bulletins de vulnérabilité de logiciel. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.