L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Dom4J : injection d'entité XML externe via SaxReader

Synthèse de la vulnérabilité 

Un attaquant peut transmettre des données XML malveillantes via SaxReader() à Dom4J, afin de lire un fichier, de scanner des sites, ou de mener un déni de service.
Logiciels vulnérables : Debian, Openfire, Spark, openSUSE Leap, JBoss EAP par Red Hat, Red Hat SSO.
Gravité de cette annonce : 2/4.
Date de création : 01/05/2020.
Références de cette vulnérabilité informatique : CVE-2020-10683, DLA-2191-1, openSUSE-SU-2020:0719-1, RHSA-2020:3461-01, RHSA-2020:3462-01, RHSA-2020:3463-01, RHSA-2020:3464-01, RHSA-2020:3495-01, RHSA-2020:3496-01, RHSA-2020:3497-01, RHSA-2020:3501-01, RHSA-2020:3637-01, RHSA-2020:3638-01, RHSA-2020:3639-01, RHSA-2020:3642-01, VIGILANCE-VUL-32161.

Description de la vulnérabilité 

Un attaquant peut transmettre des données XML malveillantes via SaxReader() à Dom4J, afin de lire un fichier, de scanner des sites, ou de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte de vulnérabilité concerne les logiciels ou systèmes comme Debian, Openfire, Spark, openSUSE Leap, JBoss EAP par Red Hat, Red Hat SSO.

Notre équipe Vigil@nce a déterminé que la gravité de cette menace est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin cyber-sécurité.

Solutions pour cette menace 

Debian 8 : nouveaux paquetages dom4j.
De nouveaux paquetages sont disponibles :
  Debian 8 : dom4j 1.6.1+dfsg.3-2+deb8u2

Ignite Spark : version 2.9.0.
La version 2.9.0 est corrigée :
  https://www.igniterealtime.org/downloads/

Openfire : version 4.5.3.
La version 4.5.3 est corrigée :
  https://www.igniterealtime.org/downloads/
  https://download.igniterealtime.org/openfire/

openSUSE Leap 15.1 : nouveaux paquetages dom4j.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : dom4j 1.6.1-lp151.6.3.1

Red Hat JBoss EAP : version 7.2.9.
La version 7.2.9 est corrigée :
  https://access.redhat.com/documentation/en-us/red_hat_jboss_enterprise_application_platform/7.2/

Red Hat JBoss EAP : version 7.3.2.
La version 7.3.2 est corrigée :
  https://access.redhat.com/documentation/en-us/red_hat_jboss_enterprise_application_platform/7.3/

Red Hat Single Sign-On : version 7.4.2.
La version 7.4.2 est corrigée :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=core.service.rhsso&downloadType=securityPatches&version=7.4
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un patch de vulnérabilités de systèmes. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.