L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Eclipse Jetty : Cross Site Scripting

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un Cross Site Scripting de Eclipse Jetty, afin d'exécuter du code JavaScript dans le contexte du site web.
Produits vulnérables : Kafka, Jetty, QRadar SIEM, Snap Creator Framework, SnapManager, Oracle Communications, Oracle Fusion Middleware, Oracle OIT, Tuxedo, WebLogic, Puppet.
Gravité de cette faille : 2/4.
Nombre de vulnérabilités dans ce bulletin : 3.
Date de création : 23/04/2019.
Références de ce bulletin : 6344071, 6344075, cpuapr2020, cpujan2020, cpujul2020, CVE-2019-10241, CVE-2019-10246, CVE-2019-10247, NTAP-20190509-0003, VIGILANCE-VUL-29106.

Description de la vulnérabilité 

Le produit Eclipse Jetty dispose d'un service web.

Cependant, les données reçues ne sont pas filtrées avant d'être insérées dans les documents HTML générés.

Un attaquant peut donc provoquer un Cross Site Scripting de Eclipse Jetty, afin d'exécuter du code JavaScript dans le contexte du site web.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte de menace informatique concerne les logiciels ou systèmes comme Kafka, Jetty, QRadar SIEM, Snap Creator Framework, SnapManager, Oracle Communications, Oracle Fusion Middleware, Oracle OIT, Tuxedo, WebLogic, Puppet.

Notre équipe Vigil@nce a déterminé que la gravité de cette faille est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Ce bulletin concerne 3 vulnérabilités.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin de vulnérabilité informatique.

Solutions pour cette menace 

Eclipse Jetty : version 9.4.17.
La version 9.4.17 est corrigée :
  http://www.eclipse.org/jetty/

Eclipse Jetty : version 9.3.27.
La version 9.3.27 est corrigée :
  http://www.eclipse.org/jetty/

Eclipse Jetty : version 9.2.28.
La version 9.2.28 est corrigée :
  http://www.eclipse.org/jetty/

Apache Kafka : version 2.3.0.
La version 2.3.0 est corrigée :
  http://kafka.apache.org/downloads

Continuous Delivery for Puppet Enterprise : version 2.18.2.
La version 2.18.2 est corrigée :
  https://puppet.com/

IBM QRadar SIEM : patch pour Components.
Un patch est indiqué dans les sources d'information.

IBM QRadar SIEM : patch pour Jetty, ActiveMQ, CXF.
Un patch est indiqué dans les sources d'information.

Oracle Communications : CPU de avril 2020.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2647690.1
  https://support.oracle.com/rs?type=doc&id=2654603.1
  https://support.oracle.com/rs?type=doc&id=2652618.1
  https://support.oracle.com/rs?type=doc&id=2653087.1
  https://support.oracle.com/rs?type=doc&id=2653688.1
  https://support.oracle.com/rs?type=doc&id=2652610.1
  https://support.oracle.com/rs?type=doc&id=2653279.1
  https://support.oracle.com/rs?type=doc&id=2652619.1
  https://support.oracle.com/rs?type=doc&id=2652621.1
  https://support.oracle.com/rs?type=doc&id=2652606.1
  https://support.oracle.com/rs?type=doc&id=2653691.1
  https://support.oracle.com/rs?type=doc&id=2653692.1
  https://support.oracle.com/rs?type=doc&id=2647687.1
  https://support.oracle.com/rs?type=doc&id=2652622.1

Oracle Communications : CPU de juillet 2020.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2681987.1
  https://support.oracle.com/rs?type=doc&id=2682459.1
  https://support.oracle.com/rs?type=doc&id=2682014.1
  https://support.oracle.com/rs?type=doc&id=2683787.1
  https://support.oracle.com/rs?type=doc&id=2683788.1
  https://support.oracle.com/rs?type=doc&id=2683789.1
  https://support.oracle.com/rs?type=doc&id=2682045.1
  https://support.oracle.com/rs?type=doc&id=2683831.1
  https://support.oracle.com/rs?type=doc&id=2682010.1
  https://support.oracle.com/rs?type=doc&id=2683832.1
  https://support.oracle.com/rs?type=doc&id=2682500.1
  https://support.oracle.com/rs?type=doc&id=2683241.1
  https://support.oracle.com/rs?type=doc&id=2682011.1
  https://support.oracle.com/rs?type=doc&id=2683840.1
  https://support.oracle.com/rs?type=doc&id=2682018.1
  https://support.oracle.com/rs?type=doc&id=2683841.1
  https://support.oracle.com/rs?type=doc&id=2683842.1
  https://support.oracle.com/rs?type=doc&id=2683843.1
  https://support.oracle.com/rs?type=doc&id=2683845.1

Oracle Fusion Middleware : CPU de avril 2020.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2633852.1

Oracle Fusion Middleware : CPU de janvier 2020.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2602410.1

Wind River Linux : solution (21/05/2019).
La solution est indiquée dans les sources d'information.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un patch de vulnérabilité de réseau. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.