L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Exiv2 : buffer overflow via Exiv2-getULong

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via Exiv2::getULong() de Exiv2, afin de mener un déni de service, et éventuellement d'exécuter du code.
Produits impactés : Debian, RHEL, Ubuntu.
Gravité de ce bulletin : 2/4.
Date de création : 22/10/2019.
Références de cette menace : CVE-2019-17402, DLA-2019-1, RHSA-2020:4030-01, USN-4159-1, VIGILANCE-VUL-30687.

Description de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via Exiv2::getULong() de Exiv2, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace sécurité concerne les logiciels ou systèmes comme Debian, RHEL, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de faille est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de vulnérabilité.

Solutions pour cette menace 

Debian 8 : nouveaux paquetages exiv2.
De nouveaux paquetages sont disponibles :
  Debian 8 : exiv2 0.24-4.1+deb8u5

RHEL 7.8 : nouveaux paquetages exiv2.
De nouveaux paquetages sont disponibles :
  RHEL 7.8 : exiv2 0.27.0-3.el7_8

Ubuntu : nouveaux paquetages exiv2.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.10 : exiv2 0.25-4ubuntu2.1
  Ubuntu 19.04 : exiv2 0.25-4ubuntu1.2
  Ubuntu 18.04 LTS : exiv2 0.25-3.1ubuntu0.18.04.4
  Ubuntu 16.04 LTS : exiv2 0.25-2.1ubuntu16.04.5
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des alertes de vulnérabilités applicatives. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.