L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données et des outils pour y remédier.

Vulnérabilité de Expat : débordement d'entier de XML

Synthèse de la vulnérabilité

Un attaquant peut provoquer un débordement d'entier dans l'analyseur XML de Expat, afin de mener un déni de service, et éventuellement d'exécuter du code.
Gravité de cette menace : 2/4.
Date création : 27/07/2015.
Références de cette faille : 1964428, 1965444, 1967199, 1969062, 1990421, 1990658, bulletinjul2016, CVE-2015-1283, DSA-3318-1, FreeBSD-SA-15:20.expat, JSA10904, openSUSE-SU-2016:1441-1, openSUSE-SU-2016:1523-1, SOL15104541, SSA:2016-359-01, SUSE-SU-2016:1508-1, SUSE-SU-2016:1512-1, USN-2726-1, USN-3013-1, VIGILANCE-VUL-17498.

Description de la vulnérabilité

Un attaquant peut provoquer un débordement d'entier dans l'analyseur XML de Expat, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin Vigil@nce complet... (Demandez votre essai gratuit)

Ce bulletin de menace informatique concerne les logiciels ou systèmes comme APR-util, Debian, BIG-IP Hardware, TMOS, FreeBSD, Android OS, Domino, Notes, Tivoli System Automation, WebSphere AS Traditional, Juniper EX-Series, Juniper J-Series, Junos OS, SRX-Series, openSUSE, openSUSE Leap, Solaris, pfSense, Python, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de vulnérabilité informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette menace sécurité.

Solutions pour cette menace

Android OS : patch 2016-11-05.
Un patch est indiqué dans les sources d'information.

Debian : nouveaux paquetages expat.
De nouveaux paquetages sont disponibles :
  Debian 7 : expat 2.1.0-1+deb7u2
  Debian 8 : expat 2.1.0-6+deb8u1

F5 BIG-IP : versions corrigées pour Expat.
Les versions corrigées sont indiquées dans les sources d'information.

FreeBSD : patch pour expat.
Un patch est disponible :
  https://security.FreeBSD.org/patches/SA-15:20/expat.patch

IBM Domino : patch pour HTTP Server.
Un patch est indiqué dans les sources d'information.

IBM Notes : patch pour expat.
Un patch est indiqué dans les sources d'information.

IBM Tivoli System Automation : patch pour Expat.
Un patch est disponible :
  http://www-01.ibm.com/support/docview.wss?uid=swg21964428
  VIGILANCE-SOL-42856

Junos OS : versions corrigées pour expat.
Les versions corrigées sont indiquées dans les sources d'information.

openSUSE : nouveaux paquetages expat.
De nouveaux paquetages sont disponibles :
  openSUSE 13.2 : expat 2.1.0-14.3.1
  openSUSE Leap 42.1 : expat 2.1.0-17.1

pfSense : version 2.2.5.
La version 2.2.5 est corrigée :
  https://pfsense.org/download/

Python : version 2.7.12.
La version 2.7.12 est corrigée :
  https://www.python.org/downloads/release/python-2712/

Python : version 3.4.5.
La version 3.4.5 est corrigée :
  https://www.python.org/ftp/python/3.4.5/Python-3.4.5.tgz

Python : version 3.5.2.
La version 3.5.2 est corrigée :
  https://www.python.org/ftp/python/3.5.2/Python-3.5.2.tgz

Slackware : nouveaux paquetages expat.
De nouveaux paquetages sont disponibles :
  Slackware 13.0 : expat 2.2.0-*-1_slack13.0
  Slackware 13.1 : expat 2.2.0-*-1_slack13.1
  Slackware 13.37 : expat 2.2.0-*-1_slack13.37
  Slackware 14.0 : expat 2.2.0-*-1_slack14.0
  Slackware 14.1 : expat 2.2.0-*-1_slack14.1
  Slackware 14.2 : expat 2.2.0-*-1_slack14.2

Solaris : patch pour logiciels tiers de juillet 2016 v2.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE : nouveaux paquetages expat.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : expat 2.1.0-17.1
  SUSE LE 11 SP4 : expat 2.0.1-88.38.1

Ubuntu : nouveaux paquetages libexpat.
De nouveaux paquetages sont disponibles :
  Ubuntu 15.04 : lib64expat1 2.1.0-6ubuntu1.1, libexpat1 2.1.0-6ubuntu1.1
  Ubuntu 14.04 LTS : lib64expat1 2.1.0-4ubuntu1.1, libexpat1 2.1.0-4ubuntu1.1
  Ubuntu 12.04 LTS : lib64expat1 2.0.1-7.2ubuntu1.2, libexpat1 2.0.1-7.2ubuntu1.2

Ubuntu : nouveaux paquetages xmlrpc-c.
De nouveaux paquetages sont disponibles :
  Ubuntu 12.04 LTS : libxmlrpc-c++4 1.16.33-3.1ubuntu5.2, libxmlrpc-core-c3 1.16.33-3.1ubuntu5.2

WebSphere AS : patch pour Expat.
Un patch est indiqué dans les sources d'information.

WebSphere AS : version 8.5.5.7.
La version 8.5.5.7 est corrigée :
  https://www-304.ibm.com/support/docview.wss?uid=swg24040533
Bulletin Vigil@nce complet... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques

Vigil@nce fournit des avis de vulnérabilités applicatives. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.