L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de FasterXML Jackson Databind : exécution de code via javax.swing.JTextPane

Synthèse de la vulnérabilité 

Un attaquant peut utiliser une vulnérabilité via javax.swing.JTextPane de FasterXML Jackson Databind, afin d'exécuter du code.
Produits impactés : Tivoli Storage Manager, openSUSE Leap, SLES.
Gravité de ce bulletin : 2/4.
Date de création : 20/01/2021.
Références de cette menace : 2854, 6410882, CERTFR-2021-AVI-101, CVE-2021-20190, openSUSE-SU-2021:0221-1, SUSE-SU-2021:0243-1, VIGILANCE-VUL-34377.

Description de la vulnérabilité 

Un attaquant peut utiliser une vulnérabilité via javax.swing.JTextPane de FasterXML Jackson Databind, afin d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette faille informatique concerne les logiciels ou systèmes comme Tivoli Storage Manager, openSUSE Leap, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de vulnérabilité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de faille informatique.

Solutions pour cette menace 

FasterXML Jackson Databind : version 2.9.10.7.
La version 2.9.10.7 est corrigée :
  https://github.com/FasterXML/jackson-databind/releases/tag/jackson-databind-2.9.10.7

FasterXML Jackson Databind : patch pour javax.swing.JTextPane.
Un patch est indiqué dans les sources d'information.

IBM Spectrum Protect Plus : versions corrigées pour Node.js/jackson-databind.
Les versions corrigées sont indiquées dans les sources d'information.

openSUSE Leap 15.2 : nouveaux paquetages jackson-databind.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : jackson-databind 2.10.5.1-lp152.2.3.1

SUSE LE 15 SP2 : nouveaux paquetages jackson-databind.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : jackson-databind 2.10.5.1-3.3.2
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des annonces de vulnérabilités de systèmes. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.