L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de FasterXML jackson-databind : exécution de code via ObjectMapper readValue Deserialization

Synthèse de la vulnérabilité 

Un attaquant peut utiliser une vulnérabilité via ObjectMapper readValue() Deserialization de FasterXML jackson-databind, afin d'exécuter du code.
Produits vulnérables : Debian, Fedora, Oracle Communications, Oracle Directory Services Plus, Oracle Fusion Middleware, Oracle GlassFish Server, Oracle Identity Management, Oracle Internet Directory, Tuxedo, Oracle Virtual Directory, WebLogic, Puppet, RHEL, JBoss EAP par Red Hat.
Gravité de cette faille : 2/4.
Date de création : 01/08/2017.
Références de ce bulletin : 5048, cpuapr2018, cpuapr2019, cpujan2019, cpujul2018, cpuoct2018, CVE-2017-7525, DLA-2091-1, DLA-2342-1, DSA-4004-1, FEDORA-2017-6a75c816fa, FEDORA-2017-8df9efed5f, FEDORA-2017-f452765e1e, FEDORA-2018-bbf8c38b51, FEDORA-2018-e4b025841e, ibm10715641, ibm10738249, RHSA-2017:1834-01, RHSA-2017:1835-01, RHSA-2017:1836-01, RHSA-2017:1837-01, RHSA-2017:1839-01, RHSA-2017:1840-01, RHSA-2017:2477-01, RHSA-2017:2546-01, RHSA-2017:2547-01, RHSA-2017:2633-01, RHSA-2017:2635-01, RHSA-2017:2636-01, RHSA-2017:2637-01, RHSA-2017:2638-01, RHSA-2017:3454-01, RHSA-2017:3455-01, RHSA-2017:3456-01, RHSA-2017:3458-01, RHSA-2018:0294-01, RHSA-2018:1447-01, RHSA-2018:1448-01, RHSA-2018:1449-01, RHSA-2018:1450-01, RHSA-2018:1451-01, VIGILANCE-VUL-23406.

Description de la vulnérabilité 

Un attaquant peut utiliser une vulnérabilité via ObjectMapper readValue() Deserialization de FasterXML jackson-databind, afin d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de menace concerne les logiciels ou systèmes comme Debian, Fedora, Oracle Communications, Oracle Directory Services Plus, Oracle Fusion Middleware, Oracle GlassFish Server, Oracle Identity Management, Oracle Internet Directory, Tuxedo, Oracle Virtual Directory, WebLogic, Puppet, RHEL, JBoss EAP par Red Hat.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de faille informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin sécurité.

Solutions pour cette menace 

Continuous Delivery for Puppet Enterprise : version 2.18.2.
La version 2.18.2 est corrigée :
  https://puppet.com/

Debian 8/9 : nouveaux paquetages jackson-databind.
De nouveaux paquetages sont disponibles :
  Debian 8 : jackson-databind 2.4.2-2+deb8u1
  Debian 9 : jackson-databind 2.8.6-1+deb9u1

Debian 8 : nouveaux paquetages libjackson-json-java.
De nouveaux paquetages sont disponibles :
  Debian 8 : libjackson-json-java 1.9.2-3+deb8u1

Debian 9 : nouveaux paquetages libjackson-json-java.
De nouveaux paquetages sont disponibles :
  Debian 9 : libjackson-json-java 1.9.2-8+deb9u1

Fedora 24 : nouveaux paquetages jackson-databind.
De nouveaux paquetages sont disponibles :
  Fedora 24 : jackson-databind 2.6.3-3.fc24

Fedora : nouveaux paquetages jackson-databind (07/02/2018).
De nouveaux paquetages sont disponibles :
  Fedora 26 : jackson-databind 2.7.6-8.fc26
  Fedora 27 : jackson-databind 2.7.6-8.fc27

Fedora : nouveaux paquetages jackson-databind (16/08/2017).
De nouveaux paquetages sont disponibles :
  Fedora 25 : jackson-databind 2.7.6-3.fc25
  Fedora 26 : jackson-databind 2.7.6-3.fc26

IBM Cognos Analytics : version 11.0.13.0.
La version 11.0.13.0 est corrigée :
  https://www-01.ibm.com/support/docview.wss?uid=ibm10718809

IBM Cognos Business Intelligence : patch.
Un patch est indiqué dans les sources d'information.

Oracle Communications : CPU de avril 2019.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2518758.1
  https://support.oracle.com/rs?type=doc&id=2518763.1
  https://support.oracle.com/rs?type=doc&id=2522151.1
  https://support.oracle.com/rs?type=doc&id=2519787.1
  https://support.oracle.com/rs?type=doc&id=2522126.1
  https://support.oracle.com/rs?type=doc&id=2522123.1
  https://support.oracle.com/rs?type=doc&id=2518753.1
  https://support.oracle.com/rs?type=doc&id=2522121.1
  https://support.oracle.com/rs?type=doc&id=2528862.1
  https://support.oracle.com/rs?type=doc&id=2518754.1

Oracle Communications : CPU de janvier 2019.
Un Critical Patch Update est disponible :
  https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html

Oracle Communications : CPU de juillet 2018.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2410237.1
  https://support.oracle.com/rs?type=doc&id=2406191.1
  https://support.oracle.com/rs?type=doc&id=2410234.1
  https://support.oracle.com/rs?type=doc&id=2408211.1
  https://support.oracle.com/rs?type=doc&id=2406689.1
  https://support.oracle.com/rs?type=doc&id=2408212.1
  https://support.oracle.com/rs?type=doc&id=2410243.1
  https://support.oracle.com/rs?type=doc&id=2410198.1

Oracle Communications : CPU de octobre 2018.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2451363.1
  https://support.oracle.com/rs?type=doc&id=2450339.1
  https://support.oracle.com/rs?type=doc&id=2450354.1
  https://support.oracle.com/rs?type=doc&id=2450340.1
  https://support.oracle.com/rs?type=doc&id=2452772.1
  https://support.oracle.com/rs?type=doc&id=2451007.1

Oracle Fusion Middleware : CPU de avril 2018.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2353306.1

Oracle Fusion Middleware : CPU de juillet 2018.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2394520.1

Oracle Fusion Middleware : CPU de octobre 2018.
Un Critical Patch Update est disponible :
  https://support.oracle.com/rs?type=doc&id=2433477.1

Puppet Enterprise : versions 2018.1.5 et 2019.0.1.
Les versions 2018.1.5 et 2019.0.1 sont corrigées :
  https://puppet.com/

Red Hat JBoss BPM Suite : version 6.4.5.
La version 6.4.5 est corrigée :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=bpm.suite&downloadType=securityPatches&version=6.4

Red Hat JBoss BRMS : version 6.4.5.
La version 6.4.5 est corrigée :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=brms&downloadType=securityPatches&version=6.4

Red Hat JBoss Data Grid : patch.
Un patch est disponible :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=data.grid&downloadType=distributions&version=7.1.2

Red Hat JBoss Data Virtualization : version 6.3 Update 7.
La version 6.3 Update 7 est corrigée :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=data.services.platform&downloadType=securityPatches&version=6.3.0

Red Hat JBoss EAP : version 6.4.20.
La version 6.4.20 est corrigée :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=appplatform&downloadType=securityPatches&version=6.4

Red Hat JBoss Enterprise Application Platform : version 6.4.17.
La version 6.4.17 est corrigée :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=appplatform&downloadType=securityPatches&version=6.4

Red Hat JBoss Enterprise Application Platform : version 7.0.7.
La version 7.0.7 est corrigée :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=appplatform&downloadType=securityPatches&version=7.0

Red Hat JBoss Enterprise Application Platform : version 7.1.0.
La version 7.1.0 est corrigée :
  https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?downloadType=distributions&product=appplatform&version=7.1

RHEL 7 : nouveaux paquetages rh-eclipse46-jackson-databind.
De nouveaux paquetages sont disponibles :
  RHEL 7 : rh-eclipse46-jackson-databind 2.6.3-2.3.el7

RHEL : nouveaux paquetages devtoolset-4-jackson-databind.
De nouveaux paquetages sont disponibles :
  RHEL 6 : devtoolset-4-jackson-databind 2.5.0-2.4.el6
  RHEL 7 : devtoolset-4-jackson-databind 2.5.0-2.4.el7

Rundeck : version 3.0.24.
La version 3.0.24 est corrigée :
  https://docs.rundeck.com/downloads.html
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des annonces de vulnérabilité de réseau. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.