L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de FreeBSD : déni de service via execve

Synthèse de la vulnérabilité 

Un attaquant peut local employer execve() à partir d'un processus multi-thread sur FreeBSD, afin de mener un déni de service.
Systèmes vulnérables : Debian, FreeBSD.
Gravité de cette menace : 1/4.
Date de création : 04/06/2014.
Références de cette faille : CVE-2014-3880, DSA-2952-1, FreeBSD-EN-14:06.exec, VIGILANCE-VUL-14840.

Description de la vulnérabilité 

Les appels système execve() et fexecve() remplacent le processus courant par une nouvelle image.

Le noyau FreeBSD optimise ce changement en remplaçant l'espace des adresses de la mémoire virtuelle (Virtual Memory Address Space). Cependant, si le processus avait des threads en fin d'exécution, ils peuvent utiliser les anciennes adresses, ce qui provoque un Triple-Fault.

Un attaquant peut local donc employer execve() à partir d'un processus multi-thread sur FreeBSD, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce de vulnérabilité informatique concerne les logiciels ou systèmes comme Debian, FreeBSD.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de vulnérabilité est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette vulnérabilité informatique.

Solutions pour cette menace 

FreeBSD : patch pour execve.
Un patch est disponible dans les sources d'information.

Debian : nouveaux paquetages kfreebsd-9.
De nouveaux paquetages sont disponibles :
  Debian 7 : kfreebsd-9 9.0-10+deb70.7
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une veille cybersécurité. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.