L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de GCC : obtention d'information via POWER9 Low Random Number Generator

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via POWER9 Low Random Number Generator de GCC, afin d'obtenir des informations sensibles.
Systèmes vulnérables : GCC, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES.
Gravité de cette menace : 2/4.
Date de création : 17/10/2019.
Références de cette faille : 91481, CVE-2019-15847, openSUSE-SU-2019:2364-1, openSUSE-SU-2019:2365-1, openSUSE-SU-2020:0716-1, RHSA-2020:0924-01, RHSA-2020:1864-01, SUSE-SU-2019:2702-1, SUSE-SU-2019:3061-1, SUSE-SU-2020:0394-1, VIGILANCE-VUL-30662.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via POWER9 Low Random Number Generator de GCC, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace cyber-sécurité concerne les logiciels ou systèmes comme GCC, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cette vulnérabilité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin de vulnérabilité.

Solutions pour cette menace 

GCC : patch pour POWER9 Low Random Number Generator.
Un patch est indiqué dans les sources d'information.

openSUSE Leap 15.1 : nouveaux paquetages gcc9.
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.

openSUSE Leap 15 : nouveaux paquetages gcc7.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : gcc7 7.4.1+r275405-lp150.12.1
  openSUSE Leap 15.1 : gcc7 7.4.1+r275405-lp151.2.6.1

RHEL 6/7 : nouveaux paquetages devtoolset-8-gcc.
De nouveaux paquetages sont disponibles :
  RHEL 6.0-6.10 : devtoolset-8-gcc 8.3.1-3.2.el6
  RHEL 7.0-7.7 : devtoolset-8-gcc 8.3.1-3.2.el7

RHEL 8 : nouveaux paquetages gcc.
De nouveaux paquetages sont disponibles :
  RHEL 8.0-8.1 : gcc 8.3.1-5.el8

SUSE LE 12 : nouveaux paquetages gcc9.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP1 : gcc9 9.2.1+r275327-1.3.9
  SUSE LE 12 SP2 : gcc9 9.2.1+r275327-1.3.9
  SUSE LE 12 SP3 : gcc9 9.2.1+r275327-1.3.9
  SUSE LE 12 SP4 : gcc9 9.2.1+r275327-1.3.9
  SUSE LE 12 SP5 : gcc9 9.2.1+r275327-1.3.9

SUSE LE 15 : nouveaux paquetages gcc7.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : gcc7 7.4.1+r275405-4.9.2
  SUSE LE 15 SP1 : gcc7 7.4.1+r275405-4.9.2

SUSE LE 15 : nouveaux paquetages gcc9.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : gcc9 9.2.1+r275327-1.3.7
  SUSE LE 15 SP1 : gcc9 9.2.1+r275327-1.3.7
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une veille de vulnérabilités de réseaux. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.