L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de GLib : lecture de fichier via file_copy_fallback

Synthèse de la vulnérabilité 

Un attaquant local peut lire un fichier via file_copy_fallback() de GLib, afin d'obtenir des informations sensibles.
Logiciels impactés : Debian, Fedora, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette vulnérabilité informatique : 2/4.
Date de création : 11/06/2019.
Références de cette annonce : bulletinjul2019, CVE-2019-12450, DLA-1826-1, FEDORA-2019-c18d2bd1bd, openSUSE-SU-2019:1650-1, RHSA-2019:3530-01, RHSA-2020:3978-01, SUSE-SU-2019:14102-1, SUSE-SU-2019:1594-1, SUSE-SU-2019:1596-1, SUSE-SU-2019:1722-1, USN-4014-1, USN-4014-2, VIGILANCE-VUL-29488.

Description de la vulnérabilité 

Un attaquant local peut lire un fichier via file_copy_fallback() de GLib, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce de faille informatique concerne les logiciels ou systèmes comme Debian, Fedora, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de vulnérabilité informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin de faille informatique.

Solutions pour cette menace 

Debian 8 : nouveaux paquetages glib2.0.
De nouveaux paquetages sont disponibles :
  Debian 8 : glib2.0 2.42.1-1+deb8u1

Fedora 30 : nouveaux paquetages glib2.
De nouveaux paquetages sont disponibles :
  Fedora 30 : glib2 2.60.4-1.fc30

openSUSE Leap 15.0 : nouveaux paquetages glib2.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : glib2 2.54.3-lp150.3.10.1

Oracle Solaris : patch pour logiciels tiers de juillet 2019 v2.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7.8 : nouveaux paquetages glib2/ibus.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.8 : glib2 2.56.1-7.el7, ibus 1.5.17-11.el7

RHEL 8 : nouveaux paquetages glib2.
De nouveaux paquetages sont disponibles :
  RHEL 8 : glib2 2.56.4-7.el8

SUSE LE 11 : nouveaux paquetages glib2.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : glib2 2.22.5-0.8.39.1
  SUSE LE 11 SP4 : glib2 2.22.5-0.8.39.1

SUSE LE 12 : nouveaux paquetages glib2.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : glib2 2.48.2-12.12.2
  SUSE LE 12 SP3 : glib2 2.48.2-12.12.2
  SUSE LE 12 SP4 : glib2 2.48.2-12.12.2
  SUSE LE 12 SP5 : glib2 2.48.2-12.12.2

SUSE LE 12 RTM/SP1 : nouveaux paquetages glib2.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : glib2 2.38.2-7.9.2
  SUSE LE 12 SP1 : glib2 2.38.2-7.9.2

SUSE LE 15 : nouveaux paquetages glib2.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : glib2 2.54.3-4.15.1
  SUSE LE 15 SP1 : glib2 2.54.3-4.15.1

Ubuntu : nouveaux paquetages libglib2.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.04 : libglib2.0 2.60.0-1ubuntu0.1
  Ubuntu 18.10 : libglib2.0 2.58.1-2ubuntu0.1
  Ubuntu 18.04 LTS : libglib2.0 2.56.4-0ubuntu0.18.04.3
  Ubuntu 16.04 LTS : libglib2.0 2.48.2-0ubuntu4.2
  Ubuntu 14.04 ESM : libglib2.0 2.40.2-0ubuntu1.1+esm1
  Ubuntu 12.04 ESM : libglib2.0 2.32.4-0ubuntu1.2

Wind River Linux : version 10.18.44.9.
La version 10.18.44.9 est corrigée :
  https://support2.windriver.com/
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une analyse de vulnérabilité informatique. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.