L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de GnuPG : création de faux messages d'état

Synthèse de la vulnérabilité 

Un attaquant peut créer de faux messages d'état dans GnuPG, afin de tromper la victime.
Produits vulnérables : Debian, VNX Operating Environment, VNX Series, Fedora, GnuPG, Junos Space, openSUSE Leap, Solaris, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Unix (plateforme) ~ non exhaustif.
Gravité de cette faille : 2/4.
Date de création : 08/06/2018.
Date de révision : 02/05/2019.
Références de ce bulletin : bulletinjul2018, CVE-2018-12020, DSA-2020-030, DSA-4222-1, DSA-4223-1, FEDORA-2018-4ef71d3525, FEDORA-2018-69780fc4d7, FEDORA-2018-a4e13742b4, JSA10917, openSUSE-SU-2018:1706-1, openSUSE-SU-2018:1708-1, openSUSE-SU-2018:1722-1, openSUSE-SU-2018:1724-1, RHSA-2018:2180-01, RHSA-2018:2181-01, SSA:2018-159-01, SSA:2018-170-01, SUSE-SU-2018:1696-1, SUSE-SU-2018:1698-1, SUSE-SU-2018:2243-1, T4012, USN-3675-1, USN-3675-2, USN-3675-3, USN-3964-1, VIGILANCE-VUL-26364.

Description de la vulnérabilité 

Un attaquant peut créer de faux messages d'état dans GnuPG, afin de tromper la victime.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace cybersécurité concerne les logiciels ou systèmes comme Debian, VNX Operating Environment, VNX Series, Fedora, GnuPG, Junos Space, openSUSE Leap, Solaris, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Unix (plateforme) ~ non exhaustif.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence débutant peut exploiter cette vulnérabilité cybersécurité.

Solutions pour cette menace 

GnuPG : version 2.2.8.
La version 2.2.8 est corrigée :
  https://gnupg.org/download/

GnuPG : version 1.4.23.
La version 1.4.23 est corrigée :
  https://www.gnupg.org/download/index.html

GnuPG : patch pour faux messages d'état.
Un patch est indiqué dans les sources d'information.

Debian 9 : nouveaux paquetages gnupg1.
De nouveaux paquetages sont disponibles :
  Debian 9 : gnupg1 1.4.21-4+deb9u1

Debian : nouveaux paquetages gnupg2.
De nouveaux paquetages sont disponibles :
  Debian 8 : gnupg2 2.0.26-6+deb8u2
  Debian 9 : gnupg2 2.1.18-8~deb9u2

Dell EMC VNXe3200 : version 3.1.11.10003441.
La version 3.1.11.10003441 est corrigée :
  https://www.dell.com/support/

Enigmail : version 2.0.7.
La version 2.0.7 est corrigée :
  https://www.enigmail.net/index.php/en/download/

Fedora 28 : nouveaux paquetages gnupg (18/06/2018).
De nouveaux paquetages sont disponibles :
  Fedora 28 : gnupg 1.4.22-7.fc28

Fedora : nouveaux paquetages gnupg (20/06/2018).
De nouveaux paquetages sont disponibles :
  Fedora 27 : gnupg 1.4.23-1.fc27
  Fedora 28 : gnupg 1.4.23-1.fc28

Junos Space : version 18.4R1.
La version 18.4R1 est corrigée.

openSUSE Leap 15.0 : nouveaux paquetages python-python-gnupg.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : python2-python-gnupg 0.4.3-lp150.2.3.1, python3-python-gnupg 0.4.3-lp150.2.3.1

openSUSE Leap : nouveaux paquetages enigmail.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : enigmail 2.0.7-21.1
  openSUSE Leap 15.0 : enigmail 2.0.7-lp150.2.12.1

openSUSE Leap : nouveaux paquetages gpg2.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : gpg2 2.0.24-9.3.1
  openSUSE Leap 15.0 : gpg2 2.2.5-lp150.3.3.1

Oracle Solaris : patch pour logiciels tiers de juillet 2018 v1.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL : nouveaux paquetages gnupg2.
De nouveaux paquetages sont disponibles :
  RHEL 6 : gnupg2 2.0.14-9.el6_10
  RHEL 7 : gnupg2 2.0.22-5.el7_5

Slackware : nouveaux paquetages gnupg.
De nouveaux paquetages sont disponibles :
  Slackware 13.0 : gnupg 1.4.23-*-1_slack13.0
  Slackware 13.1 : gnupg 1.4.23-*-1_slack13.1
  Slackware 13.37 : gnupg 1.4.23-*-1_slack13.37
  Slackware 14.0 : gnupg 1.4.23-*-1_slack14.0
  Slackware 14.1 : gnupg 1.4.23-*-1_slack14.1
  Slackware 14.2 : gnupg 1.4.23-*-1_slack14.2

Slackware : nouveaux paquetages gnupg2.
De nouveaux paquetages sont disponibles :
  Slackware 13.37 : gnupg2 2.0.31-*-1_slack13.37
  Slackware 14.0 : gnupg2 2.0.31-*-1_slack14.0
  Slackware 14.1 : gnupg2 2.0.31-*-1_slack14.1
  Slackware 14.2 : gnupg2 2.0.31-*-1_slack14.2

SUSE LE 11 SP3/4 : nouveaux paquetages gpg2.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP3 : gpg2 2.0.9-25.33.42.3.1
  SUSE LE 11 SP4 : gpg2 2.0.9-25.33.42.3.1

SUSE LE 12 : nouveaux paquetages enigmail.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM-SP3 : enigmail 2.0.7-18.1

SUSE LE 12 : nouveaux paquetages gpg2.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : gpg2 2.0.24-9.3.1
  SUSE LE 12 SP1 : gpg2 2.0.24-9.3.1
  SUSE LE 12 SP2 : gpg2 2.0.24-9.3.1
  SUSE LE 12 SP3 : gpg2 2.0.24-9.3.1

SUSE LE 15 : nouveaux paquetages enigmail.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : enigmail 2.0.7-3.7.2

Ubuntu : nouveaux paquetages gnupg.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : gnupg 2.2.4-1ubuntu1.1, gpg 2.2.4-1ubuntu1.1
  Ubuntu 17.10 : gnupg 2.1.15-1ubuntu8.1
  Ubuntu 16.04 LTS : gnupg 1.4.20-1ubuntu3.2, gnupg2 2.1.11-6ubuntu2.1
  Ubuntu 14.04 LTS : gnupg 1.4.16-1ubuntu2.5, gnupg2 2.0.22-3ubuntu1.4
  Ubuntu 12.04 ESM : gnupg 1.4.11-3ubuntu2.11

Ubuntu : nouveaux paquetages python-gnupg.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.04 : python-gnupg 0.4.3-1ubuntu1.19.04.1, python3-gnupg 0.4.3-1ubuntu1.19.04.1
  Ubuntu 18.10 : python-gnupg 0.4.1-1ubuntu1.18.10.1, python3-gnupg 0.4.1-1ubuntu1.18.10.1
  Ubuntu 18.04 LTS : python-gnupg 0.4.1-1ubuntu1.18.04.1, python3-gnupg 0.4.1-1ubuntu1.18.04.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une analyse de vulnérabilités logicielles. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.