L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Go : erreur d'assertion via dsa.Verify

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une erreur d'assertion via dsa.Verify() de Go, afin de mener un déni de service.
Systèmes vulnérables : Debian, Docker CE, IBM API Connect, openSUSE Leap, RHEL, SLES.
Gravité de cette menace : 2/4.
Date de création : 28/10/2019.
Références de cette faille : 1283668, CVE-2019-17596, DSA-4551-1, ESA-2019-15, ESA-2019-16, openSUSE-SU-2019:2521-1, openSUSE-SU-2019:2522-1, RHSA-2020:0329-01, SUSE-SU-2019:2940-1, VIGILANCE-VUL-30722.

Description de la vulnérabilité 

Un attaquant peut provoquer une erreur d'assertion via dsa.Verify() de Go, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte cyber-sécurité concerne les logiciels ou systèmes comme Debian, Docker CE, IBM API Connect, openSUSE Leap, RHEL, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cette menace cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte de menace.

Solutions pour cette menace 

Cloud Foundry : versions corrigées pour Go.
Les versions corrigées sont indiquées dans les sources d'information.

Debian 10 : nouveaux paquetages golang-1.11.
De nouveaux paquetages sont disponibles :
  Debian 10 : golang-1.11 1.11.6-1+deb10u3

Docker Engine/Moby : version 19.03.9.
La version 19.03.9 est corrigée.

Elastic Beats Metricbeat : version 7.5.0.
La version 7.5.0 est corrigée :
  https://www.elastic.co/

IBM API Connect : patch pour Golang.
Un patch est indiqué dans les sources d'information.

openSUSE Leap 15 : nouveaux paquetages go1.12.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : go1.12 1.12.12-lp150.11.1
  openSUSE Leap 15.1 : go1.12 1.12.12-lp151.2.25.1

RHEL 8.1 : nouveau module go-toolset-rhel8.
Le module suivant est mis à jour :
  RHEL 8.1 Module : go-toolset:rhel8

SUSE LE 15 : nouveaux paquetages go1.12.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : go1.12 1.12.12-1.20.1
  SUSE LE 15 SP1 : go1.12 1.12.12-1.20.1

Wind River Linux : version 10.17.41.19.
La version 10.17.41.19 est corrigée.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des annonces de vulnérabilité applicative. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.