L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de HAProxy : obtention d'information via Authorization Header

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via Authorization Header de HAProxy, afin d'obtenir des informations sensibles.
Produits vulnérables : Fedora, openSUSE Leap, RHEL, SLES, Ubuntu.
Gravité de cette faille : 2/4.
Date de création : 28/05/2018.
Références de ce bulletin : CVE-2018-11469, FEDORA-2018-941d094624, openSUSE-SU-2018:3324-1, RHSA-2019:1436-01, SUSE-SU-2018:3249-1, USN-3663-1, VIGILANCE-VUL-26244.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès aux données via Authorization Header de HAProxy, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis cybersécurité concerne les logiciels ou systèmes comme Fedora, openSUSE Leap, RHEL, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette menace cyber-sécurité.

Solutions pour cette menace 

HAProxy : patch pour Authorization Header.
Un patch est indiqué dans les sources d'information.

Fedora 28 : nouveaux paquetages haproxy.
De nouveaux paquetages sont disponibles :
  Fedora 28 : haproxy 1.8.12-2.fc28

openSUSE Leap 15.0 : nouveaux paquetages haproxy.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : haproxy 1.8.14~git0.52e4d43b-lp150.2.3.1

RHEL 7 : nouveaux paquetages rh-haproxy18-haproxy.
De nouveaux paquetages sont disponibles :
  RHEL 7 : rh-haproxy18-haproxy 1.8.17-1.el7

SUSE LE 15 : nouveaux paquetages haproxy.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : haproxy 1.8.14~git0.52e4d43b-3.3.2

Ubuntu : nouveaux paquetages haproxy.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : haproxy 1.8.8-1ubuntu0.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un correctif de vulnérabilités logicielles. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.