L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de HP Diagnostics Server, LoadRunner : buffer overflow via magentservice.exe

Synthèse de la vulnérabilité 

Un attaquant non authentifié peut envoyer un paquet illicite vers HP Diagnostics Server ou LoadRunner, afin de provoquer un buffer overflow, conduisant à un déni de service ou à l'exécution de code.
Logiciels vulnérables : HP Diagnostics, LoadRunner.
Gravité de cette annonce : 3/4.
Date de création : 13/01/2012.
Références de cette vulnérabilité informatique : BID-51398, c03216705, CVE-2011-4789, HPSBMU02785, SSRT100526, VIGILANCE-VUL-11281, ZDI-12-016.

Description de la vulnérabilité 

Le service magentservice.exe de HP Diagnostics Server écoute sur le port 23472.

Ce service analyse les messages reçus sur le port : les 32 premiers bits indiquent une taille, qui est décrémentée de un, avant d'être utilisée pour copier les données qui suivent. Par exemple, si le paquet commence par 0x00000000, la copie tente de s'effectuer sur 0xFFFFFFFF octets, ce qui corrompt la mémoire.

Un attaquant non authentifié peut donc envoyer un paquet illicite vers HP Diagnostics Server, afin de provoquer un buffer overflow, conduisant à un déni de service ou à l'exécution de code.

Cette vulnérabilité impacte aussi HP LoadRunner.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte cybersécurité concerne les logiciels ou systèmes comme HP Diagnostics, LoadRunner.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de menace est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client intranet.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence technicien peut exploiter cette annonce de menace informatique.

Solutions pour cette menace 

HP Diagnostics Server : contre-mesure pour magentservice.exe.
Une contre-mesure consiste à filtrer les accès sur le port 23472.

HP LoadRunner : version 11.00 patch 4.
La version 11.00 patch 4 est corrigée :
  http://support.openview.hp.com/selfsolve/patches
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un bulletin de vulnérabilité informatique. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.