L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de HP-UX, Bind : dénis de service

Synthèse de la vulnérabilité 

Un attaquant distant peut stopper Bind en lui envoyant des données incorrectes.
Systèmes vulnérables : HP-UX.
Gravité de cette menace : 3/4.
Date de création : 08/02/2005.
Date de révision : 01/03/2005.
Références de cette faille : BID-12497, CVE-2005-0364, HP01117, V6-HPBIND920REQUIRE, VIGILANCE-VUL-4730.

Description de la vulnérabilité 

La macro REQUIRE, définie dans le code source de Bind, permet de tester les conditions d'entrée des fonctions et de stopper le serveur lorsqu'une erreur grave se produit. La macro INSIST est similaire.

La macro REQUIRE est appelée dans lib/isc/task.c (pseudo code) :
  REQUIRE(task != 0 ET magic == "TASK");
Un attaquant peut envoyer des données DNS spéciales rendant cette condition valide. Le serveur se stoppe alors.

Le fichier name.c, qui emploie la macro INSIST, est sujet à une attaque similaire.

Ces vulnérabilités permettent donc à un attaquant distant de mener un déni de service en stoppant le serveur. Il faut noter que cette vulnérabilité est différente de VIGILANCE-VUL-4692.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de faille concerne les logiciels ou systèmes comme HP-UX.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis cybersécurité est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de serveur internet.

Un attaquant avec un niveau de compétence expert peut exploiter cette annonce de faille.

Solutions pour cette menace 

HP-UX : version Bind.
Des nouvelles versions et patches sont disponibles :
HP-UX B.11.00 :
  nouvelle version BIND 9.2.0 B.11.00.01.004 http://software.hp.com/
HP-UX B.11.11 :
  nouvelle version BIND 9.2.0 B.11.11.01.006 http://software.hp.com/
HP-UX B.11.22 :
  InternetSrvcs.INETSVCS2-RUN : patch PHNE_32783
HP-UX B.11.23 :
  patch PHNE_32443 http://itrc.hp.com/
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une analyse cybersécurité. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.