L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de ICU : débordement d'entier via UnicodeString-doAppend

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un débordement d'entier via UnicodeString::doAppend() de ICU, afin de mener un déni de service, et éventuellement d'exécuter du code.
Produits impactés : Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de ce bulletin : 2/4.
Date de création : 17/03/2020.
Références de cette menace : CVE-2020-10531, DLA-2151-1, DSA-4646-1, FEDORA-2020-39e0b8bd14, openSUSE-SU-2020:0459-1, RHSA-2020:0896-01, RHSA-2020:0897-01, RHSA-2020:0901-01, RHSA-2020:0902-01, RHSA-2020:1293-01, RHSA-2020:1317-01, RHSA-2020:1343-01, SUSE-SU-2020:1180-1, USN-4305-1, VIGILANCE-VUL-31815.

Description de la vulnérabilité 

Un attaquant peut provoquer un débordement d'entier via UnicodeString::doAppend() de ICU, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de menace concerne les logiciels ou systèmes comme Debian, Fedora, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte de vulnérabilité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de menace informatique.

Solutions pour cette menace 

Debian 8 : nouveaux paquetages icu.
De nouveaux paquetages sont disponibles :
  Debian 8 : icu 52.1-8+deb8u8

Debian 9/10 : nouveaux paquetages icu.
De nouveaux paquetages sont disponibles :
  Debian 9 : icu 57.1-6+deb9u4
  Debian 10 : icu 63.1-6+deb10u1

Fedora 30 : nouveaux paquetages chromium.
De nouveaux paquetages sont disponibles :
  Fedora 30 : chromium 80.0.3987.149-1.fc30

openSUSE Leap 15.1 : nouveaux paquetages icu.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : icu 60.2-lp151.3.11.1

RHEL 6.10 : nouveaux paquetages icu.
De nouveaux paquetages sont disponibles :
  RHEL 6.10 : icu 4.2.1-15.el6_10

RHEL 7.7 : nouveaux paquetages icu.
De nouveaux paquetages sont disponibles :
  RHEL 7.7 : icu 50.2-4.el7_7

RHEL 8.0 : nouveau module nodejs-10.
Le module suivant est mis à jour :
  RHEL 8.0 Module : nodejs:10

RHEL 8.0 : nouveaux paquetages icu.
De nouveaux paquetages sont disponibles :
  RHEL 8.0 : icu 60.3-2.el8_0

RHEL 8.1 : nouveau module nodejs-10.
Le module suivant est mis à jour :
  RHEL 8.1 Module : nodejs:10

RHEL 8.1 : nouveau module nodejs-12.
Le module suivant est mis à jour :
  RHEL 8.1 Module : nodejs:12

RHEL 8.1 : nouveaux paquetages icu.
De nouveaux paquetages sont disponibles :
  RHEL 8.1 : icu 60.3-2.el8_1

SUSE LE 12 : nouveaux paquetages icu.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : icu 52.1-8.10.1
  SUSE LE 12 SP4 : icu 52.1-8.10.1
  SUSE LE 12 SP3 : libicu52_1 52.1-8.10.1
  SUSE LE 12 SP2 : libicu52_1 52.1-8.10.1
  SUSE LE 12 SP1 : icu 52.1-8.10.1

Ubuntu : nouveaux paquetages libicu.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.10 : libicu63 63.2-2ubuntu0.1
  Ubuntu 18.04 LTS : libicu60 60.2-3ubuntu3.1
  Ubuntu 16.04 LTS : libicu55 55.1-7ubuntu0.5
  Ubuntu 14.04 ESM : libicu52 52.1-3ubuntu0.8+esm1
  Ubuntu 12.04 ESM : libicu48 4.8.1.1-3ubuntu0.10

Wind River Linux : version 10.18.44.17.
La version 10.18.44.17 est corrigée :
  https://support2.windriver.com/

Wind River Linux : version 10.19.45.8.
La version 10.19.45.8 est corrigée.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un correctif de vulnérabilité de logiciel. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.