L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Java Web Start : buffer overflow de JNLP

Synthèse de la vulnérabilité 

Un attaquant peut créer un fichier JNLP illicite afin de faire exécuter du code sur la machine des victimes ayant Java Web Start installé.
Produits vulnérables : openSUSE, Java Oracle, RHEL, SLES.
Gravité de cette faille : 3/4.
Date de création : 10/07/2007.
Dates de révisions : 11/07/2007, 12/07/2007.
Références de ce bulletin : 102958, 102996, 6490790, 6501487, BID-24832, CVE-2007-3655, RHSA-2007:0829-01, SUSE-SA:2007:056, VIGILANCE-VUL-6978.

Description de la vulnérabilité 

Le protocole JNLP (Java Networking Launching Protocol) permet d'exécuter des applets distantes sans les installer. Java Web Start est automatiquement appelé lorsque l'utilisateur clique sur un fichier portant l'extension ".jnlp", ou reçoit un fichier avec le Content-Type "application/x-java-jnlp-file".

Lorsqu'un fichier JLNP possède un attribut "codebase" de plus de 1024 caractères, un buffer overflow se produit dans javaws.exe. Ce débordement conduit à l'exécution de code, si l'attaque emploie uniquement des caractères ascii.

Un attaquant peut donc créer un fichier JNLP illicite afin de faire exécuter du code sur la machine des victimes ayant Java Web Start installé.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace concerne les logiciels ou systèmes comme openSUSE, Java Oracle, RHEL, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce cyber-sécurité est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence technicien peut exploiter cette faille informatique.

Solutions pour cette menace 

Java JDK/JRE : version 6.0 Update 2.
La version 6.0 Update 2 est corrigée :
  http://java.sun.com/javase/downloads/index.jsp
  http://java.sun.com/javase/6/webnotes/ReleaseNotes.html
Pour Solaris :
  Sparc :
    32 bits : patch 125136-04
    64 bits : patch 125137-04
  x86 :
    32 bits : patch 125138-04
    64 bits : patch 125139-04

JDK, JRE : version 5.0 Update 12.
La version 5.0 Update 12 est corrigée :
  http://java.sun.com/javase/downloads/index_jdk5.jsp
Il faut ensuite regénérer tous les documents créés par JavaDoc.

RHEL 4, 5 : nouveaux paquetages java-1.5.0-ibm.
De nouveaux paquetages sont disponibles :
Red Hat Enterprise Linux version 4: java-1.5.0-ibm-1.5.0.5-1jpp.2.el4
Red Hat Enterprise Linux version 5: java-1.5.0-ibm-1.5.0.5-1jpp.0.1.el5

SUSE : nouveaux paquetages IBM Java.
De nouveaux paquetages sont disponibles :
   UnitedLinux 1.0
     http://support.novell.com/techcenter/psdb/4931a7f4cae4a43064c21ec2362f54e5.html
     http://support.novell.com/techcenter/psdb/1d3d4cc05bdfc425f875a1d8a7ef9b7e.html
   SuSE Linux Openexchange Server 4
     http://support.novell.com/techcenter/psdb/4931a7f4cae4a43064c21ec2362f54e5.html
     http://support.novell.com/techcenter/psdb/1d3d4cc05bdfc425f875a1d8a7ef9b7e.html
   Open Enterprise Server
     http://support.novell.com/techcenter/psdb/1d3d4cc05bdfc425f875a1d8a7ef9b7e.html
   Novell Linux POS 9
     http://support.novell.com/techcenter/psdb/1d3d4cc05bdfc425f875a1d8a7ef9b7e.html
   SuSE Linux Enterprise Server 8
     http://support.novell.com/techcenter/psdb/4931a7f4cae4a43064c21ec2362f54e5.html
     http://support.novell.com/techcenter/psdb/1d3d4cc05bdfc425f875a1d8a7ef9b7e.html
   SuSE Linux Standard Server 8
     http://support.novell.com/techcenter/psdb/4931a7f4cae4a43064c21ec2362f54e5.html
     http://support.novell.com/techcenter/psdb/1d3d4cc05bdfc425f875a1d8a7ef9b7e.html
   SuSE Linux School Server
     http://support.novell.com/techcenter/psdb/4931a7f4cae4a43064c21ec2362f54e5.html
     http://support.novell.com/techcenter/psdb/1d3d4cc05bdfc425f875a1d8a7ef9b7e.html
   SUSE LINUX Retail Solution 8
     http://support.novell.com/techcenter/psdb/4931a7f4cae4a43064c21ec2362f54e5.html
     http://support.novell.com/techcenter/psdb/1d3d4cc05bdfc425f875a1d8a7ef9b7e.html
   SUSE SLES 9
     http://support.novell.com/techcenter/psdb/1d3d4cc05bdfc425f875a1d8a7ef9b7e.html
   SLE SDK 10 SP1
     http://support.novell.com/techcenter/psdb/51fd7d03020fe413e43cda8f60442612.html
   SUSE Linux Enterprise Server 10 SP1
     http://support.novell.com/techcenter/psdb/51fd7d03020fe413e43cda8f60442612.html
     http://support.novell.com/techcenter/psdb/5544d25cb52fbadcc4de5bfd2d3654a1.html
   SUSE Linux Enterprise Desktop 10 SP1
     http://support.novell.com/techcenter/psdb/5544d25cb52fbadcc4de5bfd2d3654a1.html
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un bulletin cybersécurité. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.