L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de LibTIFF : erreur d'assertion via TIFFWriteDirectorySec

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une erreur d'assertion via TIFFWriteDirectorySec() de LibTIFF, afin de mener un déni de service.
Systèmes vulnérables : Debian, LibTIFF, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette menace : 2/4.
Date de création : 31/08/2017.
Références de cette faille : 2727, bulletinjan2018, bulletinjul2018, CVE-2017-13726, DLA-1093-1, DSA-4100-1, openSUSE-SU-2018:1834-1, SUSE-SU-2018:1826-1, USN-3602-1, VIGILANCE-VUL-23654.

Description de la vulnérabilité 

Un attaquant peut provoquer une erreur d'assertion via TIFFWriteDirectorySec() de LibTIFF, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de faille informatique concerne les logiciels ou systèmes comme Debian, LibTIFF, openSUSE Leap, Solaris, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de faille informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis cyber-sécurité.

Solutions pour cette menace 

LibTIFF : tif_dirwrite.c version 1.88.
La version 1.88 de tif_dirwrite.c est corrigée.

Debian 7 : nouveaux paquetages tiff.
De nouveaux paquetages sont disponibles :
  Debian 7 : tiff 4.0.2-6+deb7u16

Debian : nouveaux paquetages tiff.
De nouveaux paquetages sont disponibles :
  Debian 8 : tiff 4.0.3-12.3+deb8u5
  Debian 9 : tiff 4.0.8-2+deb9u2

openSUSE Leap 42.3 : nouveaux paquetages tiff.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : tiff 4.0.9-31.1

Oracle Solaris : patch pour logiciels tiers de janvier 2018 v3.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Oracle Solaris : patch pour logiciels tiers de juillet 2018 v2.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE 12 SP3 : nouveaux paquetages tiff (28/06/2018).
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : libtiff 4.0.9-44.15.2

Ubuntu : nouveaux paquetages libtiff5.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : libtiff5 4.0.6-1ubuntu0.3
  Ubuntu 14.04 LTS : libtiff5 4.0.3-7ubuntu0.8

Wind River Linux : solution de fin-octobre 2017.
La solution est indiquée dans les sources d'information.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une analyse de vulnérabilités informatiques. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.