L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de LibVNC : obtention d'information via rfbSendServerCutText

Synthèse de la vulnérabilité 

Un attaquant local peut lire un fragment de la mémoire via rfbSendServerCutText() de LibVNC, afin d'obtenir des informations sensibles.
Produits vulnérables : Debian, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette faille : 1/4.
Date de création : 30/10/2019.
Références de ce bulletin : CVE-2019-15681, DLA-1977-1, DLA-1979-1, DLA-2014-1, DLA-2045-1, openSUSE-SU-2020:0624-1, openSUSE-SU-2020:1071-1, SUSE-SU-2020:0955-1, SUSE-SU-2020:1164-1, SUSE-SU-2020:1164-2, SUSE-SU-2020:1165-1, SUSE-SU-2020:14355-1, SUSE-SU-2020:2009-1, USN-4407-1, USN-4547-1, USN-4573-1, USN-4587-1, VIGILANCE-VUL-30750.

Description de la vulnérabilité 

Un attaquant local peut lire un fragment de la mémoire via rfbSendServerCutText() de LibVNC, afin d'obtenir des informations sensibles.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte de vulnérabilité informatique concerne les logiciels ou systèmes comme Debian, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte de faille est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte sécurité.

Solutions pour cette menace 

Debian 8 : nouveaux paquetages italc.
De nouveaux paquetages sont disponibles :
  Debian 8 : italc 1:2.0.2+dfsg1-2+deb8u1

Debian 8 : nouveaux paquetages libvncserver.
De nouveaux paquetages sont disponibles :
  Debian 8 : libvncserver 0.9.9+dfsg2-6.1+deb8u6

Debian 8 : nouveaux paquetages tightvnc.
De nouveaux paquetages sont disponibles :
  Debian 8 : tightvnc 1.3.9-6.5+deb8u1

Debian 8 : nouveaux paquetages vino.
De nouveaux paquetages sont disponibles :
  Debian 8 : vino 3.14.0-2+deb8u1

openSUSE Leap 15.1 : nouveaux paquetages LibVNCServer.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : libvncclient0 0.9.10-lp151.7.3.1, libvncserver0 0.9.10-lp151.7.3.1

openSUSE Leap 15.1 : nouveaux paquetages vino.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : vino 3.22.0-lp151.4.3.1

SUSE LE 12 SP4/5 : nouveaux paquetages vino.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : vino 3.20.2-7.3.21
  SUSE LE 12 SP5 : vino 3.20.2-7.3.21

SUSE LE 15 SP1 : nouveaux paquetages LibVNCServer.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : LibVNCServer 0.9.10-4.14.1

SUSE LE 15 SP1 : nouveaux paquetages vino.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : vino 3.22.0-3.6.76

SUSE LE : nouveaux paquetages LibVNCServer.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : libvncclient0 0.9.10-4.14.1, libvncserver0 0.9.10-4.14.1
  SUSE LE 15 SP1 : libvncclient0 0.9.10-4.14.1, libvncserver0 0.9.10-4.14.1
  SUSE LE 12 SP5 : libvncclient0 0.9.9-17.19.1, libvncserver0 0.9.9-17.19.1
  SUSE LE 12 SP4 : libvncclient0 0.9.9-17.19.1, libvncserver0 0.9.9-17.19.1
  SUSE LE 12 SP3 : libvncclient0 0.9.9-17.19.1, libvncserver0 0.9.9-17.19.1
  SUSE LE 12 SP2 : libvncclient0 0.9.9-17.19.1, libvncserver0 0.9.9-17.19.1
  SUSE LE 12 SP1 : libvncclient0 0.9.9-17.19.1, libvncserver0 0.9.9-17.19.1
  SUSE LE 11 SP4 : LibVNCServer 0.9.1-160.14.1

Ubuntu 16.04 : nouveaux paquetages italc.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : italc 1:2.0.2+dfsg1-4ubuntu0.1

Ubuntu 18.04 : nouveaux paquetages italc.
De nouveaux paquetages sont disponibles :
  Ubuntu 18.04 LTS : italc 1:3.0.3+dfsg1-3ubuntu0.1

Ubuntu : nouveaux paquetages LibVNCServer.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.04 LTS : libvncclient1 0.9.12+dfsg-9ubuntu0.1, libvncserver1 0.9.12+dfsg-9ubuntu0.1
  Ubuntu 19.10 : libvncclient1 0.9.11+dfsg-1.3ubuntu0.1, libvncserver1 0.9.11+dfsg-1.3ubuntu0.1
  Ubuntu 18.04 LTS : libvncclient1 0.9.11+dfsg-1ubuntu1.2, libvncserver1 0.9.11+dfsg-1ubuntu1.2
  Ubuntu 16.04 LTS : libvncclient1 0.9.10+dfsg-3ubuntu0.16.04.4, libvncserver1 0.9.10+dfsg-3ubuntu0.16.04.4

Ubuntu : nouveaux paquetages vino.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.04 LTS : vino 3.22.0-5ubuntu2.1
  Ubuntu 18.04 LTS : vino 3.22.0-3ubuntu1.1
  Ubuntu 16.04 LTS : vino 3.8.1-0ubuntu9.3
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un bulletin de vulnérabilité de système. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.