L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de LibVNCServer : cinq vulnérabilités

Synthèse de la vulnérabilité 

Un attaquant peut employer plusieurs vulnérabilités de LibVNCServer.
Logiciels impactés : Debian, openSUSE Leap, Ubuntu.
Gravité de cette vulnérabilité informatique : 2/4.
Nombre de vulnérabilités dans ce bulletin : 5.
Date de création : 04/12/2015.
Références de cette annonce : CVE-2014-6051, CVE-2014-6052, CVE-2014-6053, CVE-2014-6054, CVE-2014-6055, DLA-1979-1, DLA-2014-1, DLA-2045-1, openSUSE-SU-2015:2207-1, USN-4573-1, USN-4587-1, VIGILANCE-VUL-18442.

Description de la vulnérabilité 

Plusieurs vulnérabilités ont été annoncées dans LibVNCServer.

Un attaquant peut provoquer un débordement d'entier dans MallocFrameBuffer, afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:2/4; CVE-2014-6051]

Un attaquant peut provoquer une corruption de mémoire dans malloc, afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:2/4; CVE-2014-6052]

Un attaquant peut provoquer une erreur fatale dans ClientCutText, afin de mener un déni de service. [grav:2/4; CVE-2014-6053]

Un attaquant peut provoquer une erreur fatale dans Scaling Factor, afin de mener un déni de service. [grav:2/4; CVE-2014-6054]

Un attaquant peut provoquer un buffer overflow dans File Transfer, afin de mener un déni de service, et éventuellement d'exécuter du code. [grav:2/4; CVE-2014-6055]
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette annonce sécurité concerne les logiciels ou systèmes comme Debian, openSUSE Leap, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de vulnérabilité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client intranet.

Ce bulletin concerne 5 vulnérabilités.

Un attaquant avec un niveau de compétence expert peut exploiter ce bulletin de faille.

Solutions pour cette menace 

Debian 8 : nouveaux paquetages italc.
De nouveaux paquetages sont disponibles :
  Debian 8 : italc 1:2.0.2+dfsg1-2+deb8u1

Debian 8 : nouveaux paquetages tightvnc.
De nouveaux paquetages sont disponibles :
  Debian 8 : tightvnc 1.3.9-6.5+deb8u1

Debian 8 : nouveaux paquetages vino.
De nouveaux paquetages sont disponibles :
  Debian 8 : vino 3.14.0-2+deb8u1

openSUSE Leap 42.1 : nouveaux paquetages LibVNCServer.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : LibVNCServer 0.9.9-13.1

Ubuntu 16.04 : nouveaux paquetages italc.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : italc 1:2.0.2+dfsg1-4ubuntu0.1

Ubuntu : nouveaux paquetages vino.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.04 LTS : vino 3.22.0-5ubuntu2.1
  Ubuntu 18.04 LTS : vino 3.22.0-3ubuntu1.1
  Ubuntu 16.04 LTS : vino 3.8.1-0ubuntu9.3
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des alertes de vulnérabilités de systèmes. L'équipe Vigil@nce surveille les vulnérabilités informatiques de systèmes et d'applications.