L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de LibreOffice : utilisation de mémoire libérée via StgSmallStrm

Synthèse de la vulnérabilité 

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via StgSmallStrm de LibreOffice, afin de mener un déni de service, et éventuellement d'exécuter du code.
Systèmes vulnérables : Debian, LibreOffice, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette menace : 2/4.
Date de création : 16/04/2018.
Références de cette faille : CVE-2018-10119, DLA-1356-1, DSA-4178-1, openSUSE-SU-2018:1311-1, RHSA-2018:3054-01, SUSE-SU-2018:1296-1, USN-3883-1, VIGILANCE-VUL-25880.

Description de la vulnérabilité 

Un attaquant peut provoquer l'utilisation d'une zone mémoire libérée via StgSmallStrm de LibreOffice, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de vulnérabilité informatique concerne les logiciels ou systèmes comme Debian, LibreOffice, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de document.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de faille.

Solutions pour cette menace 

LibreOffice : versions 5.4.5 et 6.0.1.
Les versions 5.4.5 et 6.0.1 sont corrigées :
  https://www.libreoffice.org/download/download/

LibreOffice : patch pour StgSmallStrm.
Un patch est indiqué dans les sources d'information.

Debian 7 : nouveaux paquetages libreoffice.
De nouveaux paquetages sont disponibles :
  Debian 7 : libreoffice 1:3.5.4+dfsg2-0+deb7u11

Debian 8/9 : nouveaux paquetages libreoffice.
De nouveaux paquetages sont disponibles :
  Debian 8 : libreoffice 1:4.3.3-2+deb8u11
  Debian 9 : libreoffice 1:5.2.7-1+deb9u4

openSUSE Leap 42.3 : nouveaux paquetages libreoffice.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.3 : libreoffice 6.0.4.2-21.1

RHEL 7 : nouveaux paquetages libreoffice.
De nouveaux paquetages sont disponibles :
  RHEL 7 : libreoffice 5.3.6.1-19.el7

SUSE LE 12 SP3 : nouveaux paquetages libreoffice.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP3 : libreoffice 6.0.4.2-43.33.1

Ubuntu : nouveaux paquetages libreoffice-core.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : libreoffice-core 1:5.1.6~rc2-0ubuntu1~xenial6
  Ubuntu 14.04 LTS : libreoffice-core 1:4.2.8-0ubuntu5.5
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une annonce cybersécurité. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.