L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Mercurial : création de fichier via symlink

Synthèse de la vulnérabilité 

Un attaquant peut utiliser un lien symbolique avec Mercurial, afin de créer un fichier hors du dépôt.
Logiciels impactés : Debian, Fedora, Solaris, RHEL, Slackware, Unix (plateforme) ~ non exhaustif.
Gravité de cette vulnérabilité informatique : 2/4.
Date de création : 16/08/2017.
Références de cette annonce : bulletinjan2019, bulletinjul2017, CVE-2017-1000115, DLA-1072-1, DSA-3963-1, FEDORA-2017-f03b04acbb, FEDORA-2017-fa1d8ad61a, RHSA-2017:2489-01, SSA:2017-223-03, VIGILANCE-VUL-23536.

Description de la vulnérabilité 

Un attaquant peut utiliser un lien symbolique avec Mercurial, afin de créer un fichier hors du dépôt.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de faille concerne les logiciels ou systèmes comme Debian, Fedora, Solaris, RHEL, Slackware, Unix (plateforme) ~ non exhaustif.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte de faille informatique.

Solutions pour cette menace 

Mercurial : version 4.3.
La version 4.3 est corrigée :
  https://www.mercurial-scm.org/

Debian 7 : nouveaux paquetages mercurial.
De nouveaux paquetages sont disponibles :
  Debian 7 : mercurial 2.2.2-4+deb7u5

Debian 8/9 : nouveaux paquetages mercurial.
De nouveaux paquetages sont disponibles :
  Debian 8 : mercurial 3.1.2-2+deb8u4
  Debian 9 : mercurial 4.0-1+deb9u1

Fedora : nouveaux paquetages mercurial.
De nouveaux paquetages sont disponibles :
  Fedora 25 : mercurial 3.8.1-4.fc25
  Fedora 26 : mercurial 4.2.3-1.fc26

Oracle Solaris : patch pour logiciels tiers de janvier 2019 v3.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

Oracle Solaris : patch pour logiciels tiers de juillet 2017 v4.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1
  11.3 SRU 24

RHEL 7.4 : nouveaux paquetages mercurial.
De nouveaux paquetages sont disponibles :
  RHEL 7 : mercurial 2.6.2-8.el7_4

Slackware : nouveaux paquetages mercurial.
De nouveaux paquetages sont disponibles :
  Slackware 14.0 : mercurial 4.3.1-*-1_slack14.0
  Slackware 14.1 : mercurial 4.3.1-*-1_slack14.1
  Slackware 14.2 : mercurial 4.3.1-*-1_slack14.2
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un bulletin de vulnérabilité de logiciel. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.