L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Mozilla NSS : buffer overflow via Cryptographic Primitives

Synthèse de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via Cryptographic Primitives de Mozilla NSS, afin de mener un déni de service, et éventuellement d'exécuter du code.
Produits vulnérables : Debian, NSS, openSUSE Leap, RHEL, RSA Authentication Manager, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette faille : 3/4.
Date de création : 31/12/2019.
Références de ce bulletin : CVE-2019-17006, DLA-2058-1, DLA-2388-1, DSA-2020-066, DSA-2020-067, DSA-4726-1, openSUSE-SU-2020:0008-1, openSUSE-SU-2020:0854-1, RHSA-2020:3280-01, RHSA-2020:4076-01, SUSE-SU-2019:3395-1, SUSE-SU-2020:14418-1, SUSE-SU-2020:1677-1, SUSE-SU-2020:1839-1, USN-4231-1, VIGILANCE-VUL-31248.

Description de la vulnérabilité 

Un attaquant peut provoquer un buffer overflow via Cryptographic Primitives de Mozilla NSS, afin de mener un déni de service, et éventuellement d'exécuter du code.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte sécurité concerne les logiciels ou systèmes comme Debian, NSS, openSUSE Leap, RHEL, RSA Authentication Manager, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin cybersécurité est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de vulnérabilité informatique.

Solutions pour cette menace 

Mozilla NSS : version 3.46.
La version 3.46 est corrigée :
  https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS

Debian 10 : nouveaux paquetages nss.
De nouveaux paquetages sont disponibles :
  Debian 10 : nss 2:3.42.1-1+deb10u3

Debian 8 : nouveaux paquetages nss.
De nouveaux paquetages sont disponibles :
  Debian 8 : nss 2:3.26-1+debu8u10

Debian 9 : nouveaux paquetages nss.
De nouveaux paquetages sont disponibles :
  Debian 9 : nss 2:3.26.2-1.1+deb9u2

openSUSE Leap 15.1 : nouveaux paquetages mozilla-nspr (13/01/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : mozilla-nspr 4.23-lp151.2.6.1, mozilla-nss 3.47.1-lp151.2.9.1

openSUSE Leap 15.1 : nouveaux paquetages mozilla-nspr (24/06/2020).
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : mozilla-nspr 4.25-lp151.2.9.1, mozilla-nss 3.53-lp151.2.23.1

RHEL 7.9 : nouveaux paquetages nss/nspr.
De nouveaux paquetages sont disponibles :
  RHEL 7.9 : nspr 4.25.0-2.el7_9, nss 3.53.1-3.el7_9

RHEL 8.2 : nouveaux paquetages nss/nspr.
De nouveaux paquetages sont disponibles :
  RHEL 8.2 : nspr 4.25.0-2.el8_2, nss 3.53.1-11.el8_2

RSA Authentication Manager : version 8.4 P11.
La version 8.4 P11 est corrigée :
  https://www.dell.com/support/

SUSE LE 11 SP4 : nouveaux paquetages mozilla-nspr/mozilla-nss.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : mozilla-nspr 4.25-29.12.2, mozilla-nss 3.53.1-38.23.1

SUSE LE 12 : nouveaux paquetages mozilla-nspr/mozilla-nss.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP2 : mozilla-nspr 4.25-19.15.1, mozilla-nss 3.53.1-58.48.1
  SUSE LE 12 SP3 : mozilla-nspr 4.25-19.15.1, mozilla-nss 3.53.1-58.48.1
  SUSE LE 12 SP4 : mozilla-nspr 4.25-19.15.1, mozilla-nss 3.53.1-58.48.1
  SUSE LE 12 SP5 : mozilla-nspr 4.25-19.15.1, mozilla-nss 3.53.1-58.48.1

SUSE LE 15 : nouveaux paquetages mozilla-nspr / mozilla-nss.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : mozilla-nspr 4.25-3.12.1, mozilla-nss 3.53-3.40.1
  SUSE LE 15 SP1 : mozilla-nspr 4.25-3.12.1, mozilla-nss 3.53-3.40.1
  SUSE LE 15 SP2 : mozilla-nspr 4.25-3.12.1, mozilla-nss 3.53-3.40.1

SUSE LE 15 : nouveaux paquetages mozilla-nspr, mozilla-nss.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : mozilla-nspr 4.23-3.9.1, mozilla-nss 3.47.1-3.22.1
  SUSE LE 15 SP1 : mozilla-nspr 4.23-3.9.1, mozilla-nss 3.47.1-3.22.1

Ubuntu : nouveaux paquetages libnss3.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.10 : libnss3 2:3.45-1ubuntu2.2
  Ubuntu 19.04 : libnss3 2:3.42-1ubuntu2.5
  Ubuntu 18.04 LTS : libnss3 2:3.35-2ubuntu2.7
  Ubuntu 16.04 LTS : libnss3 2:3.28.4-0ubuntu0.16.04.10
  Ubuntu 14.04 ESM : libnss3 2:3.28.4-0ubuntu0.14.04.5+esm4
  Ubuntu 12.04 ESM : libnss3 2:3.28.4-0ubuntu0.12.04.7
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des alertes de vulnérabilité de réseau. La base de vulnérabilités Vigil@nce contient plusieurs milliers de failles.