L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de MySQL : élévation de privilèges via la réplication

Synthèse de la vulnérabilité 

Un attaquant local ayant un accès sur un serveur MySQL primaire peut exécuter du code SQL sur un serveur secondaire en version supérieure.
Produits impactés : Fedora, MySQL Community, MySQL Enterprise, openSUSE, Percona Server.
Gravité de ce bulletin : 2/4.
Date de création : 04/10/2010.
Références de cette menace : 49124, BID-43677, CVE-2009-5026, FEDORA-2010-15147, FEDORA-2010-15166, openSUSE-SU-2012:0617-1, VIGILANCE-VUL-9999.

Description de la vulnérabilité 

La réplication MySQL permet de copier des données d'un serveur primaire vers un serveur secondaire. Le code SQL est exécuté sur le serveur secondaire avec les privilèges SUPER, car il s'est d'abord exécuté avec succès sur le primaire.

MySQL supporte des commentaires indiquant du code SQL à exécuter sur une version spécifique :
  /*!5.1.40 ici du SQL pour les versions supérieures à 5.1.40 */

Lorsque le serveur secondaire a une version de MySQL supérieure au serveur primaire, un attaquant peut utiliser un commentaire contenant du code destiné au serveur secondaire uniquement. Etant donné que ce code est exécuté avec les privilèges SUPER, l'attaquant peut ainsi élever ses privilèges sur le serveur secondaire.

Un attaquant local ayant un accès sur un serveur MySQL primaire peut donc exécuter du code SQL sur un serveur secondaire en version supérieure.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette faille concerne les logiciels ou systèmes comme Fedora, MySQL Community, MySQL Enterprise, openSUSE, Percona Server.

Notre équipe Vigil@nce a déterminé que la gravité de cette vulnérabilité cyber-sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de compte utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte cybersécurité.

Solutions pour cette menace 

MySQL : version 5.1.50.
La version 5.1.50 est corrigée :
  http://dev.mysql.com/

MySQL : version 5.0.93.
La version 5.0.93 est corrigée :
  http://dev.mysql.com/downloads/

Fedora : nouveaux paquetages mysql.
De nouveaux paquetages sont disponibles :
  mysql-5.1.50-2.fc13
  mysql-5.1.50-2.fc14

openSUSE : nouveaux paquetages mysql-cluster.
De nouveaux paquetages sont disponibles :
  openSUSE 11.4 : mysql-cluster-7.1.21-52.1
  openSUSE 12.1 : mysql-cluster-7.1.21-2.4.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des bulletins de vulnérabilité de réseau. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.