L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de MySQL : multiples dénis de service

Synthèse de la vulnérabilité 

Un attaquant local peut employer des requêtes illicites, afin de stopper MySQL.
Logiciels vulnérables : Debian, Fedora, Mandriva Linux, MySQL Community, MySQL Enterprise, openSUSE, Percona Server, RHEL, SLES.
Gravité de cette annonce : 1/4.
Nombre de vulnérabilités dans ce bulletin : 8.
Date de création : 29/09/2010.
Références de cette vulnérabilité informatique : 52512, 52711, 54007, 54044, 54393, 54477, 54575, 55039, CVE-2010-3676, CVE-2010-3677, CVE-2010-3678, CVE-2010-3679, CVE-2010-3680, CVE-2010-3681, CVE-2010-3682, CVE-2010-3683, DSA-2143-1, FEDORA-2010-15147, FEDORA-2010-15166, MDVSA-2010:155-1, MDVSA-2010:222, MDVSA-2011:012, openSUSE-SU-2010:0730-1, openSUSE-SU-2010:0731-1, RHSA-2010:0824-01, RHSA-2010:0825-01, RHSA-2011:0164-01, SUSE-SR:2010:019, SUSE-SR:2010:021, VIGILANCE-VUL-9985.

Description de la vulnérabilité 

Plusieurs dénis de service ont été annoncés dans MySQL.

Un attaquant peut modifier les valeurs de innodb_file_format et innodb_file_per_table, puis employer une requête DDL afin de stopper le serveur. [grav:1/4; 55039, CVE-2010-3676]

Un attaquant peut employer JOIN et SET, afin de stopper le serveur. [grav:1/4; 54575, CVE-2010-3677]

Un attaquant peut employer CASE ou IN, afin de stopper le serveur. [grav:1/4; 54477, CVE-2010-3678]

Un attaquant peut employer BINLOG, afin de stopper le serveur. [grav:1/4; 54393, CVE-2010-3679]

Un attaquant peut employer une table InnoDB TEMPORARY, afin de stopper le serveur. [grav:1/4; 54044, CVE-2010-3680]

Un attaquant peut employer HANDLER, afin de stopper le serveur. [grav:1/4; 54007, CVE-2010-3681]

Un attaquant peut employer EXPLAIN, afin de stopper le serveur. [grav:1/4; 52711, CVE-2010-3682]

Un attaquant peut employer LOAD DATA INFILE, afin de stopper le serveur. [grav:1/4; 52512, CVE-2010-3683]

Un attaquant local peut donc employer des requêtes illicites, afin de stopper MySQL.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin cybersécurité concerne les logiciels ou systèmes comme Debian, Fedora, Mandriva Linux, MySQL Community, MySQL Enterprise, openSUSE, Percona Server, RHEL, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin sécurité est faible.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de compte utilisateur.

Ce bulletin concerne 8 vulnérabilités.

Un attaquant avec un niveau de compétence expert peut exploiter cette menace informatique.

Solutions pour cette menace 

MySQL : version 5.1.49.
La version 5.1.49 est corrigée :
  http://dev.mysql.com/downloads/mysql/

MySQL : version 5.0.92.
La version 5.0.92 est corrigée :
  http://www.mysql.com/
  http://dev.mysql.com/

Debian : nouveaux paquetages mysql-dfsg-5.0.
De nouveaux paquetages sont disponibles :
  mysql-dfsg-5.0 5.0.51a-24+lenny5

Fedora : nouveaux paquetages mysql.
De nouveaux paquetages sont disponibles :
  mysql-5.1.50-2.fc13
  mysql-5.1.50-2.fc14

Mandriva 2009.0, C4, MES5 : nouveaux paquetages mysql.
De nouveaux paquetages sont disponibles :
  Mandriva Linux 2009.0: mysql-5.0.91-0.1mdv2009.0
  Corporate 4.0: mysql-5.0.91-0.1.20060mlcs4
  Mandriva Enterprise Server 5: mysql-5.0.91-0.1mdvmes5.1

Mandriva 2009.1 : nouveaux paquetages mysql.
De nouveaux paquetages sont disponibles :
Mandriva Linux 2009.1:
  mysql-5.1.42-0.6mdv2009.1

Mandriva : nouveaux paquetages mysql.
De nouveaux paquetages sont disponibles :
Mandriva Linux 2010.0:
  mysql-5.1.54-0.1mdv2010.0
Mandriva Linux 2010.1:
  mysql-5.1.54-0.1mdv2010.2

openSUSE : nouveaux paquetages mysql.
De nouveaux paquetages sont disponibles :
  openSUSE 11.1 : mysql-5.0.67-12.18.1
  openSUSE 11.2 : mysql-5.1.49-0.1.1

RHEL 4 : nouveaux paquetages mysql.
De nouveaux paquetages sont disponibles :
  mysql-4.1.22-2.el4_8.4

RHEL 5 : nouveaux paquetages mysql.
De nouveaux paquetages sont disponibles :
  mysql-5.0.77-4.el5_5.4

RHEL 6.0 : nouveaux paquetages mysql.
De nouveaux paquetages sont disponibles :
  mysql-5.1.52-1.el6_0.1

SUSE : nouveaux paquetages (16/11/2010).
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.

SUSE : nouveaux paquetages (25/10/2010).
De nouveaux paquetages sont disponibles, comme indiqué dans les sources d'informations.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un bulletin de vulnérabilités de réseaux. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.