L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de MySQL : multiples vulnérabilités de avril 2016

Synthèse de la vulnérabilité 

Un attaquant peut employer plusieurs vulnérabilités de MySQL.
Logiciels impactés : Mac OS X, Debian, Unisphere EMC, BIG-IP Hardware, TMOS, Fedora, MariaDB ~ précis, MySQL Community, MySQL Enterprise, openSUSE, openSUSE Leap, Percona Server, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette vulnérabilité informatique : 3/4.
Nombre de vulnérabilités dans ce bulletin : 31.
Date de création : 12/04/2016.
Date de révision : 20/04/2016.
Références de cette annonce : 2014202, CERTFR-2016-AVI-138, cpuapr2016, CVE-2015-3194, CVE-2016-0639, CVE-2016-0640, CVE-2016-0641, CVE-2016-0642, CVE-2016-0643, CVE-2016-0644, CVE-2016-0646, CVE-2016-0647, CVE-2016-0648, CVE-2016-0649, CVE-2016-0650, CVE-2016-0651, CVE-2016-0652, CVE-2016-0653, CVE-2016-0654, CVE-2016-0655, CVE-2016-0656, CVE-2016-0657, CVE-2016-0658, CVE-2016-0659, CVE-2016-0661, CVE-2016-0662, CVE-2016-0663, CVE-2016-0665, CVE-2016-0666, CVE-2016-0667, CVE-2016-0668, CVE-2016-0705, CVE-2016-2047, CVE-2016-3461, DLA-447-1, DSA-2020-062, DSA-3557-1, DSA-3595-1, FEDORA-2016-1aaf308de4, FEDORA-2016-7c48036d73, FEDORA-2016-dfa325d31b, HT209139, openSUSE-SU-2016:1332-1, openSUSE-SU-2016:1664-1, openSUSE-SU-2016:1686-1, RHSA-2016:0705-01, RHSA-2016:1132-01, RHSA-2016:1480-01, RHSA-2016:1481-01, SOL01409145, SUSE-SU-2016:1279-1, SUSE-SU-2016:1619-1, SUSE-SU-2016:1620-1, USN-2953-1, USN-2954-1, VIGILANCE-VUL-19342.

Description de la vulnérabilité 

Un attaquant peut employer plusieurs vulnérabilités de MySQL.

Un attaquant peut employer une vulnérabilité de Server: Packaging, afin d'obtenir des informations, d'altérer des informations, ou de mener un déni de service. [grav:3/4; CVE-2016-0705]

Un attaquant peut employer une vulnérabilité de Server: Pluggable Authentication, afin d'obtenir des informations, d'altérer des informations, ou de mener un déni de service. [grav:3/4; CVE-2016-0639]

Un attaquant peut employer une vulnérabilité de Server: Security: Encryption, afin de mener un déni de service. [grav:3/4; CVE-2015-3194]

Un attaquant peut employer une vulnérabilité de Monitoring: Server, afin d'obtenir des informations, d'altérer des informations, ou de mener un déni de service. [grav:3/4; CVE-2016-3461]

Un attaquant peut employer une vulnérabilité de Server: DML, afin d'altérer des informations, ou de mener un déni de service. [grav:2/4; CVE-2016-0640]

Un attaquant peut employer une vulnérabilité de Server: Connection Handling, afin d'altérer des informations. [grav:2/4; CVE-2016-2047]

Un attaquant peut employer une vulnérabilité de Server: DDL, afin de mener un déni de service. [grav:2/4; CVE-2016-0644]

Un attaquant peut employer une vulnérabilité de Server: DML, afin de mener un déni de service. [grav:2/4; CVE-2016-0646]

Un attaquant peut employer une vulnérabilité de Server: DML, afin de mener un déni de service. [grav:2/4; CVE-2016-0652]

Un attaquant peut employer une vulnérabilité de Server: FTS, afin de mener un déni de service. [grav:2/4; CVE-2016-0647]

Un attaquant peut employer une vulnérabilité de Server: FTS, afin de mener un déni de service. [grav:2/4; CVE-2016-0653]

Un attaquant peut employer une vulnérabilité de Server: InnoDB, afin de mener un déni de service. [grav:2/4; CVE-2016-0654]

Un attaquant peut employer une vulnérabilité de Server: InnoDB, afin de mener un déni de service. [grav:2/4; CVE-2016-0656]

Un attaquant peut employer une vulnérabilité de Server: JSON, afin d'obtenir des informations. [grav:2/4; CVE-2016-0657]

Un attaquant peut employer une vulnérabilité de Server: Optimizer, afin de mener un déni de service. [grav:2/4; CVE-2016-0658]

Un attaquant peut employer une vulnérabilité de Server: Optimizer, afin de mener un déni de service. [grav:2/4; CVE-2016-0651]

Un attaquant peut employer une vulnérabilité de Server: Optimizer, afin de mener un déni de service. [grav:2/4; CVE-2016-0659]

Un attaquant peut employer une vulnérabilité de Server: PS, afin de mener un déni de service. [grav:2/4; CVE-2016-0648]

Un attaquant peut employer une vulnérabilité de Server: PS, afin de mener un déni de service. [grav:2/4; CVE-2016-0649]

Un attaquant peut employer une vulnérabilité de Server: Partition, afin de mener un déni de service. [grav:2/4; CVE-2016-0662]

Un attaquant peut employer une vulnérabilité de Server: Replication, afin de mener un déni de service. [grav:2/4; CVE-2016-0650]

Un attaquant peut employer une vulnérabilité de Server: Security: Encryption, afin de mener un déni de service. [grav:2/4; CVE-2016-0665]

Un attaquant peut employer une vulnérabilité de Security, afin de mener un déni de service. [grav:2/4; CVE-2016-0666]

Un attaquant peut employer une vulnérabilité de Server: MyISAM, afin d'obtenir des informations, ou de mener un déni de service. [grav:2/4; CVE-2016-0641]

Un attaquant peut employer une vulnérabilité de Server: Federated, afin d'altérer des informations, ou de mener un déni de service. [grav:2/4; CVE-2016-0642]

Un attaquant peut employer une vulnérabilité de Server: InnoDB, afin de mener un déni de service. [grav:2/4; CVE-2016-0655]

Un attaquant peut employer une vulnérabilité de Server: Options, afin de mener un déni de service. [grav:2/4; CVE-2016-0661]

Un attaquant peut employer une vulnérabilité de Server: Performance Schema, afin de mener un déni de service. [grav:2/4; CVE-2016-0663]

Un attaquant peut employer une vulnérabilité de Server: Locking, afin de mener un déni de service. [grav:2/4; CVE-2016-0667]

Un attaquant peut employer une vulnérabilité de Server: InnoDB, afin de mener un déni de service. [grav:2/4; CVE-2016-0668]

Un attaquant peut employer une vulnérabilité de Server: DML, afin d'obtenir des informations. [grav:1/4; CVE-2016-0643]
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cet avis de faille informatique concerne les logiciels ou systèmes comme Mac OS X, Debian, Unisphere EMC, BIG-IP Hardware, TMOS, Fedora, MariaDB ~ précis, MySQL Community, MySQL Enterprise, openSUSE, openSUSE Leap, Percona Server, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette annonce de faille informatique est important.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de compte utilisateur.

Ce bulletin concerne 31 vulnérabilités.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis cyber-sécurité.

Solutions pour cette menace 

MySQL : version 5.7.12.
La version 5.7.12 est corrigée :
  http://dev.mysql.com/downloads/mysql/

MySQL : version 5.6.30.
La version 5.6.30 est corrigée :
  http://dev.mysql.com/downloads/mysql/

MySQL : version 5.5.49.
La version 5.5.49 est corrigée :
  http://dev.mysql.com/downloads/mysql/

Apple macOS : version 10.14.
La version 10.14 est corrigée :
  https://support.apple.com/

Debian 8 : nouveaux paquetages mariadb-10.0.
De nouveaux paquetages sont disponibles :
  Debian 8 : mariadb-10.0 10.0.25-0+deb8u1

Debian : nouveaux paquetages mysql-5.5.
De nouveaux paquetages sont disponibles :
  Debian 7 : mysql-5.5 5.5.49-0+deb7u1
  Debian 8 : mysql-5.5 5.5.49-0+deb8u1

Dell EMC Unisphere for PowerMax : solution.
La solution est indiquée dans les sources d'information.

F5 BIG-IP : solution pour MySQL.
La solution est indiquée dans les sources d'information.

Fedora : nouveaux paquetages community-mysql.
De nouveaux paquetages sont disponibles :
  Fedora 22 : community-mysql 5.6.30-1.fc22
  Fedora 23 : community-mysql 5.6.30-1.fc23
  Fedora 24 : community-mysql 5.7.12-1.fc24

IBM Cognos Business Intelligence : solution.
La solution est indiquée dans les sources d'information.

openSUSE : nouveaux paquetages mariadb.
De nouveaux paquetages sont disponibles :
  openSUSE 13.2 : mariadb 10.0.25-2.24.1
  openSUSE Leap 42.1 : mariadb 10.0.25-6.1

openSUSE : nouveaux paquetages mysql-community-server.
De nouveaux paquetages sont disponibles :
  openSUSE 13.2 : mysql-community-server 5.6.30-2.20.2
  openSUSE Leap 42.1 : mysql-community-server 5.6.30-16.2

Percona Server : version 5.5.49-37.9.
La version 5.5.49-37.9 est corrigée :
  https://www.percona.com/software/percona-server

Percona Server : version 5.6.30-76.3.
La version 5.6.30-76.3 est corrigée :
  https://www.percona.com/downloads/Percona-Server-5.6/Percona-Server-5.6.30-76.3/

Percona Server : version 5.7.12-5.
La version 5.7.12-5 est corrigée :
  https://www.percona.com/software/percona-server

RHEL : nouveaux paquetages mariadb55-mariadb (25/07/2016).
De nouveaux paquetages sont disponibles :
  RHEL 6 : mariadb55-mariadb 5.5.49-1.el6
  RHEL 7 : mariadb55-mariadb 5.5.49-1.el7

RHEL : nouveaux paquetages mysql55-mysql.
De nouveaux paquetages sont disponibles :
  RHEL 6 : mysql55-mysql 5.5.50-1.el6
  RHEL 7 : mysql55-mysql 5.5.50-1.el7

RHEL : nouveaux paquetages rh-mariadb100-mariadb.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-mariadb100-mariadb 10.0.25-4.el6
  RHEL 7 : rh-mariadb100-mariadb 10.0.25-4.el7

RHEL : nouveaux paquetages rh-mysql56-mysql.
De nouveaux paquetages sont disponibles :
  RHEL 6 : rh-mysql56-mysql 5.6.30-1.el6
  RHEL 7 : rh-mysql56-mysql 5.6.30-1.el7

SUSE LE 11 SP4 : nouveaux paquetages mysql.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : mysql 5.5.49-0.20.1

SUSE LE : nouveaux paquetages mariadb.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : mariadb 10.0.25-20.6.1
  SUSE LE 12 SP1 : mariadb 10.0.25-6.1

Ubuntu : nouveaux paquetages mysql-server-5.7.
De nouveaux paquetages sont disponibles :
  Ubuntu 16.04 LTS : mysql-server-5.7 5.7.12-0ubuntu1

Ubuntu : nouveaux paquetages mysql-server-5.x.
De nouveaux paquetages sont disponibles :
  Ubuntu 15.10 : mysql-server-5.6 5.6.30-0ubuntu0.15.10.1
  Ubuntu 14.04 LTS : mysql-server-5.5 5.5.49-0ubuntu0.14.04.1
  Ubuntu 12.04 LTS : mysql-server-5.5 5.5.49-0ubuntu0.12.04.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une contre-mesure de vulnérabilité de système. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.