L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de NTP.org : modification de l'heure via Small-step/Big-step

Synthèse de la vulnérabilité 

Un attaquant peut se positionner en Man-in-the-Middle de NTP.org, afin de changer l'heure locale.
Systèmes impactés : CheckPoint IP Appliance, IPSO, XenServer, Fedora, FreeBSD, AIX, Meinberg NTP Server, NTP.org, openSUSE, openSUSE Leap, Solaris, Slackware, SUSE Linux Enterprise Desktop, SLES.
Gravité de cette alerte : 2/4.
Date de création : 08/01/2016.
Références de cette alerte : 2956, bulletinjan2016, CTX220112, CVE-2015-5300, FEDORA-2016-34bc10a2c8, FreeBSD-SA-16:02.ntp, openSUSE-SU-2016:1292-1, openSUSE-SU-2016:1329-1, openSUSE-SU-2016:1423-1, sk109942, SSA:2016-054-04, SUSE-SU-2016:1175-1, SUSE-SU-2016:1177-1, SUSE-SU-2016:1247-1, SUSE-SU-2016:1278-1, SUSE-SU-2016:1291-1, SUSE-SU-2016:1311-1, SUSE-SU-2016:1471-1, SUSE-SU-2016:1912-1, SUSE-SU-2016:2094-1, VIGILANCE-VUL-18665.

Description de la vulnérabilité 

Le démon ntpd de NTP.org gère l'heure locale en recevant des informations provenant de plusieurs serveurs de temps de strate supérieure.

Cependant, si un attaquant se positionne en Man-in-the-middle, et envoie des informations incohérentes vers NTP.org, le démon redémarre. Ensuite, durant le redémarrage, l'attaquant peut continuer à usurper les serveurs de strate supérieure, pour modifier l'heure. Si ntpd est démarré sans l'option "-g", le changement d'heure est limité à 900 secondes.

Un attaquant peut donc se positionner en Man-in-the-Middle de NTP.org, afin de changer l'heure locale.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Ce bulletin de vulnérabilité concerne les logiciels ou systèmes comme CheckPoint IP Appliance, IPSO, XenServer, Fedora, FreeBSD, AIX, Meinberg NTP Server, NTP.org, openSUSE, openSUSE Leap, Solaris, Slackware, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de cette alerte cyber-sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de serveur internet.

Un attaquant avec un niveau de compétence expert peut exploiter cette annonce cybersécurité.

Solutions pour cette menace 

NTP.org : version 4.2.8p5.
La version 4.2.8p5 est corrigée :
  http://support.ntp.org/bin/view/Main/SoftwareDownloads

AIX : patch pour NTP.
Un patch est indiqué dans les sources d'information.

Check Point IPSO : solution pour NTP.
La solution est indiquée dans les sources d'information.

Citrix XenServer : solution.
La solution est indiquée dans les sources d'information.

Fedora 22 : nouveaux paquetages ntp.
De nouveaux paquetages sont disponibles :
  Fedora 22 : ntp 4.2.6p5-36.fc22

FreeBSD : patch pour ntp.
Un patch est disponible :
  https://security.FreeBSD.org/patches/SA-16:02/ntp-9.patch
  https://security.FreeBSD.org/patches/SA-16:02/ntp-10.patch

Meinberg NTP Server : solution.
La solution est indiquée dans les sources d'information.

openSUSE 13.2 : nouveaux paquetages ntp.
De nouveaux paquetages sont disponibles :
  openSUSE 13.2 : ntp 4.2.8p7-25.15.1

openSUSE Leap 42.1 : nouveaux paquetages ntp.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 42.1 : ntp 4.2.8p6-15.1

Slackware : nouveaux paquetages ntp.
De nouveaux paquetages sont disponibles :
  Slackware 13.0 : ntp 4.2.8p6-*-1_slack13.0
  Slackware 13.1 : ntp 4.2.8p6-*-1_slack13.1
  Slackware 13.37 : ntp 4.2.8p6-*-1_slack13.37
  Slackware 14.0 : ntp 4.2.8p6-*-1_slack14.0
  Slackware 14.1 : ntp 4.2.8p6-*-1_slack14.1

Solaris : patch pour Third Party 03/2016.
Un patch est disponible :
  https://support.oracle.com/rs?type=doc&id=1448883.1

SUSE LE 10 SP4 : nouveaux paquetages ntp.
De nouveaux paquetages sont disponibles :
  SUSE LE 10 SP4 : ntp 4.2.8p8-0.7.1

SUSE LE 10 SP4 : nouveaux paquetages yast2-ntp-client.
De nouveaux paquetages sont disponibles :
  SUSE LE 10 SP4 : yast2-ntp-client 2.13.18-0.20.1

SUSE LE 11 SP2/3 : nouveaux paquetages ntp.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP2 : ntp 4.2.8p6-41.1
  SUSE LE 11 SP3 : ntp 4.2.8p6-41.1

SUSE LE : nouveaux paquetages ntp.
De nouveaux paquetages sont disponibles :
  SUSE LE 11 SP4 : ntp 4.2.8p7-11.1, ntp 4.2.8p6-8.2
  SUSE LE 12 RTM : ntp 4.2.8p6-46.5.2
  SUSE LE 12 SP1 : ntp 4.2.8p6-8.2
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit un patch de vulnérabilité applicative. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.