L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Nettle : Man-in-the-Middle via Signature Verification Functions

Synthèse de la vulnérabilité 

Un attaquant peut se positionner en Man-in-the-Middle via Signature Verification Functions sur Nettle, afin de lire ou modifier des données de la session.
Logiciels impactés : Debian, BIG-IP Hardware, TMOS, Fedora, openSUSE Leap, RHEL, SIMATIC, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette vulnérabilité informatique : 2/4.
Date de création : 09/04/2021.
Références de cette annonce : CVE-2021-20305, DSA-4933-1, FEDORA-2021-454a0f6f76, K33101555, openSUSE-SU-2021:0635-1, RHSA-2021:1145-01, RHSA-2021:1206-01, RHSA-2021:1245-01, RHSA-2021:1246-01, RHSA-2021:2280-01, RHSA-2021:2356-01, SSA:2021-145-01, SSB-439005, SUSE-SU-2021:1399-1, SUSE-SU-2021:1412-1, USN-4906-1, VIGILANCE-VUL-35038.

Description de la vulnérabilité 

Un attaquant peut se positionner en Man-in-the-Middle via Signature Verification Functions sur Nettle, afin de lire ou modifier des données de la session.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette faille concerne les logiciels ou systèmes comme Debian, BIG-IP Hardware, TMOS, Fedora, openSUSE Leap, RHEL, SIMATIC, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cette vulnérabilité cyber-sécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de serveur internet.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte cybersécurité.

Solutions pour cette menace 

Debian 10 : nouveaux paquetages nettle.
De nouveaux paquetages sont disponibles :
  Debian 10 : nettle 3.4.1-1+deb10u1

F5 BIG-IP : solution pour Nettle.
La solution est indiquée dans les sources d'information.

Fedora 33 : nouveaux paquetages gnutls.
De nouveaux paquetages sont disponibles :
  Fedora 33 : gnutls 3.6.16-1.fc33

openSUSE Leap 15.2 : nouveaux paquetages libnettle.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : libnettle6 3.4.1-lp152.4.3.1

RHEL 7.6 : nouveaux paquetages nettle.
De nouveaux paquetages sont disponibles :
  RHEL 7.6 : nettle 2.7.1-9.el7_6

RHEL 7.7 : nouveaux paquetages nettle.
De nouveaux paquetages sont disponibles :
  RHEL 7.7 : nettle 2.7.1-9.el7_7

RHEL 7.9 : nouveaux paquetages nettle.
De nouveaux paquetages sont disponibles :
  RHEL 7.9 : nettle 2.7.1-9.el7_9

RHEL 8.1-8.2 : nouveaux paquetages gnutls/nettle.
De nouveaux paquetages sont disponibles :
  RHEL 8.1 : gnutls 3.6.8-10.el8_1, nettle 3.4.1-2.el8_1
  RHEL 8.2 : gnutls 3.6.8-12.el8_2, nettle 3.4.1-2.el8_2

RHEL 8.3 : nouveaux paquetages gnutls/nettle.
De nouveaux paquetages sont disponibles :
  RHEL 8.3 : gnutls 3.6.14-8.el8_3, nettle 3.4.1-4.el8_3

SIMATIC S7-1500 CPU 1518 : contre-mesure pour GNU/Linux Vulnerabilities.
Une contre-mesure est indiquée dans la source d'information.

Slackware : nouveaux paquetages gnutls.
De nouveaux paquetages sont disponibles :
  Slackware 14.2 : gnutls 3.6.16-*-1_slack14.2

SUSE LE 12 : nouveaux paquetages libnettle.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : libnettle4 2.7.1-13.3.1
  SUSE LE 12 SP4 : libnettle4 2.7.1-13.3.1
  SUSE LE 12 SP3 : libnettle4 2.7.1-13.3.1
  SUSE LE 12 SP2 : libnettle 2.7.1-13.3.1

SUSE LE 15 : nouveaux paquetages libnettle.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : libnettle6 3.4.1-4.15.1
  SUSE LE 15 SP1 : libnettle6 3.4.1-4.15.1
  SUSE LE 15 SP2 : libnettle6 3.4.1-4.15.1
  SUSE LE 15 SP3 : libnettle6 3.4.1-4.15.1

Ubuntu : nouveaux paquetages libnettle.
De nouveaux paquetages sont disponibles :
  Ubuntu 20.10 : libnettle8 3.6-2ubuntu0.1
  Ubuntu 20.04 LTS : libnettle7 3.5.1+really3.5.1-2ubuntu0.1
  Ubuntu 18.04 LTS : libnettle6 3.4-1ubuntu0.1
  Ubuntu 16.04 LTS : libnettle6 3.2-1ubuntu0.16.04.2
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des avis de vulnérabilité applicative. La veille sécurité Vigil@nce publie des bulletins de vulnérabilités pour les failles qui impactent le système d'information.