L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Node.js fstream : élévation de privilèges via File Overwrite

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions via File Overwrite de Node.js fstream, afin d'élever ses privilèges.
Systèmes impactés : Nodejs Modules ~ non exhaustif, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette alerte : 2/4.
Date de création : 15/05/2019.
Références de cette alerte : CVE-2019-13173, NPM-886, openSUSE-SU-2019:1846-1, openSUSE-SU-2019:1907-1, SUSE-SU-2019:2055-1, SUSE-SU-2019:2078-1, SUSE-SU-2019:2081-1, SUSE-SU-2019:2099-1, SUSE-SU-2019:2181-1, SUSE-SU-2020:0059-1, USN-4123-1, VIGILANCE-VUL-29315.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions via File Overwrite de Node.js fstream, afin d'élever ses privilèges.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace sécurité concerne les logiciels ou systèmes comme Nodejs Modules ~ non exhaustif, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de faille est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client internet.

Un attaquant avec un niveau de compétence expert peut exploiter cet avis de vulnérabilité.

Solutions pour cette menace 

Node.js fstream : version 1.0.12.
La version 1.0.12 est corrigée :
  https://www.npmjs.com/package/fstream

openSUSE Leap 15.1 : nouveaux paquetages nodejs10.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : nodejs10 10.16.0-lp151.2.3.1

openSUSE Leap : nouveaux paquetages nodejs8.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.0 : nodejs8 8.15.1-lp150.2.16.1
  openSUSE Leap 15.1 : nodejs8 8.15.1-lp151.2.3.1

SUSE LE 12 : nouveaux paquetages nodejs10.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM-SP5 : nodejs10 10.16.0-1.9.1

SUSE LE 12 : nouveaux paquetages nodejs12.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM-SP5 : nodejs12 12.13.0-1.3.1

SUSE LE 12 : nouveaux paquetages nodejs4.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM-SP5 : nodejs4 4.9.1-15.23.1

SUSE LE 12 : nouveaux paquetages nodejs6.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM-SP5 : nodejs6 6.17.0-11.27.1

SUSE LE 15 : nouveaux paquetages nodejs10.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : nodejs10 10.16.0-1.9.1
  SUSE LE 15 SP1 : nodejs10 10.16.0-1.9.1

SUSE LE 15 : nouveaux paquetages nodejs8.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : nodejs8 8.15.1-3.17.1
  SUSE LE 15 SP1 : nodejs8 8.15.1-3.17.1

Ubuntu : nouveaux paquetages node-fstream.
De nouveaux paquetages sont disponibles :
  Ubuntu 19.04 : node-fstream 1.0.10-1ubuntu0.19.04.2
  Ubuntu 18.04 LTS : node-fstream 1.0.10-1ubuntu0.18.04.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des bulletins cybersécurité. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.