L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Node.js minimist : déni de service via Prototype Pollution

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une erreur fatale via Prototype Pollution de Node.js minimist, afin de mener un déni de service.
Produits vulnérables : Nodejs Modules ~ non exhaustif, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES.
Gravité de cette faille : 2/4.
Date de création : 15/06/2020.
Références de ce bulletin : CVE-2020-7598, openSUSE-SU-2020:0802-1, RHSA-2020:2847-01, RHSA-2020:2848-01, RHSA-2020:2849-01, RHSA-2020:2852-01, RHSA-2020:2895-01, RHSA-2020:3042-01, RHSA-2020:3084-01, SUSE-SU-2020:1623-1, SUSE-SU-2020:2800-1, VIGILANCE-VUL-32538.

Description de la vulnérabilité 

Un attaquant peut provoquer une erreur fatale via Prototype Pollution de Node.js minimist, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette menace cybersécurité concerne les logiciels ou systèmes comme Nodejs Modules ~ non exhaustif, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES.

Notre équipe Vigil@nce a déterminé que la gravité de ce bulletin de menace informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client intranet.

Un démonstrateur ou un outil d'attaque est disponible, donc vos équipes doivent traiter cette alerte. Un attaquant avec un niveau de compétence technicien peut exploiter cette vulnérabilité cybersécurité.

Solutions pour cette menace 

Node.js minimist : version 1.2.3.
La version 1.2.3 est corrigée :
  https://www.npmjs.com/package/minimist

openSUSE Leap 15.1 : nouveaux paquetages nodejs8.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.1 : nodejs8 8.17.0-lp151.2.15.1

RHEL 7 : nouveaux paquetages rh-nodejs10-nodejs.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.8 : rh-nodejs10-nodejs 10.21.0-3.el7

RHEL 7 : nouveaux paquetages rh-nodejs12-nodejs.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.8 : rh-nodejs12-nodejs 12.18.2-1.el7

RHEL 8.0 : nouveau module nodejs-10.
Le module suivant est mis à jour :
  RHEL 8.0 Module : nodejs:10

RHEL 8.1 : nouveau module nodejs-10.
Le module suivant est mis à jour :
  RHEL 8.1 Module : nodejs:10

RHEL 8.1 : nouveau module nodejs-12.
Le module suivant est mis à jour :
  RHEL 8.1 Module : nodejs:12

RHEL 8.2 : nouveau module nodejs-10.
Le module suivant est mis à jour :
  RHEL 8.2 Module : nodejs:10

RHEL 8.2 : nouveau module nodejs-12.
Le module suivant est mis à jour :
  RHEL 8.2 Module : nodejs:12

SUSE LE 12 : nouveaux paquetages nodejs6.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 RTM : nodejs6 6.17.1-11.37.1

SUSE LE 15 SP2 : nouveaux paquetages nodejs8.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : nodejs8 8.17.0-10.3.1
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit des bulletins de vulnérabilités logicielles. La cellule de veille technologique suit les menaces sécurité qui ciblent le parc informatique.