L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Node.js npm-user-validate : surcharge via Regular Expression

Synthèse de la vulnérabilité 

Un attaquant peut provoquer une surcharge via Regular Expression de Node.js npm-user-validate, afin de mener un déni de service.
Produits impactés : Nodejs Modules ~ non exhaustif, RHEL.
Gravité de ce bulletin : 2/4.
Date de création : 19/10/2020.
Références de cette menace : CVE-2020-7754, GHSA-xgh6-85xh-479p, NPM-1572, RHSA-2021:0421-01, RHSA-2021:0485-01, RHSA-2021:0521-01, RHSA-2021:0548-01, RHSA-2021:0549-01, RHSA-2021:0551-01, VIGILANCE-VUL-33621.

Description de la vulnérabilité 

Un attaquant peut provoquer une surcharge via Regular Expression de Node.js npm-user-validate, afin de mener un déni de service.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette alerte de menace concerne les logiciels ou systèmes comme Nodejs Modules ~ non exhaustif, RHEL.

Notre équipe Vigil@nce a déterminé que la gravité de cette vulnérabilité cybersécurité est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de client intranet.

Un attaquant avec un niveau de compétence expert peut exploiter cette faille cybersécurité.

Solutions pour cette menace 

Node.js npm-user-validate : version 1.0.1.
La version 1.0.1 est corrigée :
  https://www.npmjs.com/package/npm-user-validate

RHEL 7 : nouveaux paquetages rh-nodejs10-nodejs.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.9 : rh-nodejs10-nodejs 10.23.1-2.el7

RHEL 7 : nouveaux paquetages rh-nodejs12-nodejs.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.9 : rh-nodejs12-nodejs 12.20.1-1.el7

RHEL 7 : nouveaux paquetages rh-nodejs14-nodejs.
De nouveaux paquetages sont disponibles :
  RHEL 7.0-7.9 : rh-nodejs14-nodejs 14.15.4-2.el7

RHEL 8 : nouveau module nodejs-10.
Le module suivant est mis à jour :
  RHEL 8 Module : nodejs:10

RHEL 8 : nouveau module nodejs-12.
Le module suivant est mis à jour :
  RHEL 8 Module : nodejs:12

RHEL 8 : nouveau module nodejs-14.
Le module suivant est mis à jour :
  RHEL 8 Module : nodejs:14
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une annonce de vulnérabilité de réseau. Le service de veille sur les vulnérabilités informatiques Vigil@nce alerte vos équipes des failles et des menaces qui concernent votre système d'information.