L'équipe Vigil@nce veille les vulnérabilités publiques qui affectent votre parc informatique, puis propose des correctifs sécurité, une base de données de vigilance et des outils pour y remédier.

Vulnérabilité de Noyau Linux : accès en écriture via get_user_pages

Synthèse de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès via get_user_pages() du noyau Linux, afin de modifier des données.
Logiciels vulnérables : Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Gravité de cette annonce : 2/4.
Date de création : 30/11/2020.
Références de cette vulnérabilité informatique : CERTFR-2021-AVI-149, CERTFR-2021-AVI-185, CERTFR-2021-AVI-264, CERTFR-2021-AVI-278, CVE-2020-29374, openSUSE-SU-2021:0393-1, PROJ-ZERO-2045, SUSE-SU-2021:0735-1, SUSE-SU-2021:0736-1, SUSE-SU-2021:0737-1, SUSE-SU-2021:0738-1, SUSE-SU-2021:0740-1, SUSE-SU-2021:0741-1, SUSE-SU-2021:1175-1, SUSE-SU-2021:1176-1, SUSE-SU-2021:1210-1, USN-4748-1, USN-4749-1, VIGILANCE-VUL-33997.

Description de la vulnérabilité 

Un attaquant peut contourner les restrictions d'accès via get_user_pages() du noyau Linux, afin de modifier des données.
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Cette vulnérabilité concerne les logiciels ou systèmes comme Linux, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Notre équipe Vigil@nce a déterminé que la gravité de cet avis de vulnérabilité informatique est moyen.

Le niveau de confiance est de type confirmé par l'éditeur, avec une provenance de shell utilisateur.

Un attaquant avec un niveau de compétence expert peut exploiter cette alerte cyber-sécurité.

Solutions pour cette menace 

Noyau Linux : version 5.7.3.
La version 5.7.3 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 5.6.19.
La version 5.6.19 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 5.4.47.
La version 5.4.47 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v5.x/

Noyau Linux : version 4.19.189.
La version 4.19.189 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.19.189.tar.xz

Noyau Linux : version 4.14.232.
La version 4.14.232 est corrigée :
  https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.14.232.tar.xz

Noyau Linux : patch pour get_user_pages.
Un patch est indiqué dans les sources d'information.

openSUSE Leap 15.2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  openSUSE Leap 15.2 : kernel 5.3.18-lp152.66.2

SUSE LE 12 SP4 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP4 : kernel 4.12.14-95.71.1

SUSE LE 12 SP5 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel 4.12.14-122.66.2

SUSE LE 12 SP5 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel-azure 4.12.14-16.50.1

SUSE LE 12 SP5 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 12 SP5 : kernel-rt 4.12.14-10.37.1

SUSE LE 15 RTM : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 RTM : kernel 4.12.14-150.69.1

SUSE LE 15 SP1 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP1 : kernel 4.12.14-197.86.1

SUSE LE 15 SP2 : nouveaux paquetages kernel.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel 5.3.18-24.52.1

SUSE LE 15 SP2 : nouveaux paquetages kernel-azure.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel-azure 5.3.18-18.38.1

SUSE LE 15 SP2 : nouveaux paquetages kernel-rt.
De nouveaux paquetages sont disponibles :
  SUSE LE 15 SP2 : kernel-rt 5.3.18-28.1

Ubuntu 14/16/18 : nouveaux paquetages linux-image-4.15.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 ESM : linux-image-azure 4.15.0.1108.81
  Ubuntu 16.04 LTS : linux-image-generic-hwe-16.04 4.15.0.136.132
  Ubuntu 18.04 LTS : linux-image-generic 4.15.0.136.123

Ubuntu 14/16 : nouveaux paquetages linux-image-4.4.0.
De nouveaux paquetages sont disponibles :
  Ubuntu 14.04 ESM : linux-image-generic-lts-xenial 4.4.0.203.177
  Ubuntu 16.04 LTS : linux-image-generic 4.4.0.203.209
Bulletin complet, filtrage par logiciel, emails, correctifs, ... (Demandez votre essai gratuit)

Service de veille sur les vulnérabilités informatiques 

Vigil@nce fournit une veille cyber-sécurité. Chaque administrateur peut personnaliser la liste des produits pour lesquels il souhaite recevoir des alertes de vulnérabilités.